]> git.pld-linux.org Git - packages/compiz.git/blob - compiz.spec
- 20060608
[packages/compiz.git] / compiz.spec
1 #
2 # Conditional build:
3 %bcond_without  gconf           # don't build gconf plugin
4 %bcond_without  gnome           # don't build gnome-window-decorator
5 %bcond_with     kde             # build kde-window-decorator (not working)
6 #
7 %define         _snap   20060608
8 #
9 Summary:        OpenGL window and compositing manager
10 Summary(pl):    OpenGL-owy zarz±dca okien i sk³adania
11 Name:           compiz
12 Version:        0.0.13
13 Release:        1.%{_snap}.1
14 License:        GPL/MIT
15 Group:          X11
16 Source0:        %{name}-%{_snap}.tar.bz2
17 # Source0-md5:  79b7329372ce4015c7e0ec226370cec6
18 Source1:        %{name}-pld.png
19 # Source1-md5:  3050dc90fd4e5e990bb5baeb82bd3c8a
20 Patch0:         %{name}-minimize-scaler-mod.patch
21 %if %{with gconf} || %{with gnome}
22 BuildRequires:  GConf2-devel >= 2.0
23 %endif
24 BuildRequires:  Mesa-libGL-devel >= 6.5-1.20060411.2
25 BuildRequires:  autoconf >= 2.57
26 BuildRequires:  automake
27 BuildRequires:  fam-devel
28 BuildRequires:  glib2-devel >= 2.0
29 BuildRequires:  glitz-devel
30 BuildRequires:  intltool
31 BuildRequires:  libpng-devel
32 BuildRequires:  libsvg-cairo-devel
33 BuildRequires:  libtool
34 BuildRequires:  pkgconfig
35 BuildRequires:  startup-notification-devel >= 0.7
36 BuildRequires:  xorg-lib-libSM-devel
37 BuildRequires:  xorg-lib-libXcomposite-devel
38 BuildRequires:  xorg-lib-libXdamage-devel
39 BuildRequires:  xorg-lib-libXrandr-devel
40 BuildRequires:  xorg-lib-libXres-devel
41 %if %{with gnome}
42 BuildRequires:  control-center-devel >= 2.0
43 BuildRequires:  gnome-desktop-devel >= 2.0
44 BuildRequires:  gnome-menus-devel
45 BuildRequires:  gtk+2-devel >= 2:2.8.0
46 BuildRequires:  libwnck-devel >= 2.14.1-2
47 %endif
48 %if %{with kde}
49 BuildRequires:  QtCore-devel
50 BuildRequires:  QtGui-devel
51 BuildRequires:  qt4-build
52 %endif
53 Requires(post,preun):   GConf2
54 Conflicts:      xorg-xserver-xgl < 0.0.20060505
55 Obsoletes:      compiz-opacity
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %description
59 Compiz is an OpenGL compositing manager that use
60 GLX_EXT_texture_from_pixmap for binding redirected top-level windows
61 to texture objects. It has a flexible plug-in system and it is
62 designed to run well on most graphics hardware.
63
64 %description -l pl
65 Compiz jest OpenGL-owym zarz±dc± sk³adania, u¿ywaj±cym rozszerzenia
66 GLX_EXT_texture_from_pixmap w celu wi±zania przekierowanych okien do
67 tekstur. Posiada elastyczny system wtyczek i jest tak zaprojektowany,
68 by dobrze dzia³aæ na wiêkszo¶ci kart graficznych.
69
70 %package devel
71 Summary:        Header files for compiz
72 Summary(pl):    Pliki nag³ówkowe dla compiza
73 Group:          Development
74 # (by compiz.pc; header requires only: OpenGL-devel, startup-notification-devel, damageproto, xextproto, libX11-devel)
75 Requires:       OpenGL-devel
76 Requires:       libpng-devel
77 Requires:       startup-notification-devel >= 0.7
78 Requires:       xorg-lib-libSM-devel
79 Requires:       xorg-lib-libXcomposite-devel
80 Requires:       xorg-lib-libXdamage-devel
81 Requires:       xorg-lib-libXrandr-devel
82
83 %description devel
84 Header files for compiz.
85
86 %description devel -l pl
87 Pliki nag³ówkowe dla compiza.
88
89 %package gnome-settings
90 Summary:        Compiz settings for gnome control panel
91 Summary(pl):    Ustawienia compiza dla panelu sterowania gnome
92 Group:          X11
93 Requires:       %{name} = %{version}-%{release}
94
95 %description gnome-settings
96 Compiz settings for gnome control panel.
97
98 %description gnome-settings -l pl
99 Ustawienia compiza dla panelu sterowania gnome.
100
101 %package gnome-decorator
102 Summary:        Window decorator for gnome
103 Summary(pl):    Dekorator okien dla gnome
104 Group:          X11
105 Requires:       %{name} = %{version}-%{release}
106
107 %description gnome-decorator
108 Window decorator for gnome.
109
110 %description gnome-decorator -l pl
111 Dekorator okien dla gnome.
112
113 %package kde-decorator
114 Summary:        Window decorator for KDE
115 Summary(pl):    Dekorator okien dla KDE
116 Group:          X11
117 Requires:       %{name} = %{version}-%{release}
118
119 %description kde-decorator
120 Window decorator for KDE.
121
122 %description kde-decorator -l pl
123 Dekorator okien dla KDE.
124
125 %prep
126 %setup -q -n %{name}-%{_snap}
127 # doesn't apply anymore
128 #%patch0 -p0
129
130 %build
131 autoreconf -v --install
132 ln -s ../po config/po
133 %{__intltoolize}
134 rm config/po
135 sed -i -e 's/^mkinstalldirs.*/MKINSTALLDIRS=mkdir -p/' po/Makefile.in.in
136
137 %configure \
138         --disable-static \
139         --enable-svg \
140         --enable-libsvg-cairo \
141         %{!?with_gconf:--disable-gconf} \
142         --%{?with_gnome:en}%{!?with_gnome:dis}able-gnome \
143         --%{?with_kde:en}%{!?with_kde:dis}able-kde
144
145 %{__make}
146
147 %install
148 rm -rf $RPM_BUILD_ROOT
149
150 %{__make} install \
151         desktopfilesdir=%{_datadir}/wm-properties \
152         DESTDIR=$RPM_BUILD_ROOT
153
154 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/compiz/novell.png
155
156 rm -f $RPM_BUILD_ROOT%{_libdir}/compiz/*.la
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %post
162 %gconf_schema_install compiz.schemas
163
164 %preun
165 %gconf_schema_uninstall compiz.schemas
166
167 %files
168 %defattr(644,root,root,755)
169 %doc AUTHORS ChangeLog README TODO
170 %attr(755,root,root) %{_bindir}/compiz
171 %dir %{_libdir}/compiz
172 %attr(755,root,root) %{_libdir}/compiz/*.so
173 %{_datadir}/compiz
174 %if %{with gnome}
175 %{_datadir}/wm-properties/*
176 %endif
177 %{_sysconfdir}/gconf/schemas/compiz.schemas
178
179 %files devel
180 %defattr(644,root,root,755)
181 %{_includedir}/compiz
182 %{_pkgconfigdir}/compiz.pc
183
184 %if %{with gnome}
185 %files gnome-settings
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_libdir}/window-manager-settings/*.so
188
189 %files gnome-decorator
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_bindir}/gnome-window-decorator
192 %endif
193
194 %if %{with kde}
195 %files kde-decorator
196 %defattr(644,root,root,755)
197 %attr(755,root,root) %{_bindir}/kde-window-decorator
198 %endif
This page took 0.047393 seconds and 3 git commands to generate.