]> git.pld-linux.org Git - packages/compiz.git/blob - compiz.spec
- 20060602
[packages/compiz.git] / compiz.spec
1 #
2 # Conditional build:
3 %bcond_without  gconf           # don't build gconf plugin
4 %bcond_without  gnome           # don't build gnome-window-decorator
5 %bcond_with     kde             # build kde-window-decorator (not working)
6 #
7 %define         _snap   20060602
8 #
9 Summary:        OpenGL window and compositing manager
10 Summary(pl):    OpenGL-owy zarz±dca okien i sk³adania
11 Name:           compiz
12 Version:        0.0.11
13 Release:        1.%{_snap}.1
14 License:        GPL/MIT
15 Group:          X11
16 Source0:        %{name}-%{_snap}.tar.bz2
17 # Source0-md5:  b71bb228ddee511f16278916d26570a7
18 Source1:        %{name}-pld.png
19 # Source1-md5:  3050dc90fd4e5e990bb5baeb82bd3c8a
20 Patch0:         %{name}-minimize-scaler-mod.patch
21 %if %{with gconf} || %{with gnome}
22 BuildRequires:  GConf2-devel >= 2.0
23 %endif
24 BuildRequires:  Mesa-libGL-devel >= 6.5-1.20060411.2
25 BuildRequires:  autoconf >= 2.57
26 BuildRequires:  automake
27 BuildRequires:  glib2-devel >= 2.0
28 BuildRequires:  glitz-devel
29 BuildRequires:  intltool
30 BuildRequires:  libpng-devel
31 BuildRequires:  libsvg-cairo-devel
32 BuildRequires:  libtool
33 BuildRequires:  pkgconfig
34 BuildRequires:  startup-notification-devel >= 0.7
35 BuildRequires:  xorg-lib-libSM-devel
36 BuildRequires:  xorg-lib-libXcomposite-devel
37 BuildRequires:  xorg-lib-libXdamage-devel
38 BuildRequires:  xorg-lib-libXrandr-devel
39 BuildRequires:  xorg-lib-libXres-devel
40 %if %{with gnome}
41 BuildRequires:  control-center-devel >= 2.0
42 BuildRequires:  gnome-desktop-devel >= 2.0
43 BuildRequires:  gnome-menus-devel
44 BuildRequires:  gtk+2-devel >= 2:2.8.0
45 BuildRequires:  libwnck-devel >= 2.14.1-2
46 %endif
47 %if %{with kde}
48 BuildRequires:  QtCore-devel
49 BuildRequires:  QtGui-devel
50 BuildRequires:  qt4-build
51 %endif
52 Requires(post,preun):   GConf2
53 Conflicts:      xorg-xserver-xgl < 0.0.20060505
54 Obsoletes:      compiz-opacity
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 Compiz is an OpenGL compositing manager that use
59 GLX_EXT_texture_from_pixmap for binding redirected top-level windows
60 to texture objects. It has a flexible plug-in system and it is
61 designed to run well on most graphics hardware.
62
63 %description -l pl
64 Compiz jest OpenGL-owym zarz±dc± sk³adania, u¿ywaj±cym rozszerzenia
65 GLX_EXT_texture_from_pixmap w celu wi±zania przekierowanych okien do
66 tekstur. Posiada elastyczny system wtyczek i jest tak zaprojektowany,
67 by dobrze dzia³aæ na wiêkszo¶ci kart graficznych.
68
69 %package devel
70 Summary:        Header files for compiz
71 Summary(pl):    Pliki nag³ówkowe dla compiza
72 Group:          Development
73 # (by compiz.pc; header requires only: OpenGL-devel, startup-notification-devel, damageproto, xextproto, libX11-devel)
74 Requires:       OpenGL-devel
75 Requires:       libpng-devel
76 Requires:       startup-notification-devel >= 0.7
77 Requires:       xorg-lib-libSM-devel
78 Requires:       xorg-lib-libXcomposite-devel
79 Requires:       xorg-lib-libXdamage-devel
80 Requires:       xorg-lib-libXrandr-devel
81
82 %description devel
83 Header files for compiz.
84
85 %description devel -l pl
86 Pliki nag³ówkowe dla compiza.
87
88 %package gnome-settings
89 Summary:        Compiz settings for gnome control panel
90 Summary(pl):    Ustawienia compiza dla panelu sterowania gnome
91 Group:          X11
92 Requires:       %{name} = %{version}-%{release}
93
94 %description gnome-settings
95 Compiz settings for gnome control panel.
96
97 %description gnome-settings -l pl
98 Ustawienia compiza dla panelu sterowania gnome.
99
100 %package gnome-decorator
101 Summary:        Window decorator for gnome
102 Summary(pl):    Dekorator okien dla gnome
103 Group:          X11
104 Requires:       %{name} = %{version}-%{release}
105
106 %description gnome-decorator
107 Window decorator for gnome.
108
109 %description gnome-decorator -l pl
110 Dekorator okien dla gnome.
111
112 %package kde-decorator
113 Summary:        Window decorator for KDE
114 Summary(pl):    Dekorator okien dla KDE
115 Group:          X11
116 Requires:       %{name} = %{version}-%{release}
117
118 %description kde-decorator
119 Window decorator for KDE.
120
121 %description kde-decorator -l pl
122 Dekorator okien dla KDE.
123
124 %prep
125 %setup -q -n %{name}-%{_snap}
126 # doesn't apply anymore
127 #%patch0 -p0
128
129 %build
130 autoreconf -v --install
131 ln -s ../po config/po
132 %{__intltoolize}
133 rm config/po
134 sed -i -e 's/^mkinstalldirs.*/MKINSTALLDIRS=mkdir -p/' po/Makefile.in.in
135
136 %configure \
137         --disable-static \
138         --enable-svg \
139         --enable-libsvg-cairo \
140         %{!?with_gconf:--disable-gconf} \
141         --%{?with_gnome:en}%{!?with_gnome:dis}able-gnome \
142         --%{?with_kde:en}%{!?with_kde:dis}able-kde
143
144 %{__make}
145
146 %install
147 rm -rf $RPM_BUILD_ROOT
148
149 %{__make} install \
150         DESTDIR=$RPM_BUILD_ROOT
151
152 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/compiz/novell.png
153
154 rm -f $RPM_BUILD_ROOT%{_libdir}/compiz/*.la
155
156 %clean
157 rm -rf $RPM_BUILD_ROOT
158
159 %post
160 %gconf_schema_install compiz.schemas
161
162 %preun
163 %gconf_schema_uninstall compiz.schemas
164
165 %files
166 %defattr(644,root,root,755)
167 %doc AUTHORS ChangeLog README TODO
168 %attr(755,root,root) %{_bindir}/compiz
169 %dir %{_libdir}/compiz
170 %attr(755,root,root) %{_libdir}/compiz/*.so
171 %{_datadir}/compiz
172 %if %{with gnome}
173 %{_datadir}/gnome/wm-properties/*
174 %endif
175 %{_sysconfdir}/gconf/schemas/compiz.schemas
176
177 %files devel
178 %defattr(644,root,root,755)
179 %{_includedir}/compiz
180 %{_pkgconfigdir}/compiz.pc
181
182 %if %{with gnome}
183 %files gnome-settings
184 %defattr(644,root,root,755)
185 %attr(755,root,root) %{_libdir}/window-manager-settings/*.so
186
187 %files gnome-decorator
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{_bindir}/gnome-window-decorator
190 %endif
191
192 %if %{with kde}
193 %files kde-decorator
194 %defattr(644,root,root,755)
195 %attr(755,root,root) %{_bindir}/kde-window-decorator
196 %endif
This page took 0.060028 seconds and 3 git commands to generate.