]> git.pld-linux.org Git - packages/compiz-fusion-icon.git/blob - compiz-fusion-icon.spec
BR: rpmbuild(macros) >= 1.710
[packages/compiz-fusion-icon.git] / compiz-fusion-icon.spec
1 %define         subver  080712git
2 %define         _name   fusion-icon
3 %define         rel             6
4 Summary:        Small program to control your GL Desktop
5 Summary(pl.UTF-8):      Mały program do kontroli pulpitu GL
6 Name:           compiz-%{_name}
7 Version:        0.1.0
8 Release:        0.%{subver}.%{rel}
9 Epoch:          1
10 License:        GPL v2+
11 Group:          X11/Window Managers/Tools
12 # It's from git://anongit.compiz-fusion.org/users/crdlb/fusion-icon
13 Source0:        %{_name}-%{subver}.tar.bz2
14 # Source0-md5:  767c3ec198b780eb83656c48f92add1d
15 URL:            http://compiz-fusion.org/
16 BuildRequires:  python-devel >= 1:2.5
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.710
19 Requires(post,postun):  gtk-update-icon-cache
20 Requires(post,postun):  hicolor-icon-theme
21 Requires:       %{name}-interface = %{epoch}:%{version}-%{release}
22 Requires:       compiz >= 0.5.1
23 Requires:       python-compizconfig
24 Requires:       xorg-app-xvinfo
25 Suggests:       ccsm
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Compiz Fusion Icon is a small program written in Python which lets you
31 control your GL Desktop it handles your different decorators
32 (non-GL/GL) and configurators.
33
34 %description -l pl.UTF-8
35 Compiz Fusion Icon jest małym programem napisanym w Pythonie, który
36 pozwala na kontrolę pulpitu GL. Obsługuje różne dekoratory (GL/nie-GL)
37 i konfiguratory.
38
39 %package interface-gtk
40 Summary:        GTK+ interface for Compiz Fusion Icon
41 Summary(pl.UTF-8):      Compiz Fusion Icon - interfejs GTK+
42 Group:          X11/Window Managers/Tools
43 Requires:       %{name} = %{epoch}:%{version}-%{release}
44 Requires:       python-pygtk-gtk >= 2:2.10.0
45 Suggests:       compizconfig-backend-gconf
46 Provides:       %{name}-interface = %{epoch}:%{version}-%{release}
47
48 %description interface-gtk
49 GTK+ interface for Compiz Fusion Icon.
50
51 %description interface-gtk -l pl.UTF-8
52 Compiz Fusion Icon - interfejs GTK+.
53
54 %package interface-qt4
55 Summary:        Qt4 interface for Compiz Fusion Icon
56 Summary(pl.UTF-8):      Compiz Fusion Icon - interfejs Qt4+
57 Group:          X11/Window Managers/Tools
58 Requires:       %{name} = %{epoch}:%{version}-%{release}
59 Requires:       python-PyQt4
60 Suggests:       compizconfig-backend-kconfig
61 Provides:       %{name}-interface = %{epoch}:%{version}-%{release}
62
63 %description interface-qt4
64 Qt4 interface for Compiz Fusion Icon.
65
66 %description interface-qt4 -l pl.UTF-8
67 Compiz Fusion Icon - interfejs Qt4.
68
69 %prep
70 %setup -q -n %{_name}
71
72 %build
73 %py_build
74 %{__make}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %py_install \
80         -O1 \
81         --skip-build \
82         --root $RPM_BUILD_ROOT
83
84 %py_postclean
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %post
90 %update_icon_cache hicolor
91
92 %postun
93 %update_icon_cache hicolor
94
95 %files
96 %defattr(644,root,root,755)
97 %attr(755,root,root) %{_bindir}/fusion-icon
98 %{_desktopdir}/fusion-icon.desktop
99 %dir %{py_sitescriptdir}/FusionIcon
100 %{py_sitescriptdir}/FusionIcon/*.py[co]
101 %{py_sitescriptdir}/fusion_icon-*.egg-info
102 %{_iconsdir}/hicolor/*x*/apps/fusion-icon.png
103 %{_iconsdir}/hicolor/scalable/apps/fusion-icon.svg
104
105 %files interface-gtk
106 %defattr(644,root,root,755)
107 %dir %{py_sitescriptdir}/FusionIcon/interface_gtk
108 %{py_sitescriptdir}/FusionIcon/interface_gtk/*.py[co]
109
110 %files interface-qt4
111 %defattr(644,root,root,755)
112 %dir %{py_sitescriptdir}/FusionIcon/interface_qt4
113 %{py_sitescriptdir}/FusionIcon/interface_qt4/*.py[co]
This page took 0.108499 seconds and 3 git commands to generate.