]> git.pld-linux.org Git - packages/commoncpp2.git/blob - commoncpp2.spec
- up to 1.6.3
[packages/commoncpp2.git] / commoncpp2.spec
1 Summary:        A GNU package for creating portable C++ programs
2 Summary(pl.UTF-8):      Pakiet GNU do tworzenia przenośnych programów w C++
3 Name:           commoncpp2
4 Version:        1.6.3
5 Release:        1
6 License:        GPL
7 Group:          Libraries
8 Source0:        ftp://ftp.gnu.org/pub/gnu/commoncpp/%{name}-%{version}.tar.gz
9 # Source0-md5:  f4238f9f2bba5b643238c2b0b42ef797
10 Patch0:         %{name}-lt.patch
11 URL:            http://www.gnu.org/software/commoncpp/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  doxygen
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  libtool
17 BuildRequires:  libxml2-devel
18 BuildRequires:  openssl-devel
19 BuildRequires:  zlib-devel
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This is the second major release of GNU Common C++. GNU Common C++ "2"
24 is a GNU package which offers portable "abstraction" of system
25 services such as threads, networks, and sockets. GNU Common C++ "2"
26 also offers individual frameworks generally useful to developing
27 portable C++ applications including a object persistance engine, math
28 libraries, threading, sockets, etc. GNU Common C++ "2" is small, and
29 highly portable. GNU Common C++ "2" will support most Unix operating
30 systems as well as Win32, in addition to GNU/Linux.
31
32 %description -l pl.UTF-8
33 Drugie główne wydanie GNU Common C++. GNU Common C++ oferuje przenośne
34 abstrakcje usług systemowych takich jak wątki, sieci i gniazda.
35 Oferuje także poszczególne szkielety użyteczne do rozwijania
36 przenośnych aplikacji C++ zawierające silnik trwałych obiektów,
37 biblioteki matematyczne, wątków, gniazd itd. GNU Common C++ jest mały
38 i przenośny. Oprócz GNU/Linuksa obsługuje także większość uniksowych
39 systemów operacyjnych oraz Win32.
40
41 %package devel
42 Summary:        Header files for commoncpp2 library
43 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki commoncpp2
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       libstdc++-devel
47 Requires:       libxml2-devel
48 Requires:       zlib-devel
49
50 %description devel
51 Header files for commoncpp2 library.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe biblioteki commoncpp2.
55
56 %package static
57 Summary:        Static commoncpp2 library
58 Summary(pl.UTF-8):      Statyczna biblioteka commoncpp2
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static commoncpp2 library.
64
65 %description static -l pl.UTF-8
66 Statyczna biblioteka commoncpp2.
67
68 %prep
69 %setup -q
70 %patch0 -p1
71
72 %build
73 %{__libtoolize}
74 %{__aclocal} -I m4
75 %{__autoconf}
76 %{__autoheader}
77 %{__automake}
78 %configure \
79         --with-openssl
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 %{__make} install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post   -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %post devel     -p      /sbin/postshell
95 -/usr/sbin/fix-info-dir -c %{_infodir}
96
97 %postun devel   -p      /sbin/postshell
98 -/usr/sbin/fix-info-dir -c %{_infodir}
99
100 %files
101 %defattr(644,root,root,755)
102 %doc AUTHORS COPYING.addendum NEWS README TODO ChangeLog
103 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
104 %ghost %{_libdir}/libccext2-1.6.so.0
105 %ghost %{_libdir}/libccgnu2-1.6.so.0
106
107 %files devel
108 %defattr(644,root,root,755)
109 %doc doc/html/*.html doc/html/*.*g*
110 %attr(755,root,root) %{_bindir}/*
111 %attr(755,root,root) %{_libdir}/lib*.so
112 %{_libdir}/lib*.la
113 %{_includedir}/cc++
114 %{_aclocaldir}/*.m4
115 %{_pkgconfigdir}/*.pc
116 %{_infodir}/*.info*
117
118 %files static
119 %defattr(644,root,root,755)
120 %{_libdir}/lib*.a
This page took 0.135888 seconds and 3 git commands to generate.