]> git.pld-linux.org Git - packages/commoncpp2.git/blob - commoncpp2.spec
- up to 1.5.3
[packages/commoncpp2.git] / commoncpp2.spec
1 Summary:        A GNU package for creating portable C++ programs
2 Summary(pl):    Pakiet GNU do tworzenia przeno¶nych programów w C++
3 Name:           commoncpp2
4 Version:        1.5.3
5 Release:        1
6 License:        GPL
7 Group:          Libraries
8 Source0:        ftp://ftp.gnu.org/pub/gnu/commoncpp/%{name}-%{version}.tar.gz
9 # Source0-md5:  559c6cb2e1fbbaa6d1856d037e3722b2
10 Patch0:         %{name}-Makefile.patch
11 URL:            http://www.gnu.org/software/commoncpp/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  doxygen
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  libxml2-devel
17 BuildRequires:  openssl-devel
18 BuildRequires:  zlib-devel
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This is the second major release of GNU Common C++. GNU Common C++ "2"
23 is a GNU package which offers portable "abstraction" of system
24 services such as threads, networks, and sockets. GNU Common C++ "2"
25 also offers individual frameworks generally useful to developing
26 portable C++ applications including a object persistance engine, math
27 libraries, threading, sockets, etc. GNU Common C++ "2" is small, and
28 highly portable. GNU Common C++ "2" will support most Unix operating
29 systems as well as Win32, in addition to GNU/Linux.
30
31 %description -l pl
32 Drugie g³ówne wydanie GNU Common C++. GNU Common C++ oferuje przeno¶ne
33 abstrakcje us³ug systemowych takich jak w±tki, sieci i gniazda.
34 Oferuje tak¿e poszczególne szkielety u¿yteczne do rozwijania
35 przeno¶nych aplikacji C++ zawieraj±ce silnik trwa³ych obiektów,
36 biblioteki matematyczne, w±tków, gniazd itd. GNU Common C++ jest ma³y
37 i przeno¶ny. Oprócz GNU/Linuksa obs³uguje tak¿e wiêkszo¶æ uniksowych
38 systemów operacyjnych oraz Win32.
39
40 %package devel
41 Summary:        Header files for commoncpp2 library
42 Summary(pl):    Pliki nag³ówkowe biblioteki commoncpp2
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       libstdc++-devel
46 Requires:       libxml2-devel
47 Requires:       zlib-devel
48
49 %description devel
50 Header files for commoncpp2 library.
51
52 %description devel -l pl
53 Pliki nag³ówkowe biblioteki commoncpp2.
54
55 %package static
56 Summary:        Static commoncpp2 library
57 Summary(pl):    Statyczna biblioteka commoncpp2
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 Static commoncpp2 library.
63
64 %description static -l pl
65 Statyczna biblioteka commoncpp2.
66
67 %prep
68 %setup -q
69 %patch0 -p1
70
71 %build
72 %{__aclocal} -I m4
73 %{__automake}
74 %{__autoconf}
75 %configure \
76         --with-openssl
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__make} install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %post   -p /sbin/ldconfig
89 %postun -p /sbin/ldconfig
90
91 %post devel
92 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
93
94 %postun devel
95 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
96
97 %files
98 %defattr(644,root,root,755)
99 %doc AUTHORS COPYING.addendum NEWS README TODO ChangeLog
100 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
101
102 %files devel
103 %defattr(644,root,root,755)
104 %doc doc/html/*.html doc/html/*.*g*
105 %attr(755,root,root) %{_bindir}/*
106 %attr(755,root,root) %{_libdir}/lib*.so
107 %{_libdir}/lib*.la
108 %{_includedir}/cc++
109 %{_aclocaldir}/*.m4
110 %{_pkgconfigdir}/*.pc
111 %{_infodir}/*.info*
112
113 %files static
114 %defattr(644,root,root,755)
115 %{_libdir}/lib*.a
This page took 0.096416 seconds and 3 git commands to generate.