]> git.pld-linux.org Git - packages/commoncpp2.git/blob - commoncpp2.spec
- added gcc4.patch
[packages/commoncpp2.git] / commoncpp2.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        A GNU package for creating portable C++ programs
6 Summary(pl.UTF-8):      Pakiet GNU do tworzenia przenośnych programów w C++
7 Name:           commoncpp2
8 Version:        1.7.3
9 Release:        1
10 License:        GPL
11 Group:          Libraries
12 Source0:        http://ftp.gnu.org/gnu/commoncpp/%{name}-%{version}.tar.gz
13 # Source0-md5:  ca741179a728d264eb276ae471ebaf70
14 Patch0:         %{name}-lt.patch
15 Patch1:         %{name}-gcc4.patch
16 URL:            http://www.gnu.org/software/commoncpp/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  doxygen
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  libtool
22 BuildRequires:  libxml2-devel
23 BuildRequires:  openssl-devel
24 BuildRequires:  zlib-devel
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This is the second major release of GNU Common C++. GNU Common C++ "2"
29 is a GNU package which offers portable "abstraction" of system
30 services such as threads, networks, and sockets. GNU Common C++ "2"
31 also offers individual frameworks generally useful to developing
32 portable C++ applications including a object persistance engine, math
33 libraries, threading, sockets, etc. GNU Common C++ "2" is small, and
34 highly portable. GNU Common C++ "2" will support most Unix operating
35 systems as well as Win32, in addition to GNU/Linux.
36
37 %description -l pl.UTF-8
38 Drugie główne wydanie GNU Common C++. GNU Common C++ oferuje przenośne
39 abstrakcje usług systemowych takich jak wątki, sieci i gniazda.
40 Oferuje także poszczególne szkielety użyteczne do rozwijania
41 przenośnych aplikacji C++ zawierające silnik trwałych obiektów,
42 biblioteki matematyczne, wątków, gniazd itd. GNU Common C++ jest mały
43 i przenośny. Oprócz GNU/Linuksa obsługuje także większość uniksowych
44 systemów operacyjnych oraz Win32.
45
46 %package devel
47 Summary:        Header files for commoncpp2 library
48 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki commoncpp2
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       libstdc++-devel
52 Requires:       libxml2-devel
53 Requires:       openssl-devel
54 Requires:       zlib-devel
55
56 %description devel
57 Header files for commoncpp2 library.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe biblioteki commoncpp2.
61
62 %package static
63 Summary:        Static commoncpp2 library
64 Summary(pl.UTF-8):      Statyczna biblioteka commoncpp2
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67
68 %description static
69 Static commoncpp2 library.
70
71 %description static -l pl.UTF-8
72 Statyczna biblioteka commoncpp2.
73
74 %prep
75 %setup -q
76 %patch0 -p1
77 %patch1 -p1
78
79 %build
80 %{__libtoolize}
81 %{__aclocal} -I m4
82 %{__autoconf}
83 %{__autoheader}
84 %{__automake}
85 %configure \
86         %{!?with_static_libs:--disable-static} \
87         --with-openssl
88 %{__make} -j1
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92
93 %{__make} install \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post   -p /sbin/ldconfig
100 %postun -p /sbin/ldconfig
101
102 %post devel     -p      /sbin/postshell
103 -/usr/sbin/fix-info-dir -c %{_infodir}
104
105 %postun devel   -p      /sbin/postshell
106 -/usr/sbin/fix-info-dir -c %{_infodir}
107
108 %files
109 %defattr(644,root,root,755)
110 %doc AUTHORS COPYING.addendum NEWS README TODO ChangeLog
111 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
112 %ghost %{_libdir}/libccext2-1.7.so.0
113 %ghost %{_libdir}/libccgnu2-1.7.so.0
114
115 %files devel
116 %defattr(644,root,root,755)
117 %doc doc/html/*.html doc/html/*.*g*
118 %attr(755,root,root) %{_bindir}/*
119 %attr(755,root,root) %{_libdir}/lib*.so
120 %{_libdir}/lib*.la
121 %{_includedir}/cc++
122 %{_aclocaldir}/*.m4
123 %{_pkgconfigdir}/*.pc
124 %{_infodir}/*.info*
125
126 %if %{with static_libs}
127 %files static
128 %defattr(644,root,root,755)
129 %{_libdir}/lib*.a
130 %endif
This page took 0.119353 seconds and 3 git commands to generate.