]> git.pld-linux.org Git - packages/commoncpp2.git/blame - commoncpp2.spec
- added gcc4.patch
[packages/commoncpp2.git] / commoncpp2.spec
CommitLineData
e5703f90
KK
1#
2# Conditional build:
3%bcond_without static_libs # don't build static library
4#
3ef9580c 5Summary: A GNU package for creating portable C++ programs
8c8acc7d 6Summary(pl.UTF-8): Pakiet GNU do tworzenia przenośnych programów w C++
3ef9580c 7Name: commoncpp2
5188bc31 8Version: 1.7.3
54a4a4fa 9Release: 1
3ef9580c 10License: GPL
11Group: Libraries
9cfec48b 12Source0: http://ftp.gnu.org/gnu/commoncpp/%{name}-%{version}.tar.gz
5188bc31 13# Source0-md5: ca741179a728d264eb276ae471ebaf70
7a5c4ef4 14Patch0: %{name}-lt.patch
54a4a4fa 15Patch1: %{name}-gcc4.patch
7c7445ba 16URL: http://www.gnu.org/software/commoncpp/
4a331386 17BuildRequires: autoconf
7c7445ba 18BuildRequires: automake
3ef9580c 19BuildRequires: doxygen
20BuildRequires: libstdc++-devel
e131c2a8 21BuildRequires: libtool
3ef9580c 22BuildRequires: libxml2-devel
4a331386 23BuildRequires: openssl-devel
3ef9580c 24BuildRequires: zlib-devel
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%description
28This is the second major release of GNU Common C++. GNU Common C++ "2"
29is a GNU package which offers portable "abstraction" of system
30services such as threads, networks, and sockets. GNU Common C++ "2"
31also offers individual frameworks generally useful to developing
32portable C++ applications including a object persistance engine, math
33libraries, threading, sockets, etc. GNU Common C++ "2" is small, and
34highly portable. GNU Common C++ "2" will support most Unix operating
1abd0668 35systems as well as Win32, in addition to GNU/Linux.
3ef9580c 36
06c607b2
JR
37%description -l pl.UTF-8
38Drugie główne wydanie GNU Common C++. GNU Common C++ oferuje przenośne
39abstrakcje usług systemowych takich jak wątki, sieci i gniazda.
40Oferuje także poszczególne szkielety użyteczne do rozwijania
41przenośnych aplikacji C++ zawierające silnik trwałych obiektów,
42biblioteki matematyczne, wątków, gniazd itd. GNU Common C++ jest mały
43i przenośny. Oprócz GNU/Linuksa obsługuje także większość uniksowych
44systemów operacyjnych oraz Win32.
17bc0025 45
3ef9580c 46%package devel
47Summary: Header files for commoncpp2 library
8c8acc7d 48Summary(pl.UTF-8): Pliki nagłówkowe biblioteki commoncpp2
3ef9580c 49Group: Development/Libraries
50Requires: %{name} = %{version}-%{release}
51Requires: libstdc++-devel
52Requires: libxml2-devel
e5703f90 53Requires: openssl-devel
3ef9580c 54Requires: zlib-devel
55
56%description devel
57Header files for commoncpp2 library.
58
06c607b2
JR
59%description devel -l pl.UTF-8
60Pliki nagłówkowe biblioteki commoncpp2.
3ef9580c 61
62%package static
63Summary: Static commoncpp2 library
8c8acc7d 64Summary(pl.UTF-8): Statyczna biblioteka commoncpp2
3ef9580c 65Group: Development/Libraries
66Requires: %{name}-devel = %{version}-%{release}
67
68%description static
69Static commoncpp2 library.
70
06c607b2 71%description static -l pl.UTF-8
3ef9580c 72Statyczna biblioteka commoncpp2.
73
74%prep
75%setup -q
7a5c4ef4 76%patch0 -p1
54a4a4fa 77%patch1 -p1
3ef9580c 78
79%build
e131c2a8 80%{__libtoolize}
4a331386 81%{__aclocal} -I m4
4a331386 82%{__autoconf}
e131c2a8 83%{__autoheader}
84%{__automake}
4a331386 85%configure \
e5703f90 86 %{!?with_static_libs:--disable-static} \
4a331386 87 --with-openssl
54a4a4fa 88%{__make} -j1
3ef9580c 89
90%install
91rm -rf $RPM_BUILD_ROOT
92
93%{__make} install \
94 DESTDIR=$RPM_BUILD_ROOT
95
96%clean
97rm -rf $RPM_BUILD_ROOT
98
99%post -p /sbin/ldconfig
100%postun -p /sbin/ldconfig
101
2485d124
ER
102%post devel -p /sbin/postshell
103-/usr/sbin/fix-info-dir -c %{_infodir}
3ef9580c 104
2485d124
ER
105%postun devel -p /sbin/postshell
106-/usr/sbin/fix-info-dir -c %{_infodir}
3ef9580c 107
108%files
109%defattr(644,root,root,755)
110%doc AUTHORS COPYING.addendum NEWS README TODO ChangeLog
111%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
f5becfa2
AM
112%ghost %{_libdir}/libccext2-1.7.so.0
113%ghost %{_libdir}/libccgnu2-1.7.so.0
3ef9580c 114
115%files devel
116%defattr(644,root,root,755)
117%doc doc/html/*.html doc/html/*.*g*
118%attr(755,root,root) %{_bindir}/*
119%attr(755,root,root) %{_libdir}/lib*.so
120%{_libdir}/lib*.la
8bab2ee7 121%{_includedir}/cc++
3ef9580c 122%{_aclocaldir}/*.m4
123%{_pkgconfigdir}/*.pc
1abd0668 124%{_infodir}/*.info*
3ef9580c 125
e5703f90 126%if %{with static_libs}
3ef9580c 127%files static
128%defattr(644,root,root,755)
129%{_libdir}/lib*.a
e5703f90 130%endif
This page took 0.049039 seconds and 4 git commands to generate.