]> git.pld-linux.org Git - packages/comanche.git/blob - comanche.spec
almost raw
[packages/comanche.git] / comanche.spec
1 Summary: A front-end for configuring the Apache Web server.
2 Name: comanche
3 Serial: 1
4 Version: 990405
5 Release: 2
6 Group: Applications/System
7 Source0: http://comanche.com.dtu.dk/comanche/download/com%{version}.tar.gz
8 Source1: comanche.wmconfig
9 Source2: comanche.xpm
10 Source3: comanche-mini.xpm
11
12 Copyright: GPL
13 BuildRoot: /var/tmp/comanche-root
14 BuildArchitectures: noarch
15 Obsoletes: apachecfg
16 Requires: itcl, tk, rcs
17
18 %description
19 Comanche (COnfiguration MANager for apaCHE) is a front-end for the
20 Apache Web server, the most popular Web server used on the Internet.
21 Comanche aims to to make it easier to manage and configure Apache.
22
23 Install the commanche package if you need a configuration manager for
24 the Apache Web server. You'll also need to install the apache package.
25
26 %prep
27 %setup -q -n com%{version}
28
29 %build
30 cat > comanche <<EOF
31 #!/bin/bash
32 #
33
34 cd /usr/lib/comanche
35 exec /usr/bin/itkwish3.0 main.tcl /etc/httpd/conf
36 EOF
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib/comanche}
41 mkdir -p $RPM_BUILD_ROOT/etc/X11/wmconfig
42 install -m 755 comanche $RPM_BUILD_ROOT/usr/bin
43 rm apachectl INSTALL changes.txt comanche 
44 cp -a * $RPM_BUILD_ROOT/usr/lib/comanche
45 install -m 644 $RPM_SOURCE_DIR/comanche.wmconfig $RPM_BUILD_ROOT/etc/X11/wmconfig/comanche
46 chmod 600 $RPM_BUILD_ROOT/etc/X11/wmconfig/comanche
47 mkdir -p $RPM_BUILD_ROOT/usr/share/icons/mini
48 install -m 644 $RPM_SOURCE_DIR/comanche.xpm $RPM_BUILD_ROOT/usr/share/icons
49 install -m 644 $RPM_SOURCE_DIR/comanche-mini.xpm \
50         $RPM_BUILD_ROOT/usr/share/icons/mini/mini-comanche.xpm
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(-,root,root)
57 /usr/bin/*
58 /usr/lib/comanche
59 %config(missingok) /etc/X11/wmconfig/comanche
60 /usr/share/icons/comanche.xpm
61 /usr/share/icons/mini/mini-comanche.xpm
This page took 0.575406 seconds and 4 git commands to generate.