]> git.pld-linux.org Git - packages/colord.git/blob - colord.spec
bd44ed056c050e64a720ff8f985ef56e2562c3ce
[packages/colord.git] / colord.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 %bcond_without  vala            # don't build Vala API
6 #
7 Summary:        Color daemon - system daemon for managing color devices
8 Summary(pl.UTF-8):      Demon colord - usługa systemowa do zarządzania urządzeniami obsługującymi kolory
9 Name:           colord
10 Version:        0.1.19
11 Release:        1
12 License:        GPL v2+ and LGPL v2+
13 Group:          Daemons
14 Source0:        http://www.freedesktop.org/software/colord/releases/%{name}-%{version}.tar.xz
15 # Source0-md5:  38f04d3882826d403f03a971bb54148a
16 URL:            http://www.freedesktop.org/software/colord/
17 BuildRequires:  autoconf >= 2.63
18 BuildRequires:  automake >= 1:1.9
19 BuildRequires:  dbus-devel
20 BuildRequires:  gettext-devel >= 0.17
21 BuildRequires:  glib2-devel >= 1:2.28.0
22 BuildRequires:  gobject-introspection-devel >= 0.9.8
23 BuildRequires:  gtk-doc >= 1.9
24 BuildRequires:  intltool >= 0.40.0
25 BuildRequires:  lcms2-devel >= 2.2
26 BuildRequires:  libgusb-devel >= 0.1.1
27 BuildRequires:  libtool
28 BuildRequires:  libusb-devel >= 1.0.0
29 BuildRequires:  pkgconfig
30 BuildRequires:  polkit-devel >= 0.103
31 BuildRequires:  rpmbuild(macros) >= 1.644
32 BuildRequires:  sane-backends-devel >= 1.0.20-3
33 BuildRequires:  sqlite3-devel
34 BuildRequires:  udev-glib-devel
35 %{?with_vala:BuildRequires:     vala}
36 Requires(post,preun,postun):    systemd-units >= 38
37 Requires:       %{name}-libs = %{version}-%{release}
38 Requires:       polkit-libs >= 0.103
39 Requires:       systemd-units >= 38
40 Suggests:       shared-color-profiles
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 colord is a low level system activated daemon that maps color devices
45 to color profiles in the system context.
46
47 %description -l pl.UTF-8
48 colord to niskopoziomowa usługa systemowa odwzorowująca urządzenia
49 obsługujące kolory na profile kolorów w kontekście systemu.
50
51 %package libs
52 Summary:        colord library
53 Summary(pl.UTF-8):      Biblioteka colord
54 Group:          Libraries
55 Requires:       glib2 >= 1:2.28.0
56 Suggests:       %{name} = %{version}-%{release}
57 Conflicts:      colord < 0.1.12-4
58
59 %description libs
60 colord library.
61
62 %description libs -l pl.UTF-8
63 Biblioteka colord.
64
65 %package devel
66 Summary:        Header files for colord library
67 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki colord
68 Group:          Development/Libraries
69 Requires:       %{name}-libs = %{version}-%{release}
70 Requires:       dbus-devel
71 Requires:       glib2-devel >= 1:2.28.0
72
73 %description devel
74 Header files for colord library.
75
76 %description devel -l pl.UTF-8
77 Pliki nagłówkowe biblioteki colord.
78
79 %package static
80 Summary:        Static colord library
81 Summary(pl.UTF-8):      Statyczna biblioteka colord
82 Group:          Development/Libraries
83 Requires:       %{name}-devel = %{version}-%{release}
84
85 %description static
86 Static colord library.
87
88 %description static -l pl.UTF-8
89 Statyczna biblioteka colord.
90
91 %package apidocs
92 Summary:        colord API documentation
93 Summary(pl.UTF-8):      Dokumentacja API colord
94 Group:          Documentation
95 Requires:       gtk-doc-common
96
97 %description apidocs
98 colord API documentation.
99
100 %description apidocs -l pl.UTF-8
101 Dokumentacja API colord.
102
103 %package -n vala-colord
104 Summary:        colord API for Vala language
105 Summary(pl.UTF-8):      API colord dla języka Vala
106 Group:          Development/Libraries
107 Requires:       %{name}-devel = %{version}-%{release}
108
109 %description -n vala-colord
110 colord API for Vala language.
111
112 %description -n vala-colord -l pl.UTF-8
113 API colord dla języka Vala.
114
115 %prep
116 %setup -q
117
118 %build
119 %{__intltoolize}
120 %{__libtoolize}
121 %{__aclocal} -I m4
122 %{__autoconf}
123 %{__autoheader}
124 %{__automake}
125 %configure \
126         --disable-silent-rules \
127         %{__enable_disable apidocs gtk-doc} \
128         %{__enable_disable static_libs static} \
129         --with-html-dir=%{_gtkdocdir} \
130         --with-systemdsystemunitdir=%{systemdunitdir}
131 # doc build is broken with -j
132 %{__make} -j1
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136
137 %{__make} install \
138         DESTDIR=$RPM_BUILD_ROOT
139
140 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
141 %{__rm} $RPM_BUILD_ROOT%{_libdir}/colord-sensors/*.a
142 %{__rm} $RPM_BUILD_ROOT%{_libdir}/colord-sensors/*.la
143
144 # the same as it locale
145 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/it_IT
146
147 %find_lang %{name}
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post
153 %systemd_post colord.service
154
155 %preun
156 %systemd_preun colord.service
157
158 %postun
159 %systemd_reload
160
161 %post   libs -p /sbin/ldconfig
162 %postun libs -p /sbin/ldconfig
163
164 %files -f %{name}.lang
165 %defattr(644,root,root,755)
166 %doc AUTHORS ChangeLog NEWS README TODO
167 %attr(755,root,root) %{_bindir}/cd-create-profile
168 %attr(755,root,root) %{_bindir}/cd-fix-profile
169 %attr(755,root,root) %{_bindir}/colormgr
170 %attr(755,root,root) %{_libexecdir}/colord
171 %attr(755,root,root) %{_libexecdir}/colord-sane
172 %dir %{_libdir}/colord-sensors
173 %attr(755,root,root) %{_libdir}/colord-sensors/libcolord_sensor_colorhug.so
174 %attr(755,root,root) %{_libdir}/colord-sensors/libcolord_sensor_dummy.so
175 %attr(755,root,root) %{_libdir}/colord-sensors/libcolord_sensor_huey.so
176 # disabled for now
177 #%attr(755,root,root) %{_libdir}/colord-sensors/libcolord_sensor_munki.so
178 %dir %{_datadir}/color/icc/colord
179 %{_datadir}/color/icc/colord/*.icc
180 %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager.Device.xml
181 %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager.Profile.xml
182 %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager.Sensor.xml
183 %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager.xml
184 %{_datadir}/dbus-1/interfaces/org.freedesktop.colord.sane.xml
185 %{_datadir}/dbus-1/system-services/org.freedesktop.ColorManager.service
186 %{_datadir}/dbus-1/system-services/org.freedesktop.colord-sane.service
187 %{_datadir}/polkit-1/actions/org.freedesktop.color.policy
188 %{_mandir}/man1/cd-create-profile.1*
189 %{_mandir}/man1/cd-fix-profile.1*
190 %{_mandir}/man1/colormgr.1*
191 %{systemdunitdir}/colord.service
192 %{systemdunitdir}/colord-sane.service
193 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/colord.conf
194 /etc/dbus-1/system.d/org.freedesktop.ColorManager.conf
195 /etc/dbus-1/system.d/org.freedesktop.colord-sane.conf
196 /lib/udev/rules.d/69-cd-sensors.rules
197 /lib/udev/rules.d/95-cd-devices.rules
198 %dir /var/lib/colord
199
200 %files libs
201 %defattr(644,root,root,755)
202 %attr(755,root,root) %{_libdir}/libcolord.so.*.*.*
203 %attr(755,root,root) %ghost %{_libdir}/libcolord.so.1
204 %{_libdir}/girepository-1.0/Colord-1.0.typelib
205
206 %files devel
207 %defattr(644,root,root,755)
208 %attr(755,root,root) %{_libdir}/libcolord.so
209 %{_includedir}/colord-1
210 %{_pkgconfigdir}/colord.pc
211 %{_datadir}/gir-1.0/Colord-1.0.gir
212
213 %if %{with static_libs}
214 %files static
215 %defattr(644,root,root,755)
216 %{_libdir}/libcolord.a
217 %endif
218
219 %if %{with apidocs}
220 %files apidocs
221 %defattr(644,root,root,755)
222 %{_gtkdocdir}/colord
223 %endif
224
225 %if %{with vala}
226 %files -n vala-colord
227 %defattr(644,root,root,755)
228 %{_datadir}/vala/vapi/colord.vapi
229 %endif
This page took 0.060489 seconds and 2 git commands to generate.