]> git.pld-linux.org Git - packages/colord.git/blob - colord.spec
1fa5456899bdaee36abc0b829fe46553dc9828ec
[packages/colord.git] / colord.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        Color daemon
7 Name:           colord
8 Version:        0.1.10
9 Release:        1
10 License:        GPL v2+ and LGPL v2+
11 Group:          Daemons
12 Source0:        http://people.freedesktop.org/~hughsient/releases/%{name}-%{version}.tar.xz
13 # Source0-md5:  6d4985b922163128beed42ecfdef5ede
14 URL:            http://colord.hughsie.com/
15 BuildRequires:  autoconf >= 2.63
16 BuildRequires:  automake >= 1:1.9
17 BuildRequires:  dbus-devel
18 BuildRequires:  gettext-devel
19 BuildRequires:  glib2-devel >= 1:2.26.0
20 BuildRequires:  gtk-doc >= 1.9
21 BuildRequires:  intltool >= 0.40.0
22 BuildRequires:  lcms2-devel
23 BuildRequires:  libtool
24 BuildRequires:  pkgconfig
25 BuildRequires:  polkit-devel >= 0.97
26 BuildRequires:  sane-backends-devel
27 BuildRequires:  sqlite3-devel
28 BuildRequires:  udev-glib-devel
29 Suggests:       shared-color-profiles
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 colord is a low level system activated daemon that maps color devices
34 to color profiles in the system context.
35
36 %package devel
37 Summary:        Header files for colord library
38 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki colord
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41 Requires:       dbus-devel
42 Requires:       glib2-devel >= 1:2.26.0
43
44 %description devel
45 Header files for colord library.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe biblioteki colord.
49
50 %package static
51 Summary:        Static colord library
52 Summary(pl.UTF-8):      Statyczna biblioteka colord
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 Static colord library.
58
59 %description static -l pl.UTF-8
60 Statyczna biblioteka colord.
61
62 %package apidocs
63 Summary:        colord API documentation
64 Summary(pl.UTF-8):      Dokumentacja API colord
65 Group:          Documentation
66 Requires:       gtk-doc-common
67
68 %description apidocs
69 colord API documentation.
70
71 %description apidocs -l pl.UTF-8
72 Dokumentacja API colord.
73
74 %prep
75 %setup -q
76
77 %build
78 %{__intltoolize}
79 %{__libtoolize}
80 %{__aclocal}
81 %{__autoconf}
82 %{__autoheader}
83 %{__automake}
84 %configure \
85         --disable-silent-rules \
86         %{__enable_disable apidocs gtk-doc} \
87         %{__enable_disable static_libs static} \
88         --with-html-dir=%{_gtkdocdir}
89 # doc build is broken with -j
90 %{__make} -j1
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94
95 %{__make} install \
96         DESTDIR=$RPM_BUILD_ROOT
97
98 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
99 %{__rm} $RPM_BUILD_ROOT%{_libdir}/colord-sensors/*.a
100 %{__rm} $RPM_BUILD_ROOT%{_libdir}/colord-sensors/*.la
101
102 %find_lang %{name}
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post   -p /sbin/ldconfig
108 %postun -p /sbin/ldconfig
109
110 %files -f %{name}.lang
111 %defattr(644,root,root,755)
112 %doc AUTHORS ChangeLog NEWS README TODO
113 %attr(755,root,root) %{_bindir}/cd-create-profile
114 %attr(755,root,root) %{_bindir}/cd-fix-profile
115 %attr(755,root,root) %{_bindir}/colormgr
116 %attr(755,root,root) %{_libexecdir}/colord
117 %attr(755,root,root) %{_libdir}/libcolord.so.*.*.*
118 %attr(755,root,root) %ghost %{_libdir}/libcolord.so.1
119 %dir %{_libdir}/colord-sensors
120 %dir %{_libdir}/colord-sensors/*.so
121 %dir %{_datadir}/color
122 %dir %{_datadir}/color/icc
123 %dir %{_datadir}/color/icc/colord
124 %{_datadir}/color/icc/colord/*.icc
125 %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager.Device.xml
126 %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager.Profile.xml
127 %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager.Sensor.xml
128 %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager.xml
129 %{_datadir}/dbus-1/system-services/org.freedesktop.ColorManager.service
130 %{_datadir}/polkit-1/actions/org.freedesktop.color.policy
131 %{_mandir}/man1/cd-create-profile.1*
132 %{_mandir}/man1/colormgr.1*
133 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/colord.conf
134 /etc/dbus-1/system.d/org.freedesktop.ColorManager.conf
135 /lib/udev/rules.d/69-cd-sensors.rules
136 /lib/udev/rules.d/95-cd-devices.rules
137
138 %files devel
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_libdir}/libcolord.so
141 %{_includedir}/colord-1
142 %{_pkgconfigdir}/colord.pc
143
144 %if %{with static_libs}
145 %files static
146 %defattr(644,root,root,755)
147 %{_libdir}/libcolord.a
148 %endif
149
150 %if %{with apidocs}
151 %files apidocs
152 %defattr(644,root,root,755)
153 %{_gtkdocdir}/colord
154 %endif
This page took 0.109392 seconds and 3 git commands to generate.