]> git.pld-linux.org Git - packages/colord-gtk.git/blob - colord-gtk.spec
- release 3
[packages/colord-gtk.git] / colord-gtk.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 %bcond_without  vala            # don't build Vala API
6 #
7 Summary:        GTK helper library for colord
8 Summary(pl.UTF-8):      Biblioteka pomocniczna GTK dla colord
9 Name:           colord-gtk
10 Version:        0.1.23
11 Release:        3
12 License:        GPL v2+ and LGPL v2+
13 Group:          Libraries
14 Source0:        http://www.freedesktop.org/software/colord/releases/%{name}-%{version}.tar.xz
15 # Source0-md5:  019fa6f9349ef39d1bd28c3dcf6fb191
16 URL:            http://www.freedesktop.org/software/colord/
17 BuildRequires:  autoconf >= 2.63
18 BuildRequires:  automake >= 1:1.9
19 BuildRequires:  colord-devel >= %{version}
20 BuildRequires:  gettext-devel >= 0.17
21 BuildRequires:  glib2-devel >= 1:2.28.0
22 BuildRequires:  gobject-introspection-devel >= 0.9.8
23 BuildRequires:  gtk+3-devel >= 3.0
24 BuildRequires:  gtk-doc >= 1.9
25 BuildRequires:  intltool >= 0.40.0
26 BuildRequires:  lcms2-devel >= 2.2
27 BuildRequires:  libtool >= 2:2.0
28 BuildRequires:  pkgconfig
29 BuildRequires:  rpmbuild(macros) >= 1.644
30 %if %{with vala}
31 BuildRequires:  vala
32 BuildRequires:  vala-colord >= %{version}
33 %endif
34 Requires:       colord-libs >= %{version}
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 GTK helper library for colord.
39
40 %description -l pl.UTF-8
41 Biblioteka pomocniczna GTK dla colord.
42
43 %package devel
44 Summary:        Header files for colord-gtk library
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki colord-gtk
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       colord-devel >= %{version}
49 Requires:       gtk+3-devel >= 3.0
50
51 %description devel
52 Header files for colord-gtk library.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe biblioteki colord-gtk.
56
57 %package static
58 Summary:        Static colord-gtk library
59 Summary(pl.UTF-8):      Statyczna biblioteka colord-gtk
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Static colord-gtk library.
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka colord-gtk.
68
69 %package apidocs
70 Summary:        colord-gtk API documentation
71 Summary(pl.UTF-8):      Dokumentacja API colord-gtk
72 Group:          Documentation
73 Requires:       gtk-doc-common
74
75 %description apidocs
76 colord-gtk API documentation.
77
78 %description apidocs -l pl.UTF-8
79 Dokumentacja API colord-gtk.
80
81 %package -n vala-colord-gtk
82 Summary:        colord-gtk API for Vala language
83 Summary(pl.UTF-8):      API colord-gtk dla języka Vala
84 Group:          Development/Libraries
85 Requires:       %{name}-devel = %{version}-%{release}
86 Requires:       vala-colord >= %{version}
87
88 %description -n vala-colord-gtk
89 colord-gtk API for Vala language.
90
91 %description -n vala-colord-gtk -l pl.UTF-8
92 API colord-gtk dla języka Vala.
93
94 %prep
95 %setup -q
96
97 %build
98 %{__intltoolize}
99 %{__libtoolize}
100 %{__aclocal} -I m4
101 %{__autoconf}
102 %{__autoheader}
103 %{__automake}
104 %configure \
105         --disable-silent-rules \
106         %{__enable_disable apidocs gtk-doc} \
107         %{__enable_disable static_libs static} \
108         --with-html-dir=%{_gtkdocdir}
109
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
119
120 # only empty translation exists atm. (as of 0.1.22)
121 #find_lang %{name}
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post   -p /sbin/ldconfig
127 %postun -p /sbin/ldconfig
128
129 %files
130 # -f %{name}.lang
131 %defattr(644,root,root,755)
132 %doc AUTHORS MAINTAINERS NEWS README TODO
133 %attr(755,root,root) %{_libdir}/libcolord-gtk.so.*.*.*
134 %attr(755,root,root) %ghost %{_libdir}/libcolord-gtk.so.1
135 %{_libdir}/girepository-1.0/ColordGtk-1.0.typelib
136
137 %files devel
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_libdir}/libcolord-gtk.so
140 %{_includedir}/colord-1/colord-gtk.h
141 %{_includedir}/colord-1/colord-gtk
142 %{_datadir}/gir-1.0/ColordGtk-1.0.gir
143 %{_pkgconfigdir}/colord-gtk.pc
144
145 %if %{with static_libs}
146 %files static
147 %defattr(644,root,root,755)
148 %{_libdir}/libcolord-gtk.a
149 %endif
150
151 %if %{with apidocs}
152 %files apidocs
153 %defattr(644,root,root,755)
154 %{_gtkdocdir}/colord-gtk
155 %endif
156
157 %if %{with vala}
158 %files -n vala-colord-gtk
159 %defattr(644,root,root,755)
160 %{_datadir}/vala/vapi/colord-gtk.vapi
161 %endif
This page took 0.115275 seconds and 4 git commands to generate.