]> git.pld-linux.org Git - packages/collectd.git/commitdiff
- up to 5.9.2 auto/th/collectd-5.9.2-1
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 2 Nov 2019 17:04:17 +0000 (18:04 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 2 Nov 2019 17:04:17 +0000 (18:04 +0100)
collectd-python.patch [deleted file]
collectd.spec
sensors.patch [deleted file]

diff --git a/collectd-python.patch b/collectd-python.patch
deleted file mode 100644 (file)
index 8992c54..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- collectd-5.8.0/src/python.c~       2017-11-18 10:03:27.000000000 +0100
-+++ collectd-5.8.0/src/python.c        2018-07-03 19:31:41.523756509 +0200
-@@ -1136,7 +1136,7 @@ static void *cpy_interactive(void *pipef
-     cpy_log_exception("interactive session init");
-   }
-   cur_sig = PyOS_setsig(SIGINT, python_sigint_handler);
--  PyOS_AfterFork();
-+  PyOS_AfterFork_Child();
-   PyEval_InitThreads();
-   close(*(int *)pipefd);
-   PyRun_InteractiveLoop(stdin, "<stdin>");
index dd031dae1a98adc15ebdbf82ccd1e9f905189587..1d050ae8741592bdcbef42298dddf97034617a6f 100644 (file)
 Summary:       Collects system information in RRD files
 Summary(pl.UTF-8):     Zbieranie informacji o systemie w plikach RRD
 Name:          collectd
 Summary:       Collects system information in RRD files
 Summary(pl.UTF-8):     Zbieranie informacji o systemie w plikach RRD
 Name:          collectd
-Version:       5.8.1
-Release:       2
+Version:       5.9.2
+Release:       1
 License:       GPL v2
 Group:         Daemons
 License:       GPL v2
 Group:         Daemons
-Source0:       http://collectd.org/files/%{name}-%{version}.tar.bz2
-# Source0-md5: bfce96c42cede5243028510bcc57c1e6
+# http://collectd.org/files/%{name}-%{version}.tar.bz2 is xz compressed :/
+Source0:       %{name}-%{version}.tar.xz
+# Source0-md5: 4ec308f256a3d3575f6c8a2be4338966
 Source1:       %{name}.conf
 Source2:       %{name}.init
 Source3:       %{name}-http.conf
 Source1:       %{name}.conf
 Source2:       %{name}.init
 Source3:       %{name}-http.conf
@@ -149,9 +150,7 @@ Source5:    %{name}-apache.conf
 Source10:      %{name}-df.conf
 Source11:      %{name}-rrdtool.conf
 Patch0:                %{name}-collection.patch
 Source10:      %{name}-df.conf
 Source11:      %{name}-rrdtool.conf
 Patch0:                %{name}-collection.patch
-Patch1:                %{name}-python.patch
 Patch2:                noquote.patch
 Patch2:                noquote.patch
-Patch3:                sensors.patch
 URL:           http://collectd.org/
 %{?with_ipmi:BuildRequires:    OpenIPMI-devel >= 2.0.14-3}
 BuildRequires: autoconf
 URL:           http://collectd.org/
 %{?with_ipmi:BuildRequires:    OpenIPMI-devel >= 2.0.14-3}
 BuildRequires: autoconf
@@ -1316,9 +1315,7 @@ Perl files from Collectd package
 %prep
 %setup -q
 %patch0 -p1
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
 %patch2 -p1
 %patch2 -p1
-%patch3 -p1
 
 %build
 %{__libtoolize} --ltdl
 
 %build
 %{__libtoolize} --ltdl
diff --git a/sensors.patch b/sensors.patch
deleted file mode 100644 (file)
index 585bdd1..0000000
+++ /dev/null
@@ -1,80 +0,0 @@
-commit d5a3c020d33cc33ee8049f54c7b4dffcd123bf83
-Author: Pavel Rochnyack <pavel2000@ngs.ru>
-Date:   Mon Dec 3 18:34:14 2018 +0700
-
-    sensors: Removed checks for upper limit of SENSORS_API_VERSION
-    
-    That makes no more sense after lm-sensors got new maintainers.
-    
-    Closes: #3006
-
-diff --git a/src/sensors.c b/src/sensors.c
-index f4ecda5e..33982e06 100644
---- a/src/sensors.c
-+++ b/src/sensors.c
-@@ -149,7 +149,7 @@ typedef struct featurelist {
- static char *conffile = SENSORS_CONF_PATH;
- /* #endif SENSORS_API_VERSION < 0x400 */
--#elif (SENSORS_API_VERSION >= 0x400) && (SENSORS_API_VERSION < 0x500)
-+#elif (SENSORS_API_VERSION >= 0x400)
- typedef struct featurelist {
-   const sensors_chip_name *chip;
-   const sensors_feature *feature;
-@@ -159,11 +159,6 @@ typedef struct featurelist {
- static char *conffile = NULL;
- static _Bool use_labels = 0;
--/* #endif (SENSORS_API_VERSION >= 0x400) && (SENSORS_API_VERSION < 0x500) */
--
--#else /* if SENSORS_API_VERSION >= 0x500 */
--#error "This version of libsensors is not supported yet. Please report this " \
--      "as bug."
- #endif
- static featurelist_t *first_feature = NULL;
-@@ -223,7 +218,7 @@ static int sensors_config(const char *key, const char *value) {
-     if (IS_TRUE(value))
-       ignorelist_set_invert(sensor_list, 0);
-   }
--#if (SENSORS_API_VERSION >= 0x400) && (SENSORS_API_VERSION < 0x500)
-+#if (SENSORS_API_VERSION >= 0x400)
-   else if (strcasecmp(key, "UseLabels") == 0) {
-     use_labels = IS_TRUE(value) ? 1 : 0;
-   }
-@@ -353,7 +348,7 @@ static int sensors_load_conf(void) {
-   }   /* while sensors_get_detected_chips */
- /* #endif SENSORS_API_VERSION < 0x400 */
--#elif (SENSORS_API_VERSION >= 0x400) && (SENSORS_API_VERSION < 0x500)
-+#elif (SENSORS_API_VERSION >= 0x400)
-   chip_num = 0;
-   while ((chip = sensors_get_detected_chips(NULL, &chip_num)) != NULL) {
-     const sensors_feature *feature;
-@@ -410,7 +405,7 @@ static int sensors_load_conf(void) {
-       } /* while (subfeature) */
-     }   /* while (feature) */
-   }     /* while (chip) */
--#endif /* (SENSORS_API_VERSION >= 0x400) && (SENSORS_API_VERSION < 0x500) */
-+#endif /* (SENSORS_API_VERSION >= 0x400) */
-   if (first_feature == NULL) {
-     sensors_cleanup();
-@@ -485,7 +480,7 @@ static int sensors_read(void) {
-   } /* for fl = first_feature .. NULL */
- /* #endif SENSORS_API_VERSION < 0x400 */
--#elif (SENSORS_API_VERSION >= 0x400) && (SENSORS_API_VERSION < 0x500)
-+#elif (SENSORS_API_VERSION >= 0x400)
-   for (featurelist_t *fl = first_feature; fl != NULL; fl = fl->next) {
-     double value;
-     int status;
-@@ -528,7 +523,7 @@ static int sensors_read(void) {
-     sensors_submit(plugin_instance, type, type_instance, value);
-   } /* for fl = first_feature .. NULL */
--#endif /* (SENSORS_API_VERSION >= 0x400) && (SENSORS_API_VERSION < 0x500) */
-+#endif /* (SENSORS_API_VERSION >= 0x400) */
-   return 0;
- } /* int sensors_read */
This page took 0.075684 seconds and 4 git commands to generate.