]> git.pld-linux.org Git - packages/cogl.git/blob - cogl.spec
bb06d1975f017b544f2c7a4f2f7d48eb8952c9e4
[packages/cogl.git] / cogl.spec
1 #
2 # Conditional build
3 %bcond_without  static_libs     # static libraries
4 %bcond_without  gdkpixbuf       # gdk-pixbuf for image loading [instead of stb_image]
5 %bcond_without  gles1           # OpenGL-ES 1.1 support
6 %bcond_without  gles2           # OpenGL-ES 2.0 support
7 %bcond_without  gstreamer       # GStreamer support
8 %bcond_without  wayland         # Wayland EGL support
9 #
10 Summary:        A library for using 3D graphics hardware to draw pretty pictures
11 Summary(pl.UTF-8):      Biblioteka do rysowania ładnych obrazków przy użyciu sprzętowej grafiki 3D
12 Name:           cogl
13 Version:        1.16.0
14 Release:        2
15 License:        LGPL v2+
16 Group:          Libraries
17 Source0:        http://ftp.gnome.org/pub/GNOME/sources/cogl/1.16/%{name}-%{version}.tar.xz
18 # Source0-md5:  611a61bed04354cbfffa3dc27feb6d4f
19 Patch0:         %{name}-link.patch
20 URL:            http://www.clutter-project.org/
21 %{?with_wayland:BuildRequires:  EGL-devel}
22 %{?with_wayland:BuildRequires:  Mesa-libwayland-egl-devel >= 1.0.0}
23 %{?with_gles1:BuildRequires:    OpenGLESv1-devel >= 1.1}
24 BuildRequires:  OpenGL-GLX-devel
25 BuildRequires:  autoconf >= 2.59
26 BuildRequires:  automake >= 1:1.11
27 BuildRequires:  cairo-devel >= 1.10
28 %{?with_gdkpixbuf:BuildRequires:        gdk-pixbuf2-devel >= 2.0}
29 BuildRequires:  gettext-devel >= 0.18.1
30 BuildRequires:  glib2-devel >= 1:2.32.0
31 BuildRequires:  gobject-introspection-devel >= 0.9.5
32 %{?with_gstreamer:BuildRequires:        gstreamer-devel >= 1.0}
33 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-base-devel >= 1.0}
34 BuildRequires:  gtk-doc >= 1.13
35 BuildRequires:  libdrm-devel
36 BuildRequires:  libtool >= 2:2.2.6
37 BuildRequires:  pango-devel >= 1:1.20
38 BuildRequires:  pkgconfig
39 BuildRequires:  tar >= 1:1.22
40 # wayland-client >= 1.0.0, wayland-server >= 1.1.90
41 %{?with_wayland:BuildRequires:  wayland-devel >= 1.2.0}
42 BuildRequires:  xorg-lib-libX11-devel
43 BuildRequires:  xorg-lib-libXcomposite-devel >= 0.4
44 BuildRequires:  xorg-lib-libXdamage-devel
45 BuildRequires:  xorg-lib-libXext-devel
46 BuildRequires:  xorg-lib-libXfixes-devel >= 3
47 BuildRequires:  xorg-lib-libXrandr-devel >= 1.2
48 BuildRequires:  xz
49 Requires:       cairo >= 1.10
50 Requires:       glib2 >= 1:2.32.0
51 Requires:       pango >= 1:1.20
52 %{?with_wayland:Requires:       wayland >= 1.2.0}
53 Requires:       xorg-lib-libXcomposite >= 0.4
54 Requires:       xorg-lib-libXfixes >= 3
55 Requires:       xorg-lib-libXrandr >= 1.2
56 Suggests:       OpenGL
57 Conflicts:      clutter < 1.8.0
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %description
61 Cogl is a small open source library for using 3D graphics hardware to
62 draw pretty pictures. The API departs from the flat state machine
63 style of OpenGL and is designed to make it easy to write orthogonal
64 components that can render without stepping on each others toes.
65
66 %description -l pl.UTF-8
67 Cogl to mała biblioteka o otwartych źródłach, pozwalająca na rysowanie
68 ładnych rysunków przy użyciu sprzętu graficznego 3D. API wywodzi się z
69 automatu skończonego w stylu OpenGL i zostało tak zaprojektowane, aby
70 ułatwić pisanie ortogonalnych komponentów, potrafiących renderować bez
71 przeszkadzania sobie nawzajem.
72
73 %package devel
74 Summary:        Header files for cogl library
75 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki cogl
76 Group:          Development/Libraries
77 Requires:       %{name} = %{version}-%{release}
78 %{?with_wayland:Requires:       EGL-devel}
79 %{?with_wayland:Requires:       Mesa-libwayland-egl-devel >= 1.0.0}
80 Requires:       cairo-devel >= 1.10
81 %{?with_gdkpixbuf:Requires:     gdk-pixbuf2-devel >= 2.0}
82 Requires:       glib2-devel >= 1:2.32.0
83 Requires:       gobject-introspection-devel >= 0.9.5
84 Requires:       libdrm-devel
85 Requires:       pango-devel >= 1:1.20
86 %{?with_wayland:Requires:       wayland-devel >= 1.2.0}
87 Requires:       xorg-lib-libXcomposite-devel >= 0.4
88 Requires:       xorg-lib-libXdamage-devel
89 Requires:       xorg-lib-libXext-devel
90 Requires:       xorg-lib-libXfixes-devel >= 3
91 Requires:       xorg-lib-libXrandr-devel >= 1.2
92 Conflicts:      clutter-devel < 1.8.0
93
94 %description devel
95 Header files for building and developing applications with cogl.
96
97 %description devel -l pl.UTF-8
98 Pliki nagłówkowe do tworzenia aplikacji z użyciem biblioteki cogl.
99
100 %package static
101 Summary:        Static cogl libraries
102 Summary(pl.UTF-8):      Statyczne biblioteki cogl
103 Group:          Development/Libraries
104 Requires:       %{name}-devel = %{version}-%{release}
105 Conflicts:      clutter-static < 1.8.0
106
107 %description static
108 Static cogl libraries.
109
110 %description static -l pl.UTF-8
111 Statyczne biblioteki cogl.
112
113 %package doc
114 Summary:        API documentation for cogl
115 Summary(pl.UTF-8):      Dokumentacja API cogl
116 Group:          Documentation
117
118 %description doc
119 This package contains API documentation for cogl.
120
121 %description doc -l pl.UTF-8
122 Ten pakiet zawiera dokumentację API cogl.
123
124 %package gles2
125 Summary:        Cogl frontend library for OpenGL-ES 2.0
126 Summary(pl.UTF-8):      Biblioteka frontendowa Cogl dla OpenGL-ES 2.0
127 Group:          Libraries
128 Requires:       %{name} = %{version}-%{release}
129
130 %description gles2
131 Cogl frontend library for OpenGL-ES 2.0.
132
133 %description gles2 -l pl.UTF-8
134 Biblioteka frontendowa Cogl dla OpenGL-ES 2.0.
135
136 %package gles2-devel
137 Summary:        Header files for cogl-gles2 library
138 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki cogl-gles2
139 Group:          Development/Libraries
140 Requires:       %{name}-devel = %{version}-%{release}
141 Requires:       %{name}-gles2 = %{version}-%{release}
142
143 %description gles2-devel
144 Header files for cogl-gles2 library.
145
146 %description gles2-devel -l pl.UTF-8
147 Pliki nagłówkowe biblioteki cogl-gles2.
148
149 %package gles2-static
150 Summary:        Static cogl-gles2 library
151 Summary(pl.UTF-8):      Statyczna biblioteka cogl-gles2
152 Group:          Development/Libraries
153 Requires:       %{name}-gst-devel = %{version}-%{release}
154
155 %description gles2-static
156 Static cogl-gles2 library.
157
158 %description gles2-static -l pl.UTF-8
159 Statyczna biblioteka cogl-gles2.
160
161 %package gst
162 Summary:        GStreamer integration library for Cogl
163 Summary(pl.UTF-8):      Biblioteka integrująca GStreamera z Cogl
164 Group:          Libraries
165 Requires:       %{name} = %{version}-%{release}
166
167 %description gst
168 GStreamer integration library for Cogl.
169
170 %description gst -l pl.UTF-8
171 Biblioteka integrująca GStreamera z Cogl.
172
173 %package gst-devel
174 Summary:        Header files for cogl-gst library
175 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki cogl-gst
176 Group:          Development/Libraries
177 Requires:       %{name}-devel = %{version}-%{release}
178 Requires:       %{name}-gst = %{version}-%{release}
179 Requires:       gstreamer-devel >= 1.0
180 Requires:       gstreamer-plugins-base-devel >= 1.0
181
182 %description gst-devel
183 Header files for cogl-gst library.
184
185 %description gst-devel -l pl.UTF-8
186 Pliki nagłówkowe biblioteki cogl-gst.
187
188 %package gst-static
189 Summary:        Static cogl-gst library
190 Summary(pl.UTF-8):      Statyczna biblioteka cogl-gst
191 Group:          Development/Libraries
192 Requires:       %{name}-gst-devel = %{version}-%{release}
193
194 %description gst-static
195 Static cogl-gst library.
196
197 %description gst-static -l pl.UTF-8
198 Statyczna biblioteka cogl-gst.
199
200 %package gst-apidocs
201 Summary:        API documentation for cogl-gst library
202 Summary(pl.UTF-8):      Dokumentacja API biblioteki cogl-gst
203 Group:          Documentation
204
205 %description gst-apidocs
206 API documentation for cogl-gst library.
207
208 %description gst-apidocs -l pl.UTF-8
209 Dokumentacja API biblioteki cogl-gst.
210
211 %prep
212 %setup -q
213 %patch0 -p1
214
215 %build
216 %{__gettextize}
217 %{__libtoolize}
218 %{__aclocal} -I build/autotools
219 %{__autoconf}
220 %{__autoheader}
221 %{__automake}
222 %configure \
223         %{!?with_gdkpixbuf:--disable-gdk-pixbuf} \
224         --disable-silent-rules \
225         --enable-cairo \
226         %{?with_gstreamer:--enable-cogl-gst} \
227         --enable-cogl-pango \
228         %{?with_gles1:--enable-gles1 --with-gles1-libname=libGLESv1_CM.so.1} \
229         %{?with_gles2:--enable-gles2 --with-gles2-libname=libGLESv2.so.2} \
230         --enable-glx \
231         --enable-gtk-doc \
232         --enable-introspection \
233         %{?with_static_libs:--enable-static} \
234         %{?with_wayland:--enable-wayland-egl-platform} \
235         %{?with_wayland:--enable-wayland-egl-server} \
236         --with-html-dir=%{_gtkdocdir}
237 %{__make}
238
239 %install
240 rm -rf $RPM_BUILD_ROOT
241
242 %{__make} install \
243         DESTDIR=$RPM_BUILD_ROOT
244
245 %if %{with gstreamer}
246 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gstreamer-1.0/libgstcogl.la
247 %if %{with static_libs}
248 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gstreamer-1.0/libgstcogl.a
249 %endif
250 %endif
251 # obsoleted by pkg-config
252 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcogl*.la
253
254 %find_lang %{name}
255
256 %clean
257 rm -rf $RPM_BUILD_ROOT
258
259 %post   -p /sbin/ldconfig
260 %postun -p /sbin/ldconfig
261
262 %post   gles2 -p /sbin/ldconfig
263 %postun gles2 -p /sbin/ldconfig
264
265 %post   gst -p /sbin/ldconfig
266 %postun gst -p /sbin/ldconfig
267
268 %files -f %{name}.lang
269 %defattr(644,root,root,755)
270 %doc ChangeLog NEWS README
271 %attr(755,root,root) %{_libdir}/libcogl.so.*.*.*
272 %attr(755,root,root) %ghost %{_libdir}/libcogl.so.15
273 %attr(755,root,root) %{_libdir}/libcogl-pango.so.*.*.*
274 %attr(755,root,root) %ghost %{_libdir}/libcogl-pango.so.15
275 %{_libdir}/girepository-1.0/Cogl-1.0.typelib
276 %{_libdir}/girepository-1.0/CoglPango-1.0.typelib
277
278 %files devel
279 %defattr(644,root,root,755)
280 %attr(755,root,root) %{_libdir}/libcogl.so
281 %attr(755,root,root) %{_libdir}/libcogl-pango.so
282 %dir %{_includedir}/cogl
283 %{_includedir}/cogl/cogl
284 %{_includedir}/cogl/cogl-pango
285 %{_includedir}/cogl/cogl-path
286 %{_pkgconfigdir}/cogl-1.0.pc
287 %{_pkgconfigdir}/cogl-2.0-experimental.pc
288 %{_pkgconfigdir}/cogl-gl-1.0.pc
289 %{_pkgconfigdir}/cogl-pango-1.0.pc
290 %{_pkgconfigdir}/cogl-pango-2.0-experimental.pc
291 %{_datadir}/gir-1.0/Cogl-1.0.gir
292 %{_datadir}/gir-1.0/CoglPango-1.0.gir
293
294 %if %{with static_libs}
295 %files static
296 %defattr(644,root,root,755)
297 %{_libdir}/libcogl.a
298 %{_libdir}/libcogl-pango.a
299 %endif
300
301 %files doc
302 %defattr(644,root,root,755)
303 %{_gtkdocdir}/cogl
304 %{_gtkdocdir}/cogl-2.0-experimental
305
306 %if %{with gles2}
307 %files gles2
308 %defattr(644,root,root,755)
309 %attr(755,root,root) %{_libdir}/libcogl-gles2.so.*.*.*
310 %attr(755,root,root) %ghost %{_libdir}/libcogl-gles2.so.15
311
312 %files gles2-devel
313 %defattr(644,root,root,755)
314 %attr(755,root,root) %{_libdir}/libcogl-gles2.so
315 %{_includedir}/cogl/cogl-gles2
316 %{_pkgconfigdir}/cogl-gles2-experimental.pc
317
318 %if %{with static_libs}
319 %files gles2-static
320 %defattr(644,root,root,755)
321 %{_libdir}/libcogl-gles2.a
322 %endif
323 %endif
324
325 %if %{with gstreamer}
326 %files gst
327 %defattr(644,root,root,755)
328 %attr(755,root,root) %{_libdir}/libcogl-gst.so.*.*.*
329 %attr(755,root,root) %ghost %{_libdir}/libcogl-gst.so.15
330 %attr(755,root,root) %{_libdir}/gstreamer-1.0/libgstcogl.so
331
332 %files gst-devel
333 %defattr(644,root,root,755)
334 %attr(755,root,root) %{_libdir}/libcogl-gst.so
335 %{_includedir}/cogl/cogl-gst
336 %{_pkgconfigdir}/cogl-gst.pc
337
338 %if %{with static_libs}
339 %files gst-static
340 %defattr(644,root,root,755)
341 %{_libdir}/libcogl-gst.a
342 %endif
343
344 %files gst-apidocs
345 %defattr(644,root,root,755)
346 %{_gtkdocdir}/cogl-gst
347 %endif
This page took 0.124328 seconds and 2 git commands to generate.