]> git.pld-linux.org Git - packages/codeblocks.git/commitdiff
- FHS fixes: now plugins are in %%{_libdir}/codeblocks/plugins
authortwittner <twittner@pld-linux.org>
Wed, 7 Dec 2005 21:16:00 +0000 (21:16 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  (not %%{_datadir}/... as before)

Changed files:
    codeblocks-fhs.patch -> 1.1

codeblocks-fhs.patch [new file with mode: 0644]

diff --git a/codeblocks-fhs.patch b/codeblocks-fhs.patch
new file mode 100644 (file)
index 0000000..e2b4648
--- /dev/null
@@ -0,0 +1,71 @@
+diff -Nur o.codeblocks-1.0rc2/acinclude.m4 n.codeblocks-1.0rc2/acinclude.m4
+--- o.codeblocks-1.0rc2/acinclude.m4   2005-10-25 09:59:00.000000000 +0200
++++ n.codeblocks-1.0rc2/acinclude.m4   2005-12-07 21:28:39.324146448 +0100
+@@ -228,3 +228,19 @@
+ fi\r
\r
+ ])\r
++\r
++AC_DEFUN([CODEBLOCKS_PLUGINS_DIR],\r
++      [\r
++      if test "x$libdir" = "xNONE/lib" ; then\r
++              plugins_dir="/usr/local/lib/codeblocks/plugins"\r
++      else\r
++              plugins_dir="${libdir}/codeblocks/plugins"\r
++      fi\r
++      AC_ARG_WITH(plugins-dir,\r
++                              AC_HELP_STRING([--with-plugins-dir=DIR],\r
++                                                              [Path for the plugins directory (default is $libdir/codeblocks/plugins)]),\r
++                              ,\r
++                              with_plugins_dir="$plugins_dir")\r
++      AC_DEFINE_UNQUOTED(PLUGINDIR, "${with_plugins_dir}", [Code::Blocks plugins' directory])\r
++      AC_MSG_RESULT(PLUGINDIR: ${with_plugins_dir})\r
++])\r
+diff -Nur o.codeblocks-1.0rc2/codeblocks.pc.in n.codeblocks-1.0rc2/codeblocks.pc.in
+--- o.codeblocks-1.0rc2/codeblocks.pc.in       2005-10-25 09:59:00.000000000 +0200
++++ n.codeblocks-1.0rc2/codeblocks.pc.in       2005-12-07 13:50:58.000000000 +0100
+@@ -2,7 +2,7 @@
+ exec_prefix=@exec_prefix@\r
+ libdir=@libdir@\r
+ includedir=@includedir@\r
+-plugindir=@datadir@/@PACKAGE@/plugins\r
++plugindir=@libdir@/@PACKAGE@/plugins\r
+ sharedir=@datadir@\r
\r
+ Name: codeblocks\r
+diff -Nur o.codeblocks-1.0rc2/configure.in n.codeblocks-1.0rc2/configure.in
+--- o.codeblocks-1.0rc2/configure.in   2005-10-25 09:59:00.000000000 +0200
++++ n.codeblocks-1.0rc2/configure.in   2005-12-07 21:28:30.369507760 +0100
+@@ -18,6 +18,7 @@
+ AC_PROG_AWK\r
\r
+ CODEBLOCKS_SETUP_FOR_TARGET\r
++CODEBLOCKS_PLUGINS_DIR\r
\r
+ AC_DISABLE_STATIC\r
+ AC_PROG_LIBTOOL\r
+diff -Nur o.codeblocks-1.0rc2/src/src/main.cpp n.codeblocks-1.0rc2/src/src/main.cpp
+--- o.codeblocks-1.0rc2/src/src/main.cpp       2005-10-25 09:59:02.000000000 +0200
++++ n.codeblocks-1.0rc2/src/src/main.cpp       2005-12-07 20:17:59.000000000 +0100
+@@ -23,6 +23,10 @@
+ * $Date$\r
+ */\r
\r
++#ifdef HAVE_CONFIG_H\r
++    #include "config.h"\r
++#endif\r
++\r
+ #include <sdk.h>\r
+ #include "app.h"\r
+ #include "main.h"\r
+@@ -660,7 +664,9 @@
\r
+     PluginManager* m_PluginManager = Manager::Get()->GetPluginManager();\r
\r
+-    wxString path = CFG_READ(_T("data_path")) + _T("/plugins");\r
++    //XXX: FHS changes \r
++    wxString path = PLUGINDIR;\r
++\r
+     MSGMAN()->Log(_("Scanning for plugins in %s..."), path.c_str());\r
+     int count = m_PluginManager->ScanForPlugins(path);\r
+     MSGMAN()->AppendLog(_("Found %d plugins: "), count);\r
This page took 0.086015 seconds and 4 git commands to generate.