]> git.pld-linux.org Git - packages/codeblocks.git/blob - codeblocks.spec
- BR fixed, md5, todo.
[packages/codeblocks.git] / codeblocks.spec
1 #
2 # TODO:
3 #               - move plugins to libdir/name/...
4 #
5 Summary:        An open source, cross platform, free C++ IDE
6 Name:           codeblocks
7 Version:        1.0
8 %define         _rc     rc2
9 Release:        0.%{_rc}.0.2
10 License:        GPL
11 Group:          Development/Languages
12 Source0:        http://dl.sourceforge.net/codeblocks/%{name}-%{version}%{_rc}.tgz
13 # Source0-md5:  425c700feb77d22b1b85b1061d2504d9
14 URL:            http://www.codeblocks.org/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  dos2unix
18 BuildRequires:  libtool
19 BuildRequires:  wxGTK2-devel
20 BuildRequires:  wxWidgets-devel
21 BuildRequires:  zip
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Code::Blocks is a free C++ IDE built specifically to meet the most
26 demanding needs of its users. It was designed, right from the start,
27 to be extensible and configurable. Built around a plugin framework,
28 Code::Blocks can be extended with plugin DLLs. It includes a plugin
29 wizard so you can compile your own plugins!
30
31 Features:
32
33 Highlights:
34
35      - Open Source! GPL2, no hidden costs.
36      - Cross-platform. Runs on Linux or Windows (uses wxWidgets).
37      - Made in GNU C++. No interpreted languages or proprietary libs
38        needed.
39      - Comes in two presentations: Standalone, and MinGW bundle
40      - Devpack support (optional)
41      - Extensible thru plugins (SDK available in the downloads section)
42
43 Compiler-related features:
44
45      - Multiple compiler support:
46        - GCC (MingW / Linux GCC)
47        - MSVC++
48        - Digital Mars
49        - Borland C++ 5.5
50        - Open Watcom
51      - Compiles directly or with makefiles
52      - Predefined project templates
53      - Custom template support
54      - Uses XML format for project files.
55      - Multi-target projects
56      - Workspaces support
57      - Imports MSVC projects and workspaces (NOTE: assembly code and
58        inter-project dependencies not supported yet)
59      - Imports Dev-C++ projects
60      - Integrates with GDB for debugging
61
62 Interface Features:
63
64      - Syntax highlighting, customizable and extensible
65      - Code folding for C++ and XML files.
66      - Tabbed interface
67      - Code completion plugin
68      - Class Browser
69      - Smart indent
70      - One-key swap between .h and .c/.cpp files
71      - Open files list for quick switching between files (optional)
72      - External customizable "Tools"
73      - To-do list management with different users
74
75 %prep
76 %setup -q -n %{name}-%{version}%{_rc}
77 find . -type f -and -not -name "*.cpp" -and -not -name "*.h" -and -not -name "*.png" -and -not -name "*.bmp" -and -not -name "*.c" -and -not -name "*.cxx" -and -not -name "*.ico" | sed "s/.*/\"\\0\"/" | xargs dos2unix
78 chmod a+x acinclude.m4 src/update
79
80 %build
81 %{__libtoolize}
82 %{__aclocal}
83 %{__autoconf}
84 %{__autoheader}
85 %{__automake}
86 %configure \
87         --with-wx-config=wx-gtk2-ansi-config
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92
93 %{__make} install \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post   -p /sbin/ldconfig
100 %postun -p /sbin/ldconfig
101
102 %files
103 %defattr(644,root,root,755)
104 #doc README COPYING AUTHORS BUGS COMPILERS TODO NEWS ChangeLog
105 %attr(755,root,root) %{_bindir}/codeblocks
106 %attr(755,root,root) %{_bindir}/console_runner
107 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
108 #{_datadir}/application-registry/codeblocks.applications
109 #{_datadir}/applications/codeblocks.desktop
110 #{_datadir}/icons/gnome/48x48/mimetypes/gnome-mime-application-x-codeblocks.png
111 #{_datadir}/mime-info/*
112 #{_datadir}/mime/packages/codeblocks.xml
113 #{_datadir}/pixmaps/codeblocks.png
114 #define pkgdata %{_datadir}/%{name}
115 #{pkgdata}/*
This page took 1.125048 seconds and 3 git commands to generate.