]> git.pld-linux.org Git - packages/coda.git/blob - coda.spec
- -server and -client Prereq: /sbin/chkconfig
[packages/coda.git] / coda.spec
1 Summary:        Coda distributed filesystem
2 Summary(pl):    Rozproszony system plików Coda
3 Name:           coda
4 Version:        5.3.10
5 Release:        1
6 Copyright:      CMU
7 Group:          Networking/Daemons
8 Group(de):      Netzwerkwesen/Server
9 Group(pl):      Sieciowe/Serwery
10 Source0:        ftp://ftp.coda.cs.cmu.edu/pub/coda/src/%{name}-%{version}.tgz
11 Patch0:         %{name}-ugly-common.patch
12 Requires:       bc
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 Source package for the Coda filesystem. Three packages are provided by
17 this rpm: the client and server and the backup components. Separately
18 you must install a kernel module, or have a Coda enabled kernel, and
19 you should get the Coda documentation package.
20
21 %description -l pl
22 Pakiet ¼ród³owy systemu plików Coda. Rpm zawiera trzy pakiety:
23 klienta, serwer oraz komponenty do backupu. Nale¿y oddzielnie
24 zainstalowaæ modu³ do j±dra (lub mieæ j±dro z obs³ug± Cody), nale¿y
25 rownie¿ zaopatrzyæ siê w pakiet z dokumentacj± Cody.
26
27 %package client
28 Summary:        Coda client
29 Summary(pl):    Klient Cody
30 Group:          Networking/Daemons
31 Group(de):      Netzwerkwesen/Server
32 Group(pl):      Sieciowe/Serwery
33 Prereq:         /sbin/chkconfig
34
35 %description client
36 This package contains the main client program, the cachemanager Venus.
37 Also included are the binaries for the cfs, utilities for logging, ACL
38 manipulation etc, the hoarding tools for use with laptops and repair
39 tools for fixing conflicts. Finally there is the cmon and codacon
40 console utilities to monitor Coda's activities. You need a Coda
41 kernel-module for your kernel version, or Coda in your kernel, to have
42 a complete coda client. Make sure to select the correct C library
43 version.
44
45 %description client -l pl
46 Ten pakiet zawiera g³ównego klienta, zarz±dcê cache Venus. Do³±czone s±
47 tak¿e binaria cfs, narzêdzia do logowania, zarz±dzania ACL-ami itp.,
48 narzêdzia do u¿ywania z laptopami i narzêdzia do naprawiania
49 konfliktów. S± tak¿e narzêdzia cmon i codacon do monitorowania
50 aktywno¶ci Cody. Pakiet wymaga Cody w kernelu lub module kernela.
51
52 %package server
53 Summary:        Coda server
54 Summary(pl):    Serwer Cody
55 Group:          Networking/Daemons
56 Group(de):      Netzwerkwesen/Server
57 Group(pl):      Sieciowe/Serwery
58 Prereq:         /sbin/chkconfig
59
60 %description server
61 This package contains the fileserver codasrv for the coda filesystem,
62 as well as the volume utilities. For highest performance you will need
63 a modified kernel with inode system calls.
64
65 %description server -l pl
66 Ten pakiet zawiera codasrv - serwer systemu plików Coda, oraz narzêdzia
67 do wolumenów. Aby osi±gn±æ lepsz± wydajno¶æ, potrzebny jest
68 zmodyfikowany kernel z wywo³aniami dotycz±cymi inodów.
69
70 %package backup
71 Summary:        Coda backup coordinator
72 Summary(pl):    Program do zarz±dzania backupem Cody
73 Group:          Networking
74 Group(de):      Netzwerkwesen
75 Group(pl):      Sieciowe
76
77 %description backup
78 This package contains the backup software for the coda filesystem, as
79 well as the volume utilities.
80
81 %description backup -l pl
82 Ten pakiet zawiera oprogramowanie do backupu systemu plików Coda oraz
83 narzêdzia do wolumenów.
84
85 %prep
86 %setup -q
87 %patch0 -p1
88
89 %build
90 touch ChangeLog
91 autoheader
92 aclocal
93 autoconf
94 #%%configure
95 CFLAGS="%{rpmcflags}" CXXFLAGS="%{rpmcflags}" LDFLAGS="%{rpmldflags}" \
96 ./configure %{_target_platform} \
97         --prefix=%{_prefix}
98 %{__make} OPTFLAGS="%{rpmcflags}"
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 install -d $RPM_BUILD_ROOT%{_prefix}/coda/venus.cache \
103         $RPM_BUILD_ROOT%{_prefix}/coda%{_sysconfdir} \
104         $RPM_BUILD_ROOT/coda $RPM_BUILD_ROOT/etc/rc.d/init.d
105
106 %{__make} prefix=$RPM_BUILD_ROOT%{_prefix} client-install
107 %{__make} prefix=$RPM_BUILD_ROOT%{_prefix} server-install
108
109 touch $RPM_BUILD_ROOT%{_prefix}/coda/venus.cache/INIT
110 #mknod $RPM_BUILD_ROOT/dev/cfs0 c 67 0
111 touch $RPM_BUILD_ROOT/coda/NOT_REALLY_CODA
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %pre client
117 grep "^coda" /proc/mounts > /dev/null 2>&1
118 if [ $? = 0 ]; then
119         echo "*** Coda is mounted: cannot install ***"
120         exit 1
121 else
122         exit 0
123 fi
124
125 %post client
126 if [ -e /usr/coda/etc/vstab ]; then 
127         touch /usr/coda/venus.cache/INIT
128 else
129         %{_sbindir}/venus-setup testserver.coda.cs.cmu.edu 40000
130 fi
131 /sbin/chkconfig --add venus.init
132
133 %preun client
134 grep "^coda" /proc/mounts > /dev/null 2>&1
135 if [ $? = 0 ]; then
136         echo "*** Coda is mounted: cannot uninstall ***"
137         exit 1
138 else
139         exit 0
140 fi
141 if [ "$1" = "0" ]; then
142         /sbin/chkconfig --del venus.init
143 fi
144
145 %post server
146 /sbin/chkconfig --add update.init
147 /sbin/chkconfig --add auth2.init
148 /sbin/chkconfig --add codasrv.init
149
150 %preun server
151 if [ "$1" = "0" ]; then
152         /sbin/chkconfig --del update.init
153         /sbin/chkconfig --del auth2.init
154         /sbin/chkconfig --del codasrv.init
155 fi
156
157 %files client
158 %defattr(644,root,root,755)
159 %dir %{_prefix}/coda
160 %dir %{_prefix}/coda%{_sysconfdir}
161 %dir %{_prefix}/coda/venus.cache
162 %verify() %{_prefix}/coda/venus.cache/INIT
163 %attr(754,root,root) /etc/rc.d/init.d/venus.init
164 %dir /coda
165 %verify() /coda/NOT_REALLY_CODA
166 %attr(755,root,root) %{_sbindir}/venus-setup
167 %attr(755,root,root) %{_sbindir}/vutil
168 %attr(755,root,root) %{_sbindir}/venus
169 %attr(755,root,root) %{_sbindir}/au
170 %attr(755,root,root) %{_bindir}/clog
171 %attr(755,root,root) %{_bindir}/cpasswd
172 %attr(755,root,root) %{_bindir}/ctokens
173 %attr(755,root,root) %{_bindir}/cunlog
174 %attr(755,root,root) %{_bindir}/repair
175 %attr(755,root,root) %{_bindir}/cmon
176 %attr(755,root,root) %{_bindir}/codacon
177 %attr(755,root,root) %{_bindir}/cfs
178 %attr(755,root,root) %{_bindir}/hoard
179 %attr(755,root,root) %{_bindir}/spy
180 %attr(755,root,root) %{_bindir}/replay
181 %attr(755,root,root) %{_bindir}/parser
182 %attr(755,root,root) %{_bindir}/filerepair
183 %attr(755,root,root) %{_bindir}/removeinc
184 %attr(755,root,root) %{_bindir}/xfrepair
185 %attr(755,root,root) %{_bindir}/xaskuser
186 %attr(755,root,root) %{_sbindir}/volmunge
187
188 %files server   
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_sbindir}/startserver
191 %attr(755,root,root) %{_sbindir}/partial-reinit.sh
192 %attr(755,root,root) %{_sbindir}/createvol_rep
193 %attr(755,root,root) %{_sbindir}/purgevol
194 %attr(755,root,root) %{_sbindir}/purgevol_rep
195 %attr(755,root,root) %{_sbindir}/bldvldb.sh
196 %attr(755,root,root) %{_sbindir}/vice-setup
197 %attr(755,root,root) %{_sbindir}/vice-setup-rvm
198 %attr(755,root,root) %{_sbindir}/vice-setup-srvdir
199 %attr(755,root,root) %{_sbindir}/vice-setup-user
200 %attr(755,root,root) %{_sbindir}/vice-setup-scm
201 %attr(755,root,root) %{_sbindir}/vice-killvolumes
202 %attr(755,root,root) %{_sbindir}/auth2
203 %attr(755,root,root) %{_sbindir}/initpw
204 %attr(755,root,root) %{_sbindir}/volutil
205 %attr(755,root,root) %{_sbindir}/rpc2portmap
206 %attr(755,root,root) %{_sbindir}/inoder
207 %attr(755,root,root) %{_sbindir}/parserecdump
208 %attr(755,root,root) %{_sbindir}/codasrv
209 %attr(755,root,root) %{_sbindir}/printvrdb
210 %attr(755,root,root) %{_sbindir}/updatesrv
211 %attr(755,root,root) %{_sbindir}/updateclnt
212 %attr(755,root,root) %{_sbindir}/updatefetch
213 %attr(755,root,root) %{_bindir}/norton
214 %attr(755,root,root) %{_bindir}/norton-reinit
215 %attr(755,root,root) %{_bindir}/reinit
216 %attr(754,root,root) /etc/rc.d/init.d/codasrv.init
217 %attr(754,root,root) /etc/rc.d/init.d/auth2.init
218 %attr(754,root,root) /etc/rc.d/init.d/update.init
219
220 %files backup   
221 %defattr(644,root,root,755)
222 %attr(755,root,root) %{_sbindir}/backup.sh
223 %attr(755,root,root) %{_sbindir}/tape.pl
224 %attr(755,root,root) %{_sbindir}/auth2
225 %attr(755,root,root) %{_sbindir}/volutil
226 %attr(755,root,root) %{_sbindir}/backup
227 %attr(755,root,root) %{_sbindir}/readdump
228 %attr(755,root,root) %{_sbindir}/merge
229 %attr(755,root,root) %{_sbindir}/updatesrv
230 %attr(755,root,root) %{_sbindir}/updateclnt
231 %attr(755,root,root) %{_sbindir}/updatefetch
This page took 0.071628 seconds and 4 git commands to generate.