]> git.pld-linux.org Git - packages/coda.git/blob - coda.spec
- BuildRequires: autoconf, automake
[packages/coda.git] / coda.spec
1 Summary:        Coda distributed filesystem
2 Summary(pl):    Rozproszony system plików Coda
3 Name:           coda
4 Version:        5.3.10
5 Release:        1
6 Copyright:      CMU
7 Group:          Networking/Daemons
8 Group(de):      Netzwerkwesen/Server
9 Group(pl):      Sieciowe/Serwery
10 Source0:        ftp://ftp.coda.cs.cmu.edu/pub/coda/src/%{name}-%{version}.tgz
11 Patch0:         %{name}-ugly-common.patch
12 URL:            http://www.coda.cs.cmu.edu/
13 Requires:       bc
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Source package for the Coda filesystem. Three packages are provided by
20 this rpm: the client and server and the backup components. Separately
21 you must install a kernel module, or have a Coda enabled kernel, and
22 you should get the Coda documentation package.
23
24 %description -l pl
25 Pakiet ¼ród³owy systemu plików Coda. Rpm zawiera trzy pakiety:
26 klienta, serwer oraz komponenty do backupu. Nale¿y oddzielnie
27 zainstalowaæ modu³ do j±dra (lub mieæ j±dro z obs³ug± Cody), nale¿y
28 rownie¿ zaopatrzyæ siê w pakiet z dokumentacj± Cody.
29
30 %package client
31 Summary:        Coda client
32 Summary(pl):    Klient Cody
33 Group:          Networking/Daemons
34 Group(de):      Netzwerkwesen/Server
35 Group(pl):      Sieciowe/Serwery
36 Prereq:         /sbin/chkconfig
37
38 %description client
39 This package contains the main client program, the cachemanager Venus.
40 Also included are the binaries for the cfs, utilities for logging, ACL
41 manipulation etc, the hoarding tools for use with laptops and repair
42 tools for fixing conflicts. Finally there is the cmon and codacon
43 console utilities to monitor Coda's activities. You need a Coda
44 kernel-module for your kernel version, or Coda in your kernel, to have
45 a complete coda client. Make sure to select the correct C library
46 version.
47
48 %description client -l pl
49 Ten pakiet zawiera g³ównego klienta, zarz±dcê cache Venus. Do³±czone s±
50 tak¿e binaria cfs, narzêdzia do logowania, zarz±dzania ACL-ami itp.,
51 narzêdzia do u¿ywania z laptopami i narzêdzia do naprawiania
52 konfliktów. S± tak¿e narzêdzia cmon i codacon do monitorowania
53 aktywno¶ci Cody. Pakiet wymaga Cody w kernelu lub module kernela.
54
55 %package server
56 Summary:        Coda server
57 Summary(pl):    Serwer Cody
58 Group:          Networking/Daemons
59 Group(de):      Netzwerkwesen/Server
60 Group(pl):      Sieciowe/Serwery
61 Prereq:         /sbin/chkconfig
62
63 %description server
64 This package contains the fileserver codasrv for the coda filesystem,
65 as well as the volume utilities. For highest performance you will need
66 a modified kernel with inode system calls.
67
68 %description server -l pl
69 Ten pakiet zawiera codasrv - serwer systemu plików Coda, oraz narzêdzia
70 do wolumenów. Aby osi±gn±æ lepsz± wydajno¶æ, potrzebny jest
71 zmodyfikowany kernel z wywo³aniami dotycz±cymi inodów.
72
73 %package backup
74 Summary:        Coda backup coordinator
75 Summary(pl):    Program do zarz±dzania backupem Cody
76 Group:          Networking
77 Group(de):      Netzwerkwesen
78 Group(pl):      Sieciowe
79
80 %description backup
81 This package contains the backup software for the coda filesystem, as
82 well as the volume utilities.
83
84 %description backup -l pl
85 Ten pakiet zawiera oprogramowanie do backupu systemu plików Coda oraz
86 narzêdzia do wolumenów.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91
92 %build
93 touch ChangeLog
94 autoheader
95 aclocal
96 autoconf
97 #%%configure
98 CFLAGS="%{rpmcflags}" CXXFLAGS="%{rpmcflags}" LDFLAGS="%{rpmldflags}" \
99 ./configure %{_target_platform} \
100         --prefix=%{_prefix}
101 %{__make} OPTFLAGS="%{rpmcflags}"
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 install -d $RPM_BUILD_ROOT%{_prefix}/coda/venus.cache \
106         $RPM_BUILD_ROOT%{_prefix}/coda%{_sysconfdir} \
107         $RPM_BUILD_ROOT/coda $RPM_BUILD_ROOT/etc/rc.d/init.d
108
109 %{__make} prefix=$RPM_BUILD_ROOT%{_prefix} client-install
110 %{__make} prefix=$RPM_BUILD_ROOT%{_prefix} server-install
111
112 touch $RPM_BUILD_ROOT%{_prefix}/coda/venus.cache/INIT
113 #mknod $RPM_BUILD_ROOT/dev/cfs0 c 67 0
114 touch $RPM_BUILD_ROOT/coda/NOT_REALLY_CODA
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %pre client
120 grep "^coda" /proc/mounts > /dev/null 2>&1
121 if [ $? = 0 ]; then
122         echo "*** Coda is mounted: cannot install ***"
123         exit 1
124 else
125         exit 0
126 fi
127
128 %post client
129 if [ -e /usr/coda/etc/vstab ]; then 
130         touch /usr/coda/venus.cache/INIT
131 else
132         %{_sbindir}/venus-setup testserver.coda.cs.cmu.edu 40000
133 fi
134 /sbin/chkconfig --add venus.init
135
136 %preun client
137 grep "^coda" /proc/mounts > /dev/null 2>&1
138 if [ $? = 0 ]; then
139         echo "*** Coda is mounted: cannot uninstall ***"
140         exit 1
141 else
142         exit 0
143 fi
144 if [ "$1" = "0" ]; then
145         /sbin/chkconfig --del venus.init
146 fi
147
148 %post server
149 /sbin/chkconfig --add update.init
150 /sbin/chkconfig --add auth2.init
151 /sbin/chkconfig --add codasrv.init
152
153 %preun server
154 if [ "$1" = "0" ]; then
155         /sbin/chkconfig --del update.init
156         /sbin/chkconfig --del auth2.init
157         /sbin/chkconfig --del codasrv.init
158 fi
159
160 %files client
161 %defattr(644,root,root,755)
162 %dir %{_prefix}/coda
163 %dir %{_prefix}/coda%{_sysconfdir}
164 %dir %{_prefix}/coda/venus.cache
165 %verify() %{_prefix}/coda/venus.cache/INIT
166 %attr(754,root,root) /etc/rc.d/init.d/venus.init
167 %dir /coda
168 %verify() /coda/NOT_REALLY_CODA
169 %attr(755,root,root) %{_sbindir}/venus-setup
170 %attr(755,root,root) %{_sbindir}/vutil
171 %attr(755,root,root) %{_sbindir}/venus
172 %attr(755,root,root) %{_sbindir}/au
173 %attr(755,root,root) %{_bindir}/clog
174 %attr(755,root,root) %{_bindir}/cpasswd
175 %attr(755,root,root) %{_bindir}/ctokens
176 %attr(755,root,root) %{_bindir}/cunlog
177 %attr(755,root,root) %{_bindir}/repair
178 %attr(755,root,root) %{_bindir}/cmon
179 %attr(755,root,root) %{_bindir}/codacon
180 %attr(755,root,root) %{_bindir}/cfs
181 %attr(755,root,root) %{_bindir}/hoard
182 %attr(755,root,root) %{_bindir}/spy
183 %attr(755,root,root) %{_bindir}/replay
184 %attr(755,root,root) %{_bindir}/parser
185 %attr(755,root,root) %{_bindir}/filerepair
186 %attr(755,root,root) %{_bindir}/removeinc
187 %attr(755,root,root) %{_bindir}/xfrepair
188 %attr(755,root,root) %{_bindir}/xaskuser
189 %attr(755,root,root) %{_sbindir}/volmunge
190
191 %files server   
192 %defattr(644,root,root,755)
193 %attr(755,root,root) %{_sbindir}/startserver
194 %attr(755,root,root) %{_sbindir}/partial-reinit.sh
195 %attr(755,root,root) %{_sbindir}/createvol_rep
196 %attr(755,root,root) %{_sbindir}/purgevol
197 %attr(755,root,root) %{_sbindir}/purgevol_rep
198 %attr(755,root,root) %{_sbindir}/bldvldb.sh
199 %attr(755,root,root) %{_sbindir}/vice-setup
200 %attr(755,root,root) %{_sbindir}/vice-setup-rvm
201 %attr(755,root,root) %{_sbindir}/vice-setup-srvdir
202 %attr(755,root,root) %{_sbindir}/vice-setup-user
203 %attr(755,root,root) %{_sbindir}/vice-setup-scm
204 %attr(755,root,root) %{_sbindir}/vice-killvolumes
205 %attr(755,root,root) %{_sbindir}/auth2
206 %attr(755,root,root) %{_sbindir}/initpw
207 %attr(755,root,root) %{_sbindir}/volutil
208 %attr(755,root,root) %{_sbindir}/rpc2portmap
209 %attr(755,root,root) %{_sbindir}/inoder
210 %attr(755,root,root) %{_sbindir}/parserecdump
211 %attr(755,root,root) %{_sbindir}/codasrv
212 %attr(755,root,root) %{_sbindir}/printvrdb
213 %attr(755,root,root) %{_sbindir}/updatesrv
214 %attr(755,root,root) %{_sbindir}/updateclnt
215 %attr(755,root,root) %{_sbindir}/updatefetch
216 %attr(755,root,root) %{_bindir}/norton
217 %attr(755,root,root) %{_bindir}/norton-reinit
218 %attr(755,root,root) %{_bindir}/reinit
219 %attr(754,root,root) /etc/rc.d/init.d/codasrv.init
220 %attr(754,root,root) /etc/rc.d/init.d/auth2.init
221 %attr(754,root,root) /etc/rc.d/init.d/update.init
222
223 %files backup   
224 %defattr(644,root,root,755)
225 %attr(755,root,root) %{_sbindir}/backup.sh
226 %attr(755,root,root) %{_sbindir}/tape.pl
227 %attr(755,root,root) %{_sbindir}/auth2
228 %attr(755,root,root) %{_sbindir}/volutil
229 %attr(755,root,root) %{_sbindir}/backup
230 %attr(755,root,root) %{_sbindir}/readdump
231 %attr(755,root,root) %{_sbindir}/merge
232 %attr(755,root,root) %{_sbindir}/updatesrv
233 %attr(755,root,root) %{_sbindir}/updateclnt
234 %attr(755,root,root) %{_sbindir}/updatefetch
This page took 0.053546 seconds and 4 git commands to generate.