]> git.pld-linux.org Git - packages/coda.git/blob - coda.spec
- more BR
[packages/coda.git] / coda.spec
1 Summary:        Coda distributed filesystem
2 Summary(pl):    Rozproszony system plików Coda
3 Name:           coda
4 Version:        5.3.10
5 Release:        1
6 License:        CMU
7 Group:          Networking/Daemons
8 Group(de):      Netzwerkwesen/Server
9 Group(pl):      Sieciowe/Serwery
10 Source0:        ftp://ftp.coda.cs.cmu.edu/pub/coda/src/%{name}-%{version}.tgz
11 Patch0:         %{name}-ugly-common.patch
12 URL:            http://www.coda.cs.cmu.edu/
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  lwp-devel
16 BuildRequires:  rvm-devel
17 BuildRequires:  rpc2-devel
18 Requires:       bc
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Source package for the Coda filesystem. Three packages are provided by
23 this rpm: the client and server and the backup components. Separately
24 you must install a kernel module, or have a Coda enabled kernel, and
25 you should get the Coda documentation package.
26
27 %description -l pl
28 Pakiet ¼ród³owy systemu plików Coda. Rpm zawiera trzy pakiety:
29 klienta, serwer oraz komponenty do backupu. Nale¿y oddzielnie
30 zainstalowaæ modu³ do j±dra (lub mieæ j±dro z obs³ug± Cody), nale¿y
31 rownie¿ zaopatrzyæ siê w pakiet z dokumentacj± Cody.
32
33 %package client
34 Summary:        Coda client
35 Summary(pl):    Klient Cody
36 Group:          Networking/Daemons
37 Group(de):      Netzwerkwesen/Server
38 Group(pl):      Sieciowe/Serwery
39 Prereq:         /sbin/chkconfig
40
41 %description client
42 This package contains the main client program, the cachemanager Venus.
43 Also included are the binaries for the cfs, utilities for logging, ACL
44 manipulation etc, the hoarding tools for use with laptops and repair
45 tools for fixing conflicts. Finally there is the cmon and codacon
46 console utilities to monitor Coda's activities. You need a Coda
47 kernel-module for your kernel version, or Coda in your kernel, to have
48 a complete coda client. Make sure to select the correct C library
49 version.
50
51 %description client -l pl
52 Ten pakiet zawiera g³ównego klienta, zarz±dcê cache Venus. Do³±czone s±
53 tak¿e binaria cfs, narzêdzia do logowania, zarz±dzania ACL-ami itp.,
54 narzêdzia do u¿ywania z laptopami i narzêdzia do naprawiania
55 konfliktów. S± tak¿e narzêdzia cmon i codacon do monitorowania
56 aktywno¶ci Cody. Pakiet wymaga Cody w kernelu lub module kernela.
57
58 %package server
59 Summary:        Coda server
60 Summary(pl):    Serwer Cody
61 Group:          Networking/Daemons
62 Group(de):      Netzwerkwesen/Server
63 Group(pl):      Sieciowe/Serwery
64 Prereq:         /sbin/chkconfig
65
66 %description server
67 This package contains the fileserver codasrv for the coda filesystem,
68 as well as the volume utilities. For highest performance you will need
69 a modified kernel with inode system calls.
70
71 %description server -l pl
72 Ten pakiet zawiera codasrv - serwer systemu plików Coda, oraz narzêdzia
73 do wolumenów. Aby osi±gn±æ lepsz± wydajno¶æ, potrzebny jest
74 zmodyfikowany kernel z wywo³aniami dotycz±cymi inodów.
75
76 %package backup
77 Summary:        Coda backup coordinator
78 Summary(pl):    Program do zarz±dzania backupem Cody
79 Group:          Networking
80 Group(de):      Netzwerkwesen
81 Group(pl):      Sieciowe
82
83 %description backup
84 This package contains the backup software for the coda filesystem, as
85 well as the volume utilities.
86
87 %description backup -l pl
88 Ten pakiet zawiera oprogramowanie do backupu systemu plików Coda oraz
89 narzêdzia do wolumenów.
90
91 %prep
92 %setup -q
93 %patch0 -p1
94
95 %build
96 touch ChangeLog
97 #autoheader
98 aclocal
99 #autoconf
100 #%%configure
101 CFLAGS="%{rpmcflags}" CXXFLAGS="%{rpmcflags}" LDFLAGS="%{rpmldflags}" \
102 ./configure %{_target_platform} \
103         --prefix=%{_prefix}
104 %{__make} OPTFLAGS="%{rpmcflags}"
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108 install -d $RPM_BUILD_ROOT%{_prefix}/coda/venus.cache \
109         $RPM_BUILD_ROOT%{_prefix}/coda%{_sysconfdir} \
110         $RPM_BUILD_ROOT/coda $RPM_BUILD_ROOT/etc/rc.d/init.d
111
112 %{__make} prefix=$RPM_BUILD_ROOT%{_prefix} client-install
113 %{__make} prefix=$RPM_BUILD_ROOT%{_prefix} server-install
114
115 touch $RPM_BUILD_ROOT%{_prefix}/coda/venus.cache/INIT
116 #mknod $RPM_BUILD_ROOT/dev/cfs0 c 67 0
117 touch $RPM_BUILD_ROOT/coda/NOT_REALLY_CODA
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %pre client
123 grep "^coda" /proc/mounts > /dev/null 2>&1
124 if [ $? = 0 ]; then
125         echo "*** Coda is mounted: cannot install ***"
126         exit 1
127 else
128         exit 0
129 fi
130
131 %post client
132 if [ -e /usr/coda/etc/vstab ]; then 
133         touch /usr/coda/venus.cache/INIT
134 else
135         %{_sbindir}/venus-setup testserver.coda.cs.cmu.edu 40000
136 fi
137 /sbin/chkconfig --add venus.init
138
139 %preun client
140 grep "^coda" /proc/mounts > /dev/null 2>&1
141 if [ $? = 0 ]; then
142         echo "*** Coda is mounted: cannot uninstall ***"
143         exit 1
144 else
145         exit 0
146 fi
147 if [ "$1" = "0" ]; then
148         /sbin/chkconfig --del venus.init
149 fi
150
151 %post server
152 /sbin/chkconfig --add update.init
153 /sbin/chkconfig --add auth2.init
154 /sbin/chkconfig --add codasrv.init
155
156 %preun server
157 if [ "$1" = "0" ]; then
158         /sbin/chkconfig --del update.init
159         /sbin/chkconfig --del auth2.init
160         /sbin/chkconfig --del codasrv.init
161 fi
162
163 %files client
164 %defattr(644,root,root,755)
165 %dir %{_prefix}/coda
166 %dir %{_prefix}/coda%{_sysconfdir}
167 %dir %{_prefix}/coda/venus.cache
168 %verify() %{_prefix}/coda/venus.cache/INIT
169 %attr(754,root,root) /etc/rc.d/init.d/venus.init
170 %dir /coda
171 %verify() /coda/NOT_REALLY_CODA
172 %attr(755,root,root) %{_sbindir}/venus-setup
173 %attr(755,root,root) %{_sbindir}/vutil
174 %attr(755,root,root) %{_sbindir}/venus
175 %attr(755,root,root) %{_sbindir}/au
176 %attr(755,root,root) %{_bindir}/clog
177 %attr(755,root,root) %{_bindir}/cpasswd
178 %attr(755,root,root) %{_bindir}/ctokens
179 %attr(755,root,root) %{_bindir}/cunlog
180 %attr(755,root,root) %{_bindir}/repair
181 %attr(755,root,root) %{_bindir}/cmon
182 %attr(755,root,root) %{_bindir}/codacon
183 %attr(755,root,root) %{_bindir}/cfs
184 %attr(755,root,root) %{_bindir}/hoard
185 %attr(755,root,root) %{_bindir}/spy
186 %attr(755,root,root) %{_bindir}/replay
187 %attr(755,root,root) %{_bindir}/parser
188 %attr(755,root,root) %{_bindir}/filerepair
189 %attr(755,root,root) %{_bindir}/removeinc
190 %attr(755,root,root) %{_bindir}/xfrepair
191 %attr(755,root,root) %{_bindir}/xaskuser
192 %attr(755,root,root) %{_sbindir}/volmunge
193
194 %files server   
195 %defattr(644,root,root,755)
196 %attr(755,root,root) %{_sbindir}/startserver
197 %attr(755,root,root) %{_sbindir}/partial-reinit.sh
198 %attr(755,root,root) %{_sbindir}/createvol_rep
199 %attr(755,root,root) %{_sbindir}/purgevol
200 %attr(755,root,root) %{_sbindir}/purgevol_rep
201 %attr(755,root,root) %{_sbindir}/bldvldb.sh
202 %attr(755,root,root) %{_sbindir}/vice-setup
203 %attr(755,root,root) %{_sbindir}/vice-setup-rvm
204 %attr(755,root,root) %{_sbindir}/vice-setup-srvdir
205 %attr(755,root,root) %{_sbindir}/vice-setup-user
206 %attr(755,root,root) %{_sbindir}/vice-setup-scm
207 %attr(755,root,root) %{_sbindir}/vice-killvolumes
208 %attr(755,root,root) %{_sbindir}/auth2
209 %attr(755,root,root) %{_sbindir}/initpw
210 %attr(755,root,root) %{_sbindir}/volutil
211 %attr(755,root,root) %{_sbindir}/rpc2portmap
212 %attr(755,root,root) %{_sbindir}/inoder
213 %attr(755,root,root) %{_sbindir}/parserecdump
214 %attr(755,root,root) %{_sbindir}/codasrv
215 %attr(755,root,root) %{_sbindir}/printvrdb
216 %attr(755,root,root) %{_sbindir}/updatesrv
217 %attr(755,root,root) %{_sbindir}/updateclnt
218 %attr(755,root,root) %{_sbindir}/updatefetch
219 %attr(755,root,root) %{_bindir}/norton
220 %attr(755,root,root) %{_bindir}/norton-reinit
221 %attr(755,root,root) %{_bindir}/reinit
222 %attr(754,root,root) /etc/rc.d/init.d/codasrv.init
223 %attr(754,root,root) /etc/rc.d/init.d/auth2.init
224 %attr(754,root,root) /etc/rc.d/init.d/update.init
225
226 %files backup   
227 %defattr(644,root,root,755)
228 %attr(755,root,root) %{_sbindir}/backup.sh
229 %attr(755,root,root) %{_sbindir}/tape.pl
230 %attr(755,root,root) %{_sbindir}/auth2
231 %attr(755,root,root) %{_sbindir}/volutil
232 %attr(755,root,root) %{_sbindir}/backup
233 %attr(755,root,root) %{_sbindir}/readdump
234 %attr(755,root,root) %{_sbindir}/merge
235 %attr(755,root,root) %{_sbindir}/updatesrv
236 %attr(755,root,root) %{_sbindir}/updateclnt
237 %attr(755,root,root) %{_sbindir}/updatefetch
This page took 0.073012 seconds and 4 git commands to generate.