]> git.pld-linux.org Git - packages/coda.git/blob - coda.spec
- added URL
[packages/coda.git] / coda.spec
1 Summary:        Coda distributed filesystem
2 Summary(pl):    Rozproszony system plików Coda
3 Name:           coda
4 Version:        5.3.10
5 Release:        1
6 Copyright:      CMU
7 Group:          Networking/Daemons
8 Group(de):      Netzwerkwesen/Server
9 Group(pl):      Sieciowe/Serwery
10 Source0:        ftp://ftp.coda.cs.cmu.edu/pub/coda/src/%{name}-%{version}.tgz
11 Patch0:         %{name}-ugly-common.patch
12 URL:            http://www.coda.cs.cmu.edu/
13 Requires:       bc
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 Source package for the Coda filesystem. Three packages are provided by
18 this rpm: the client and server and the backup components. Separately
19 you must install a kernel module, or have a Coda enabled kernel, and
20 you should get the Coda documentation package.
21
22 %description -l pl
23 Pakiet ¼ród³owy systemu plików Coda. Rpm zawiera trzy pakiety:
24 klienta, serwer oraz komponenty do backupu. Nale¿y oddzielnie
25 zainstalowaæ modu³ do j±dra (lub mieæ j±dro z obs³ug± Cody), nale¿y
26 rownie¿ zaopatrzyæ siê w pakiet z dokumentacj± Cody.
27
28 %package client
29 Summary:        Coda client
30 Summary(pl):    Klient Cody
31 Group:          Networking/Daemons
32 Group(de):      Netzwerkwesen/Server
33 Group(pl):      Sieciowe/Serwery
34 Prereq:         /sbin/chkconfig
35
36 %description client
37 This package contains the main client program, the cachemanager Venus.
38 Also included are the binaries for the cfs, utilities for logging, ACL
39 manipulation etc, the hoarding tools for use with laptops and repair
40 tools for fixing conflicts. Finally there is the cmon and codacon
41 console utilities to monitor Coda's activities. You need a Coda
42 kernel-module for your kernel version, or Coda in your kernel, to have
43 a complete coda client. Make sure to select the correct C library
44 version.
45
46 %description client -l pl
47 Ten pakiet zawiera g³ównego klienta, zarz±dcê cache Venus. Do³±czone s±
48 tak¿e binaria cfs, narzêdzia do logowania, zarz±dzania ACL-ami itp.,
49 narzêdzia do u¿ywania z laptopami i narzêdzia do naprawiania
50 konfliktów. S± tak¿e narzêdzia cmon i codacon do monitorowania
51 aktywno¶ci Cody. Pakiet wymaga Cody w kernelu lub module kernela.
52
53 %package server
54 Summary:        Coda server
55 Summary(pl):    Serwer Cody
56 Group:          Networking/Daemons
57 Group(de):      Netzwerkwesen/Server
58 Group(pl):      Sieciowe/Serwery
59 Prereq:         /sbin/chkconfig
60
61 %description server
62 This package contains the fileserver codasrv for the coda filesystem,
63 as well as the volume utilities. For highest performance you will need
64 a modified kernel with inode system calls.
65
66 %description server -l pl
67 Ten pakiet zawiera codasrv - serwer systemu plików Coda, oraz narzêdzia
68 do wolumenów. Aby osi±gn±æ lepsz± wydajno¶æ, potrzebny jest
69 zmodyfikowany kernel z wywo³aniami dotycz±cymi inodów.
70
71 %package backup
72 Summary:        Coda backup coordinator
73 Summary(pl):    Program do zarz±dzania backupem Cody
74 Group:          Networking
75 Group(de):      Netzwerkwesen
76 Group(pl):      Sieciowe
77
78 %description backup
79 This package contains the backup software for the coda filesystem, as
80 well as the volume utilities.
81
82 %description backup -l pl
83 Ten pakiet zawiera oprogramowanie do backupu systemu plików Coda oraz
84 narzêdzia do wolumenów.
85
86 %prep
87 %setup -q
88 %patch0 -p1
89
90 %build
91 touch ChangeLog
92 autoheader
93 aclocal
94 autoconf
95 #%%configure
96 CFLAGS="%{rpmcflags}" CXXFLAGS="%{rpmcflags}" LDFLAGS="%{rpmldflags}" \
97 ./configure %{_target_platform} \
98         --prefix=%{_prefix}
99 %{__make} OPTFLAGS="%{rpmcflags}"
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103 install -d $RPM_BUILD_ROOT%{_prefix}/coda/venus.cache \
104         $RPM_BUILD_ROOT%{_prefix}/coda%{_sysconfdir} \
105         $RPM_BUILD_ROOT/coda $RPM_BUILD_ROOT/etc/rc.d/init.d
106
107 %{__make} prefix=$RPM_BUILD_ROOT%{_prefix} client-install
108 %{__make} prefix=$RPM_BUILD_ROOT%{_prefix} server-install
109
110 touch $RPM_BUILD_ROOT%{_prefix}/coda/venus.cache/INIT
111 #mknod $RPM_BUILD_ROOT/dev/cfs0 c 67 0
112 touch $RPM_BUILD_ROOT/coda/NOT_REALLY_CODA
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %pre client
118 grep "^coda" /proc/mounts > /dev/null 2>&1
119 if [ $? = 0 ]; then
120         echo "*** Coda is mounted: cannot install ***"
121         exit 1
122 else
123         exit 0
124 fi
125
126 %post client
127 if [ -e /usr/coda/etc/vstab ]; then 
128         touch /usr/coda/venus.cache/INIT
129 else
130         %{_sbindir}/venus-setup testserver.coda.cs.cmu.edu 40000
131 fi
132 /sbin/chkconfig --add venus.init
133
134 %preun client
135 grep "^coda" /proc/mounts > /dev/null 2>&1
136 if [ $? = 0 ]; then
137         echo "*** Coda is mounted: cannot uninstall ***"
138         exit 1
139 else
140         exit 0
141 fi
142 if [ "$1" = "0" ]; then
143         /sbin/chkconfig --del venus.init
144 fi
145
146 %post server
147 /sbin/chkconfig --add update.init
148 /sbin/chkconfig --add auth2.init
149 /sbin/chkconfig --add codasrv.init
150
151 %preun server
152 if [ "$1" = "0" ]; then
153         /sbin/chkconfig --del update.init
154         /sbin/chkconfig --del auth2.init
155         /sbin/chkconfig --del codasrv.init
156 fi
157
158 %files client
159 %defattr(644,root,root,755)
160 %dir %{_prefix}/coda
161 %dir %{_prefix}/coda%{_sysconfdir}
162 %dir %{_prefix}/coda/venus.cache
163 %verify() %{_prefix}/coda/venus.cache/INIT
164 %attr(754,root,root) /etc/rc.d/init.d/venus.init
165 %dir /coda
166 %verify() /coda/NOT_REALLY_CODA
167 %attr(755,root,root) %{_sbindir}/venus-setup
168 %attr(755,root,root) %{_sbindir}/vutil
169 %attr(755,root,root) %{_sbindir}/venus
170 %attr(755,root,root) %{_sbindir}/au
171 %attr(755,root,root) %{_bindir}/clog
172 %attr(755,root,root) %{_bindir}/cpasswd
173 %attr(755,root,root) %{_bindir}/ctokens
174 %attr(755,root,root) %{_bindir}/cunlog
175 %attr(755,root,root) %{_bindir}/repair
176 %attr(755,root,root) %{_bindir}/cmon
177 %attr(755,root,root) %{_bindir}/codacon
178 %attr(755,root,root) %{_bindir}/cfs
179 %attr(755,root,root) %{_bindir}/hoard
180 %attr(755,root,root) %{_bindir}/spy
181 %attr(755,root,root) %{_bindir}/replay
182 %attr(755,root,root) %{_bindir}/parser
183 %attr(755,root,root) %{_bindir}/filerepair
184 %attr(755,root,root) %{_bindir}/removeinc
185 %attr(755,root,root) %{_bindir}/xfrepair
186 %attr(755,root,root) %{_bindir}/xaskuser
187 %attr(755,root,root) %{_sbindir}/volmunge
188
189 %files server   
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_sbindir}/startserver
192 %attr(755,root,root) %{_sbindir}/partial-reinit.sh
193 %attr(755,root,root) %{_sbindir}/createvol_rep
194 %attr(755,root,root) %{_sbindir}/purgevol
195 %attr(755,root,root) %{_sbindir}/purgevol_rep
196 %attr(755,root,root) %{_sbindir}/bldvldb.sh
197 %attr(755,root,root) %{_sbindir}/vice-setup
198 %attr(755,root,root) %{_sbindir}/vice-setup-rvm
199 %attr(755,root,root) %{_sbindir}/vice-setup-srvdir
200 %attr(755,root,root) %{_sbindir}/vice-setup-user
201 %attr(755,root,root) %{_sbindir}/vice-setup-scm
202 %attr(755,root,root) %{_sbindir}/vice-killvolumes
203 %attr(755,root,root) %{_sbindir}/auth2
204 %attr(755,root,root) %{_sbindir}/initpw
205 %attr(755,root,root) %{_sbindir}/volutil
206 %attr(755,root,root) %{_sbindir}/rpc2portmap
207 %attr(755,root,root) %{_sbindir}/inoder
208 %attr(755,root,root) %{_sbindir}/parserecdump
209 %attr(755,root,root) %{_sbindir}/codasrv
210 %attr(755,root,root) %{_sbindir}/printvrdb
211 %attr(755,root,root) %{_sbindir}/updatesrv
212 %attr(755,root,root) %{_sbindir}/updateclnt
213 %attr(755,root,root) %{_sbindir}/updatefetch
214 %attr(755,root,root) %{_bindir}/norton
215 %attr(755,root,root) %{_bindir}/norton-reinit
216 %attr(755,root,root) %{_bindir}/reinit
217 %attr(754,root,root) /etc/rc.d/init.d/codasrv.init
218 %attr(754,root,root) /etc/rc.d/init.d/auth2.init
219 %attr(754,root,root) /etc/rc.d/init.d/update.init
220
221 %files backup   
222 %defattr(644,root,root,755)
223 %attr(755,root,root) %{_sbindir}/backup.sh
224 %attr(755,root,root) %{_sbindir}/tape.pl
225 %attr(755,root,root) %{_sbindir}/auth2
226 %attr(755,root,root) %{_sbindir}/volutil
227 %attr(755,root,root) %{_sbindir}/backup
228 %attr(755,root,root) %{_sbindir}/readdump
229 %attr(755,root,root) %{_sbindir}/merge
230 %attr(755,root,root) %{_sbindir}/updatesrv
231 %attr(755,root,root) %{_sbindir}/updateclnt
232 %attr(755,root,root) %{_sbindir}/updatefetch
This page took 0.062127 seconds and 4 git commands to generate.