]> git.pld-linux.org Git - packages/coda.git/blob - coda.spec
- use macros in %{pre,post}{,un}
[packages/coda.git] / coda.spec
1 Summary:        Coda distributed filesystem
2 Summary(pl):    Rozproszony system plików Coda
3 Name:           coda
4 Version:        5.3.10
5 Release:        1
6 Copyright:      CMU
7 Group:          Networking/Daemons
8 Group(de):      Netzwerkwesen/Server
9 Group(pl):      Sieciowe/Serwery
10 Source0:        %{name}-%{version}.tgz
11 Patch0:         %{name}-ugly-common.patch
12 Requires:       bc
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 Source package for the Coda filesystem. Three packages are provided by
17 this rpm: the client and server and the backup components. Separately
18 you must install a kernel module, or have a Coda enabled kernel, and
19 you should get the Coda documentation package. BEWARE: CVS VERSION
20
21 %description -l pl
22 Pakiet ¼ród³owy systemu plików Coda. Rpm zawiera trzy pakiety:
23 klienta, serwer oraz komponenty do backupu. Nale¿y oddzielnie
24 zainstalowaæ modu³ do j±dra (lub mieæ j±dro z obs³ug± Cody), nale¿y
25 rownie¿ zaopatrzyæ siê w pakiet z dokumentacj± Cody. UWAGA: WERSJA CVS
26
27 %package client
28 Summary:        Coda client
29 Summary(pl):    Klient Cody
30 Group:          Networking/Daemons
31 Group(de):      Netzwerkwesen/Server
32 Group(pl):      Sieciowe/Serwery
33 Prereq:         /sbin/chkconfig
34
35 %description client
36 This package contains the main client program, the cachemanager Venus.
37 Also included are the binaries for the cfs, utilities for logging, ACL
38 manipulation etc, the hoarding tools for use with laptops and repair
39 tools for fixing conflicts. Finally there is the cmon and codacon
40 console utilities to monitor Coda's activities. You need a Coda
41 kernel-module for your kernel version, or Coda in your kernel, to have
42 a complete coda client. Make sure to select the correct C library
43 version. BEWARE: CVS VERSION
44
45 %package server
46 Summary:        Coda server
47 Summary(pl):    Serwer Cody
48 Group:          Networking/Daemons
49 Group(de):      Netzwerkwesen/Server
50 Group(pl):      Sieciowe/Serwery
51 Prereq:         /sbin/chkconfig
52
53 %description server
54 This package contains the fileserver codasrv for the coda filesystem,
55 as well as the volume utilities. For highest performance you will need
56 a modified kernel with inode system calls. BEWARE: CVS VERSION
57
58 %package backup
59 Summary:        Coda backup coordinator
60 Summary(pl):    Program do zarz±dzania backupem Cody
61 Prereq:         /sbin/chkconfig
62
63 %description backup
64 This package contains the backup software for the coda filesystem, as
65 well as the volume utilities. BEWARE: CVS VERSION
66
67 %prep
68 %setup -q
69 %patch0 -p1
70
71 %build
72 touch ChangeLog
73 autoheader
74 aclocal
75 autoconf
76 #%%configure
77 CFLAGS="%{rpmcflags}" CXXFLAGS="%{rpmcflags}" LDFLAGS="%{rpmldflags}" \
78 ./configure %{_target_platform} \
79         --prefix=%{_prefix}
80 %{__make} OPTFLAGS="%{rpmcflags}"
81
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 install -d $RPM_BUILD_ROOT%{_prefix}/coda/venus.cache \
86         $RPM_BUILD_ROOT%{_prefix}/coda%{_sysconfdir} \
87         $RPM_BUILD_ROOT/coda $RPM_BUILD_ROOT/etc/rc.d/init.d
88
89 %{__make} prefix=$RPM_BUILD_ROOT%{_prefix} client-install
90 %{__make} prefix=$RPM_BUILD_ROOT%{_prefix} server-install
91
92 touch $RPM_BUILD_ROOT%{_prefix}/coda/venus.cache/INIT
93 #mknod $RPM_BUILD_ROOT/dev/cfs0 c 67 0
94 touch $RPM_BUILD_ROOT/coda/NOT_REALLY_CODA
95
96 %clean
97 Group:          Networking/Daemons
98 Group(de):      Netzwerkwesen/Server
99 Group(pl):      Sieciowe/Serwery
100 rm -rf $RPM_BUILD_ROOT
101
102 %pre client
103 grep "^coda" /proc/mounts > /dev/null 2>&1
104 if [ $? = 0 ]; then
105         echo "*** Coda is mounted: cannot install ***"
106         exit 1
107 else
108         exit 0
109 fi
110
111 %preun client
112 grep "^coda" /proc/mounts > /dev/null 2>&1
113 if [ $? = 0 ]; then
114         echo "*** Coda is mounted: cannot uninstall ***"
115         exit 1
116 else
117         exit 0
118 fi
119         
120 %post client
121 if [ -e /usr/coda/etc/vstab ]; then 
122         touch /usr/coda/venus.cache/INIT
123 else
124         %{_sbindir}/venus-setup testserver.coda.cs.cmu.edu 40000
125 fi
126 NAME=venus.init; %chkconfig_add
127
128 %preun client
129 NAME=venus.init; %chkconfig_del
130
131 %post server
132 NAME=update.init; %chkconfig_add
133 NAME=auth2.init; DESC=auth2.init; %chkconfig_add
134 NAME=codasrv.init; DESC=codasrv.init; %chkconfig_add
135
136 %postun server
137 NAME=update.init; %chkconfig_del
138 NAME=auth2.init; %chkconfig_del
139 NAME=codasrv.init; %chkconfig_del
140
141 %files client
142 %defattr(644,root,root,755)
143 %dir %{_prefix}/coda
144 %dir %{_prefix}/coda%{_sysconfdir}
145 %dir %{_prefix}/coda/venus.cache
146 %verify() %{_prefix}/coda/venus.cache/INIT
147 /etc/rc.d/init.d/venus.init
148 %dir /coda
149 %verify() /coda/NOT_REALLY_CODA
150 %attr(755,root,root) %{_sbindir}/venus-setup
151 %attr(755,root,root) %{_sbindir}/vutil
152 %attr(755,root,root) %{_sbindir}/venus
153 %attr(755,root,root) %{_sbindir}/au
154 %attr(755,root,root) %{_bindir}/clog
155 %attr(755,root,root) %{_bindir}/cpasswd
156 %attr(755,root,root) %{_bindir}/ctokens
157 %attr(755,root,root) %{_bindir}/cunlog
158 %attr(755,root,root) %{_bindir}/repair
159 %attr(755,root,root) %{_bindir}/cmon
160 %attr(755,root,root) %{_bindir}/codacon
161 %attr(755,root,root) %{_bindir}/cfs
162 %attr(755,root,root) %{_bindir}/hoard
163 %attr(755,root,root) %{_bindir}/spy
164 %attr(755,root,root) %{_bindir}/replay
165 %attr(755,root,root) %{_bindir}/parser
166 %attr(755,root,root) %{_bindir}/filerepair
167 %attr(755,root,root) %{_bindir}/removeinc
168 %attr(755,root,root) %{_bindir}/xfrepair
169 %attr(755,root,root) %{_bindir}/xaskuser
170 %attr(755,root,root) %{_sbindir}/volmunge
171
172 %files server   
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{_sbindir}/startserver
175 %attr(755,root,root) %{_sbindir}/partial-reinit.sh
176 %attr(755,root,root) %{_sbindir}/createvol_rep
177 %attr(755,root,root) %{_sbindir}/purgevol
178 %attr(755,root,root) %{_sbindir}/purgevol_rep
179 %attr(755,root,root) %{_sbindir}/bldvldb.sh
180 %attr(755,root,root) %{_sbindir}/vice-setup
181 %attr(755,root,root) %{_sbindir}/vice-setup-rvm
182 %attr(755,root,root) %{_sbindir}/vice-setup-srvdir
183 %attr(755,root,root) %{_sbindir}/vice-setup-user
184 %attr(755,root,root) %{_sbindir}/vice-setup-scm
185 %attr(755,root,root) %{_sbindir}/vice-killvolumes
186 %attr(755,root,root) %{_sbindir}/auth2
187 %attr(755,root,root) %{_sbindir}/initpw
188 %attr(755,root,root) %{_sbindir}/volutil
189 %attr(755,root,root) %{_sbindir}/rpc2portmap
190 %attr(755,root,root) %{_sbindir}/inoder
191 %attr(755,root,root) %{_sbindir}/parserecdump
192 %attr(755,root,root) %{_sbindir}/codasrv
193 %attr(755,root,root) %{_sbindir}/printvrdb
194 %attr(755,root,root) %{_sbindir}/updatesrv
195 %attr(755,root,root) %{_sbindir}/updateclnt
196 %attr(755,root,root) %{_sbindir}/updatefetch
197 %attr(755,root,root) %{_bindir}/norton
198 %attr(755,root,root) %{_bindir}/norton-reinit
199 %attr(755,root,root) %{_bindir}/reinit
200 /etc/rc.d/init.d/codasrv.init
201 /etc/rc.d/init.d/auth2.init
202 /etc/rc.d/init.d/update.init
203
204 %files backup   
205 %defattr(644,root,root,755)
206 %attr(755,root,root) %{_sbindir}/backup.sh
207 %attr(755,root,root) %{_sbindir}/tape.pl
208 %attr(755,root,root) %{_sbindir}/auth2
209 %attr(755,root,root) %{_sbindir}/volutil
210 %attr(755,root,root) %{_sbindir}/backup
211 %attr(755,root,root) %{_sbindir}/readdump
212 %attr(755,root,root) %{_sbindir}/merge
213 %attr(755,root,root) %{_sbindir}/updatesrv
214 %attr(755,root,root) %{_sbindir}/updateclnt
215 %attr(755,root,root) %{_sbindir}/updatefetch
This page took 0.104642 seconds and 4 git commands to generate.