]> git.pld-linux.org Git - packages/coda.git/blob - coda.spec
- raw spec from bero.
[packages/coda.git] / coda.spec
1 Summary: Coda distributed filesystem
2 Name: coda
3 Version: 5.0.1
4 Release: bero1
5 Source: ftp://ftp.coda.cs.cmu.edu/pub/coda/src/coda-5.0.1.tar.bz2
6 Requires: bc
7 Copyright: CMU
8 BuildRoot: /usr/src/RPM/BUILD/coda-build
9 Group: Networking/Daemons
10 %description
11 Source package for the Coda filesystem.  Three packages are provided by
12 this rpm: the client and server and the backup components. Separately
13 you must install a kernel module, or have a Coda enabled kernel, and 
14 you should get the Coda documentation package.
15
16 %package client
17 Summary: Coda client
18 Group: Networking/Daemons
19 %description client
20 This package contains the main client program, the cachemanager Venus.
21 Also included are the binaries for the cfs, utilities for logging, ACL
22 manipulation etc, the hoarding tools for use with laptops and repair
23 tools for fixing conflicts. Finally there is the cmon and codacon
24 console utilities to monitor Coda's activities. You need a Coda
25 kernel-module for your kernel version, or Coda in your kernel, to have
26 a complete coda client.  Make sure to select the correct C library
27 version.
28
29 %package server
30 Summary: Coda server
31 Group: Networking/Daemons
32 %description server
33 This package contains the fileserver codasrv for the coda filesystem,
34 as well as the volume utilities.  For highest performance you will
35 need a modified kernel with inode system calls.
36
37 %package backup
38 Summary: Coda backup coordinator
39 Group: Networking/Daemons
40 %description backup
41 This package contains the backup software for the coda filesystem, as
42 well as the volume utilities.
43
44 %changelog
45 * Fri Feb 12 1999 Bernhard Rosenkraenzer <bero@microsoft.sucks.eu.org>
46 - adapt to BeroLinux
47 * Sun Jun 21 1998 Peter Braam <braam@cs.cmu.edu>
48 - get rid of the kernel package. This needs interaction during the build.
49 - no more separate libc, glibc packages
50 * Tue Dec 30 1997 Peter Braam <braam@cs.cmu.edu>
51 - several changes: documentation separate
52 - use variables: =`uname -r`, 5.0.1=coda version
53 * Mon Jun 02 1997 Peter Braam <braam@cs.cmu.edu>
54 - small changes to Elliots improvements.
55 - some of his ideas are now in the scripts
56 * Wed May 28 1997 Elliot Lee <sopwith@redhat.com>
57 - Based upon 4.0.3-1 spec file.
58 - Changed to BuildRoot
59 - Do as much as possible at build time instead of in %post
60 - Added initscript for venus
61         
62 %prep
63 %setup -n coda-5.0.1
64
65 %build
66 chown -R root.bin $RPM_BUILD_DIR/coda-5.0.1
67 rm -rf $RPM_BUILD_DIR/obj-5.0.1
68 mkdir $RPM_BUILD_DIR/obj-5.0.1
69 cd $RPM_BUILD_DIR/obj-5.0.1
70 CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" $RPM_BUILD_DIR/coda-5.0.1/configure --prefix=$RPM_BUILD_ROOT/usr
71 make
72
73 %install
74 cd $RPM_BUILD_DIR/obj-5.0.1
75 rm -rf $RPM_BUILD_ROOT
76 mkdir -p $RPM_BUILD_ROOT/usr/coda/venus.cache $RPM_BUILD_ROOT/dev \
77         $RPM_BUILD_ROOT/usr/coda/etc \
78         $RPM_BUILD_ROOT/coda $RPM_BUILD_ROOT/etc/rc.d/init.d\
79         $RPM_BUILD_ROOT/$RPM_BUILD_DIR\
80         $RPM_BUILD_ROOT/usr/lib/coda $RPM_BUILD_ROOT/etc/rc.d/init.d
81
82 make client-install
83 make server-install
84
85 touch $RPM_BUILD_ROOT/usr/coda/venus.cache/INIT
86 mknod $RPM_BUILD_ROOT/dev/cfs0 c 67 0
87 touch $RPM_BUILD_ROOT/coda/NOT_REALLY_CODA
88
89
90 # for non debuging versions
91 #if [ X1 != X1 ]; then
92 strip $RPM_BUILD_ROOT/usr/bin/* $RPM_BUILD_ROOT/vice/bin/* $RPM_BUILD_ROOT/usr/sbin/* || :
93 #fi
94
95 cd $RPM_BUILD_DIR
96 cp $RPM_SOURCE_DIR/coda-5.0.1.tar.bz2 $RPM_BUILD_ROOT/$RPM_BUILD_DIR/coda-5.0.1.tar.bz2
97 chown -R root.root $RPM_BUILD_ROOT
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %pre client
103 grep "^coda" /proc/mounts > /dev/null 2>&1
104 if [ $? = 0 ]; then
105         echo "*** Coda is mounted: cannot install ***"
106         exit 1
107 else
108         exit 0
109 fi
110
111 %preun client
112 grep "^coda" /proc/mounts > /dev/null 2>&1
113 if [ $? = 0 ]; then
114         echo "*** Coda is mounted: cannot uninstall ***"
115         exit 1
116 else
117         exit 0
118 fi
119         
120 %post client
121 if [ -e /usr/coda/etc/vstab ]; then 
122         touch /usr/coda/venus.cache/INIT
123 else
124         /usr/sbin/venus-setup testserver.coda.cs.cmu.edu 40000
125 fi
126
127 cd /usr/lib/coda
128 if [ ! -x /usr/bin/tixindex ]; then
129         chmod a+x /usr/bin/tixindex 
130 fi
131 tixindex *tcl
132 #if [ ! -f /usr/bin/tixwish ]; then
133 #       ln -s /usr/bin/tixwish* /usr/bin/tixwish
134 #       if [ x$? != x0 ]; then
135 #               echo "**WARNING: tixwish is not correctly installed"
136 #       fi
137 #fi
138 /sbin/chkconfig --add venus.init
139
140 %postun
141 /sbin/chkconfig --del venus.init
142
143 %post server
144 /sbin/chkconfig --add update.init
145 /sbin/chkconfig --add auth2.init
146 /sbin/chkconfig --add codasrv.init
147
148 %postun server
149 /sbin/chkconfig --del update.init
150 /sbin/chkconfig --del auth2.init
151 /sbin/chkconfig --del codasrv.init
152
153
154 %files client
155 /dev/cfs0
156 %dir /usr/coda
157 %dir /usr/coda/etc
158 %dir /usr/coda/venus.cache
159 %verify() /usr/coda/venus.cache/INIT
160 /etc/rc.d/init.d/venus.init
161 %dir /coda
162 %verify() /coda/NOT_REALLY_CODA
163 /usr/sbin/venus-setup
164 /usr/sbin/vutil
165 /usr/sbin/venus
166 /usr/sbin/au
167 /usr/bin/advice_srv
168 /usr/bin/filcon
169 /usr/bin/clog
170 /usr/bin/cpasswd
171 /usr/bin/ctokens
172 /usr/bin/cunlog
173 /usr/bin/repair
174 /usr/bin/cmon
175 /usr/bin/codacon
176 /usr/bin/cfs
177 /usr/bin/hoard
178 /usr/bin/spy
179 /usr/bin/replay
180 /usr/bin/parser
181 /usr/bin/filerepair
182 /usr/bin/removeinc
183 /usr/bin/xfrepair
184 /usr/bin/xaskuser
185 /usr/bin/logbandwidth
186 /usr/bin/logcmls
187 /usr/bin/logreintegration
188 /usr/sbin/volmunge
189 /usr/lib/coda/Advice.tcl
190 /usr/lib/coda/CodaConsole
191 /usr/lib/coda/Consider.tcl
192 /usr/lib/coda/ConsiderAdding.tcl
193 /usr/lib/coda/ConsiderRemoving.tcl
194 /usr/lib/coda/ControlPanel.tcl
195 /usr/lib/coda/Date.tcl
196 /usr/lib/coda/DiscoMiss.tcl
197 /usr/lib/coda/Events.tcl
198 /usr/lib/coda/Globals.tcl
199 /usr/lib/coda/Helper.tcl
200 /usr/lib/coda/HoardWalk.tcl
201 /usr/lib/coda/HoardWalkAdvice.tcl
202 /usr/lib/coda/Indicators.tcl
203 /usr/lib/coda/Initialization.tcl
204 /usr/lib/coda/Lock.tcl
205 /usr/lib/coda/Log.tcl
206 /usr/lib/coda/Network.tcl
207 /usr/lib/coda/OutsideWorld.tcl
208 /usr/lib/coda/ReadMiss.tcl
209 /usr/lib/coda/Reconnection.tcl
210 /usr/lib/coda/Reintegration.tcl
211 /usr/lib/coda/Repair.tcl
212 /usr/lib/coda/Space.tcl
213 /usr/lib/coda/Task.tcl
214 /usr/lib/coda/Timing.tcl
215 /usr/lib/coda/Tokens.tcl
216 /usr/lib/coda/WeakMiss.tcl
217 /usr/lib/coda/tixCodaMeter.tcl
218
219 %files server   
220 /usr/sbin/rvmutl
221 /usr/sbin/rdsinit
222 /usr/sbin/startserver
223 /usr/sbin/partial-reinit.sh
224 /usr/sbin/createvol_rep
225 /usr/sbin/purgevol
226 /usr/sbin/purgevol_rep
227 /usr/sbin/bldvldb.sh
228 /usr/sbin/vice-setup
229 /usr/sbin/vice-setup-rvm
230 /usr/sbin/vice-setup-srvdir
231 /usr/sbin/vice-setup-user
232 /usr/sbin/vice-setup-scm
233 /usr/sbin/vice-setup-ports
234 /usr/sbin/vice-killvolumes
235 /usr/sbin/pcfgen
236 /usr/sbin/pwd2pdb
237 /usr/sbin/mvdb
238 /usr/sbin/auth2
239 /usr/sbin/initpw
240 /usr/sbin/volutil
241 /usr/sbin/rpc2portmap
242 /usr/sbin/makeftree
243 /usr/sbin/inoder
244 /usr/sbin/parserecdump
245 /usr/sbin/codasrv
246 /usr/sbin/printvrdb
247 /usr/sbin/updatesrv
248 /usr/sbin/updateclnt
249 /usr/sbin/updatefetch
250 /usr/bin/filcon
251 /usr/bin/norton
252 /usr/bin/norton-reinit
253 /usr/bin/reinit
254 /etc/rc.d/init.d/codasrv.init
255 /etc/rc.d/init.d/auth2.init
256 /etc/rc.d/init.d/update.init
257
258 %files backup   
259 /usr/sbin/backup.sh
260 /usr/sbin/tape.pl
261 /usr/sbin/auth2
262 /usr/sbin/volutil
263 /usr/sbin/backup
264 /usr/sbin/readdump
265 /usr/sbin/merge
266 /usr/sbin/updatesrv
267 /usr/sbin/updateclnt
268 /usr/sbin/updatefetch
269 /usr/bin/filcon
This page took 0.084938 seconds and 4 git commands to generate.