]> git.pld-linux.org Git - packages/coda.git/blob - coda.spec
kosmetyka
[packages/coda.git] / coda.spec
1 Summary:        Coda distributed filesystem
2 Name:           coda
3 Version:        5.2.4
4 Release:        1
5 Copyright:      CMU
6 Group:          Networking/Daemons
7 Source:         ftp://ftp.coda.cs.cmu.edu/pub/coda/src/%{name}-%{version}.tgz
8 Requires:       bc
9 BuildRoot:      /tmp/%{name}-%{version}-root
10
11 %description
12 Source package for the Coda filesystem.  Three packages are provided by
13 this rpm: the client and server and the backup components. Separately
14 you must install a kernel module, or have a Coda enabled kernel, and 
15 you should get the Coda documentation package.
16
17 %package client
18 Summary:        Coda client
19 Group:          Networking/Daemons
20
21 %description client
22 This package contains the main client program, the cachemanager Venus.
23 Also included are the binaries for the cfs, utilities for logging, ACL
24 manipulation etc, the hoarding tools for use with laptops and repair
25 tools for fixing conflicts. Finally there is the cmon and codacon
26 console utilities to monitor Coda's activities. You need a Coda
27 kernel-module for your kernel version, or Coda in your kernel, to have
28 a complete coda client.  Make sure to select the correct C library
29 version.
30
31 %package server
32 Summary:        Coda server
33 Group:          Networking/Daemons
34
35 %description server
36 This package contains the fileserver codasrv for the coda filesystem,
37 as well as the volume utilities.  For highest performance you will
38 need a modified kernel with inode system calls.
39
40 %package backup
41 Summary: Coda backup coordinator
42 Group: Networking/Daemons
43 %description backup
44 This package contains the backup software for the coda filesystem, as
45 well as the volume utilities.
46
47         
48 %prep
49 %setup -q
50
51 %build
52 CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
53 ./configure %{_target_platform} \
54         --prefix=/usr
55 make
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 install -d $RPM_BUILD_ROOT/usr/coda/venus.cache $RPM_BUILD_ROOT/dev \
60         $RPM_BUILD_ROOT/usr/coda/etc \
61         $RPM_BUILD_ROOT/coda $RPM_BUILD_ROOT/etc/rc.d/init.d\
62         $RPM_BUILD_ROOT%{_libdir}/coda
63
64 make client-install
65 make server-install
66
67 touch $RPM_BUILD_ROOT/usr/coda/venus.cache/INIT
68 mknod $RPM_BUILD_ROOT/dev/cfs0 c 67 0
69 touch $RPM_BUILD_ROOT/coda/NOT_REALLY_CODA
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %pre client
75 grep "^coda" /proc/mounts > /dev/null 2>&1
76 if [ $? = 0 ]; then
77         echo "*** Coda is mounted: cannot install ***"
78         exit 1
79 else
80         exit 0
81 fi
82
83 %preun client
84 grep "^coda" /proc/mounts > /dev/null 2>&1
85 if [ $? = 0 ]; then
86         echo "*** Coda is mounted: cannot uninstall ***"
87         exit 1
88 else
89         exit 0
90 fi
91         
92 %post client
93 if [ -e /usr/coda/etc/vstab ]; then 
94         touch /usr/coda/venus.cache/INIT
95 else
96         %{_sbindir}/venus-setup testserver.coda.cs.cmu.edu 40000
97 fi
98
99 cd %{_libdir}/coda
100 if [ ! -x %{_bindir}/tixindex ]; then
101         chmod a+x %{_bindir}/tixindex 
102 fi
103 tixindex *tcl
104 #if [ ! -f %{_bindir}/tixwish ]; then
105 #       ln -s %{_bindir}/tixwish* /usr/bin/tixwish
106 #       if [ x$? != x0 ]; then
107 #               echo "**WARNING: tixwish is not correctly installed"
108 #       fi
109 #fi
110 /sbin/chkconfig --add venus.init
111
112 %postun
113 /sbin/chkconfig --del venus.init
114
115 %post server
116 /sbin/chkconfig --add update.init
117 /sbin/chkconfig --add auth2.init
118 /sbin/chkconfig --add codasrv.init
119
120 %postun server
121 /sbin/chkconfig --del update.init
122 /sbin/chkconfig --del auth2.init
123 /sbin/chkconfig --del codasrv.init
124
125
126 %files client
127 /dev/cfs0
128 %dir /usr/coda
129 %dir /usr/coda/etc
130 %dir /usr/coda/venus.cache
131 %verify() /usr/coda/venus.cache/INIT
132 /etc/rc.d/init.d/venus.init
133 %dir /coda
134 %verify() /coda/NOT_REALLY_CODA
135 %{_sbindir}/venus-setup
136 %{_sbindir}/vutil
137 %{_sbindir}/venus
138 %{_sbindir}/au
139 %{_bindir}/advice_srv
140 %{_bindir}/filcon
141 %{_bindir}/clog
142 %{_bindir}/cpasswd
143 %{_bindir}/ctokens
144 %{_bindir}/cunlog
145 %{_bindir}/repair
146 %{_bindir}/cmon
147 %{_bindir}/codacon
148 %{_bindir}/cfs
149 %{_bindir}/hoard
150 %{_bindir}/spy
151 %{_bindir}/replay
152 %{_bindir}/parser
153 %{_bindir}/filerepair
154 %{_bindir}/removeinc
155 %{_bindir}/xfrepair
156 %{_bindir}/xaskuser
157 %{_bindir}/logbandwidth
158 %{_bindir}/logcmls
159 %{_bindir}/logreintegration
160 %{_sbindir}/volmunge
161 %{_libdir}/coda/Advice.tcl
162 %{_libdir}/coda/CodaConsole
163 %{_libdir}/coda/Consider.tcl
164 %{_libdir}/coda/ConsiderAdding.tcl
165 %{_libdir}/coda/ConsiderRemoving.tcl
166 %{_libdir}/coda/ControlPanel.tcl
167 %{_libdir}/coda/Date.tcl
168 %{_libdir}/coda/DiscoMiss.tcl
169 %{_libdir}/coda/Events.tcl
170 %{_libdir}/coda/Globals.tcl
171 %{_libdir}/coda/Helper.tcl
172 %{_libdir}/coda/HoardWalk.tcl
173 %{_libdir}/coda/HoardWalkAdvice.tcl
174 %{_libdir}/coda/Indicators.tcl
175 %{_libdir}/coda/Initialization.tcl
176 %{_libdir}/coda/Lock.tcl
177 %{_libdir}/coda/Log.tcl
178 %{_libdir}/coda/Network.tcl
179 %{_libdir}/coda/OutsideWorld.tcl
180 %{_libdir}/coda/ReadMiss.tcl
181 %{_libdir}/coda/Reconnection.tcl
182 %{_libdir}/coda/Reintegration.tcl
183 %{_libdir}/coda/Repair.tcl
184 %{_libdir}/coda/Space.tcl
185 %{_libdir}/coda/Task.tcl
186 %{_libdir}/coda/Timing.tcl
187 %{_libdir}/coda/Tokens.tcl
188 %{_libdir}/coda/WeakMiss.tcl
189 %{_libdir}/coda/tixCodaMeter.tcl
190
191 %files server   
192 %{_sbindir}/rvmutl
193 %{_sbindir}/rdsinit
194 %{_sbindir}/startserver
195 %{_sbindir}/partial-reinit.sh
196 %{_sbindir}/createvol_rep
197 %{_sbindir}/purgevol
198 %{_sbindir}/purgevol_rep
199 %{_sbindir}/bldvldb.sh
200 %{_sbindir}/vice-setup
201 %{_sbindir}/vice-setup-rvm
202 %{_sbindir}/vice-setup-srvdir
203 %{_sbindir}/vice-setup-user
204 %{_sbindir}/vice-setup-scm
205 %{_sbindir}/vice-setup-ports
206 %{_sbindir}/vice-killvolumes
207 %{_sbindir}/pcfgen
208 %{_sbindir}/pwd2pdb
209 %{_sbindir}/mvdb
210 %{_sbindir}/auth2
211 %{_sbindir}/initpw
212 %{_sbindir}/volutil
213 %{_sbindir}/rpc2portmap
214 %{_sbindir}/makeftree
215 %{_sbindir}/inoder
216 %{_sbindir}/parserecdump
217 %{_sbindir}/codasrv
218 %{_sbindir}/printvrdb
219 %{_sbindir}/updatesrv
220 %{_sbindir}/updateclnt
221 %{_sbindir}/updatefetch
222 %{_bindir}/filcon
223 %{_bindir}/norton
224 %{_bindir}/norton-reinit
225 %{_bindir}/reinit
226 /etc/rc.d/init.d/codasrv.init
227 /etc/rc.d/init.d/auth2.init
228 /etc/rc.d/init.d/update.init
229
230 %files backup   
231 %{_sbindir}/backup.sh
232 %{_sbindir}/tape.pl
233 %{_sbindir}/auth2
234 %{_sbindir}/volutil
235 %{_sbindir}/backup
236 %{_sbindir}/readdump
237 %{_sbindir}/merge
238 %{_sbindir}/updatesrv
239 %{_sbindir}/updateclnt
240 %{_sbindir}/updatefetch
241 %{_bindir}/filcon
242
243 %changelog
244 * Fri Feb 12 1999 Bernhard Rosenkraenzer <bero@microsoft.sucks.eu.org>
245 - adapt to BeroLinux
246
247 * Sun Jun 21 1998 Peter Braam <braam@cs.cmu.edu>
248 - get rid of the kernel package. This needs interaction during the build.
249 - no more separate libc, glibc packages
250
251 * Tue Dec 30 1997 Peter Braam <braam@cs.cmu.edu>
252 - several changes: documentation separate
253 - use variables: =`uname -r`, 5.0.1=coda version
254
255 * Mon Jun 02 1997 Peter Braam <braam@cs.cmu.edu>
256 - small changes to Elliots improvements.
257 - some of his ideas are now in the scripts
258
259 * Wed May 28 1997 Elliot Lee <sopwith@redhat.com>
260 - Based upon 4.0.3-1 spec file.
261 - Changed to BuildRoot
262 - Do as much as possible at build time instead of in %post
263 - Added initscript for venus
This page took 0.043185 seconds and 4 git commands to generate.