]> git.pld-linux.org Git - packages/cocoon.git/blob - cocoon.spec
- Group changed to Applications/Publishing/XML/Java
[packages/cocoon.git] / cocoon.spec
1
2 %define fopver 0_15_0
3 %define xalanver 1_2_D02
4 %define xercesver 1_2
5
6 Summary:        The servlet XML transformation system
7 Name:           cocoon
8 Version:        1.8.2
9 Release:        2
10 License:        Apache
11 Group:          Applications/Publishing/XML/Java
12 Group(de):      Applikationen/Publizieren/XML/Java
13 Group(pl):      Aplikacje/Publikowanie/XML/Java
14 Source0:        http://xml.apache.org/cocoon/dist/Cocoon-%{version}.tar.gz
15 Source1:        %{name}-web.xml
16 Source2:        %{name}-webapp.conf
17 Patch0:         %{name}-paths.patch
18 URL:            http://xml.apache.org/cocoon/
19 Requires:       jre >= 1.1
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21 BuildArch:      noarch
22
23 %description
24 Cocoon is a 100% pure Java publishing framework that relies on new W3C
25 technologies (such as XML and XSL) to provide web content.
26
27 %package doc
28 Group:          Applications/Publishing/XML/Java
29 Group(de):      Applikationen/Publizieren/XML/Java
30 Group(pl):      Aplikacje/Publikowanie/XML/Java
31 Summary:        Online manual for Cocoon
32
33 %description doc
34 Documentation for Cocoon, viewable through your web server, too.
35
36 %package optional
37 Group:          Applications/Publishing/XML/Java
38 Group(de):      Applikationen/Publizieren/XML/Java
39 Group(pl):      Aplikacje/Publikowanie/XML/Java
40 Requires:       cocoon = %{version}
41 Summary:        Optional jars for cocoon
42
43 %description optional
44 Additional functionality for Cocoon:
45  - bsfengines - Bean Scripting Framework (Xalan existion)
46  - bsf - Bean Scripting Framework (Xalan existion functions)
47  - fop - converts xsl:fo into PDF output
48
49 %package sax-bugfix
50 Group:          Applications/Publishing/XML/Java
51 Group(de):      Applikationen/Publizieren/XML/Java
52 Group(pl):      Aplikacje/Publikowanie/XML/Java
53 Requires:       cocoon = %{version}
54 Summary:        Fixes error reporting bug
55
56 %description sax-bugfix
57 Note The sax-bugfix.jar is an optional, unofficial bugfix - which must
58 be ahead of xerces in the CLASSPATH to work - to allow you to see line
59 numbers and column numbers in XML parsing error messages, and is only
60 needed on some virtual machines. If you get "sealing violations", try
61 removing it from your CLASSPATH.
62
63 %package samples
64 Group:          Applications/Publishing/XML/Java
65 Group(de):      Applikationen/Publizieren/XML/Java
66 Group(pl):      Aplikacje/Publikowanie/XML/Java
67 Requires:       cocoon = %{version}
68 Summary:        Samples for cocoon
69
70 %description samples
71 This directory contains samples to show you the power of the Cocoon
72 Publishing Framework. Each subdirectory contains examples of possible
73 uses that should give you insights on Cocoon capabilities as well as
74 real-life suggestions on how to XML-ize your web-serving environment.
75
76 %package xmldoc
77 Group:          Applications/Publishing/XML/Java
78 Group(de):      Applikationen/Publizieren/XML/Java
79 Group(pl):      Aplikacje/Publikowanie/XML/Java
80 Requires:       cocoon = %{version}
81 Summary:        Documentation for cocoon in XML
82
83 %description xmldoc
84 Documentation for cocoon in XML
85
86 %prep
87 %setup -q
88 %patch0 -p1
89
90 %build
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 install -d $RPM_BUILD_ROOT%{_datadir}/%{name} \
95         $RPM_BUILD_ROOT%{_datadir}/%{name}/{lib,conf} \
96         $RPM_BUILD_ROOT/home/httpd/%{name}/WEB-INF \
97         $RPM_BUILD_ROOT%{_localstatedir}/lib/%{name}/repository
98
99 cp bin/cocoon.jar \
100         lib/{turbine-pool,w3c,xalan_%{xalanver},xerces_%{xercesver}}.jar \
101         $RPM_BUILD_ROOT%{_datadir}/%{name}/lib
102 cp lib/{bsfengines,bsf,fop_%{fopver}}.jar \
103         $RPM_BUILD_ROOT%{_datadir}/%{name}/lib
104 cp lib/sax-bugfix.jar $RPM_BUILD_ROOT%{_datadir}/%{name}/lib
105
106 cp index.html $RPM_BUILD_ROOT/home/httpd/%{name}
107
108 cp %{SOURCE1} $RPM_BUILD_ROOT/home/httpd/%{name}/WEB-INF/web.xml
109 cp conf/cocoon.properties $RPM_BUILD_ROOT%{_datadir}/%{name}/conf
110 cp %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/%{name}/conf/webapp.conf
111
112 cp -R samples $RPM_BUILD_ROOT/home/httpd/%{name}
113
114 mv {todo,changes}.xml xdocs
115 cp -R xdocs $RPM_BUILD_ROOT/home/httpd/%{name}
116
117 gzip -9nf LICENSE README
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post
123 ln -sf %{_datadir}/%{name}/{lib,conf/cocoon.properties} /home/httpd/%{name}/WEB-INF
124
125 %postun
126 rm -rf /home/httpd/%{name}/WEB-INF/{lib,cocoon.properties}
127
128 %post doc
129 ln -sf %{_defaultdocdir}/%{name}-doc-%{version}/docs /home/httpd/%{name}
130
131 %postun doc
132 rm -rf /home/httpd/%{name}/docs
133
134 %files
135 %defattr(644,root,root,755)
136 %attr(0640,root,http) %config(noreplace) %verify(not size mtime md5) %{_datadir}/%{name}/conf/cocoon.properties
137 %attr(0640,root,http) %config(noreplace) %verify(not size mtime md5) %{_datadir}/%{name}/conf/webapp.conf
138 %attr(0640,root,http) %config(noreplace) %verify(not size mtime md5) /home/httpd/%{name}/WEB-INF/web.xml
139 %attr(0750,root,http) %dir %{_localstatedir}/lib/%{name}/repository
140 /home/httpd/%{name}/index.html
141 %{_datadir}/%{name}/lib/cocoon.jar
142 %{_datadir}/%{name}/lib/turbine-pool.jar
143 %{_datadir}/%{name}/lib/w3c.jar
144 %{_datadir}/%{name}/lib/xalan_%{xalanver}.jar
145 %{_datadir}/%{name}/lib/xerces_%{xercesver}.jar
146 %doc LICENSE.gz README.gz
147
148 %files doc
149 %defattr(644,root,root,755)
150 %doc docs
151
152 %files optional
153 %defattr(644,root,root,755)
154 %{_datadir}/%{name}/lib/bsfengines.jar
155 %{_datadir}/%{name}/lib/bsf.jar
156 %{_datadir}/%{name}/lib/fop_%{fopver}.jar
157
158 %files sax-bugfix
159 %defattr(644,root,root,755)
160 %{_datadir}/%{name}/lib/sax-bugfix.jar
161
162 %files samples
163 %defattr(644,root,root,755)
164 /home/httpd/%{name}/samples
165
166 %files xmldoc
167 %defattr(644,root,root,755)
168 /home/httpd/%{name}/xdocs
This page took 0.22718 seconds and 4 git commands to generate.