]> git.pld-linux.org Git - packages/cmdtest.git/blob - cmdtest.spec
353489c3b1a0b30a74f5843fd0269be75335447d
[packages/cmdtest.git] / cmdtest.spec
1 Summary:        Black-box testing for Unix command line tools
2 Name:           cmdtest
3 Version:        0.9
4 Release:        1
5 License:        GPL v3+
6 Group:          Development/Building
7 Source0:        http://code.liw.fi/debian/pool/main/c/cmdtest/%{name}_%{version}.orig.tar.gz
8 # Source0-md5:  5fff5c87c8b01b261f73bd4ae1277ed5
9 URL:            http://liw.fi/cmdtest/
10 BuildRequires:  python-cliapp
11 BuildRequires:  python-coverage-test-runner
12 BuildRequires:  python-markdown
13 BuildRequires:  python-ttystatus
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  rpmbuild(macros) >= 1.219
16 Requires:       python-cliapp
17 Requires:       python-ttystatus
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 cmdtest black box tests Unix command line tools. Roughly, it is given
23 a command line and input files, and the expected output, and it
24 verifies that the command line produces the expected output. If not,
25 it reports a problem, and shows the differences.
26
27 %prep
28 %setup -q
29
30 %build
31 %if %{with tests}
32 # CoverageTestRunner trips up on build directory;
33 # remove it first
34 rm -rf build
35 %{__python} setup.py check
36 %endif
37
38 %{__python} setup.py build
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 %{__python} setup.py install \
43         --skip-build \
44         --optimize=2 \
45         --root=$RPM_BUILD_ROOT
46
47 %{__rm} $RPM_BUILD_ROOT%{py_sitescriptdir}/yarnlib/*_tests.py*
48
49 %py_postclean
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc NEWS README README.yarn
57 %attr(755,root,root) %{_bindir}/cmdtest
58 %attr(755,root,root) %{_bindir}/yarn
59 %{_mandir}/man1/cmdtest.1*
60 %{_mandir}/man1/yarn.1*
61 %{py_sitescriptdir}/cmdtestlib.py[co]
62 %{py_sitescriptdir}/cmdtest-%{version}-py*.egg-info
63 %dir %{py_sitescriptdir}/yarnlib
64 %{py_sitescriptdir}/yarnlib/*.py[co]
This page took 0.043435 seconds and 2 git commands to generate.