]> git.pld-linux.org Git - packages/cmake.git/commitdiff
Rediff.
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 12 Apr 2021 20:19:47 +0000 (22:19 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 12 Apr 2021 20:19:54 +0000 (22:19 +0200)
cmake-findruby2.patch
cmake-helpers.patch

index bdd9c3747da11fdfcf85c817317a3b93f0be8390..2f6677fb5187a4f7131bff115203a16577132669 100644 (file)
@@ -1,10 +1,11 @@
---- cmake-2.8.12.2/Modules/FindRuby.cmake~     2014-08-26 22:03:46.000000000 +0200
-+++ cmake-2.8.12.2/Modules/FindRuby.cmake      2014-08-26 22:05:53.115892137 +0200
-@@ -170,6 +170,7 @@
+diff -urNp -x '*.orig' cmake-3.17.2.org/Modules/FindRuby.cmake cmake-3.17.2/Modules/FindRuby.cmake
+--- cmake-3.17.2.org/Modules/FindRuby.cmake    2021-04-12 22:19:23.761018307 +0200
++++ cmake-3.17.2/Modules/FindRuby.cmake        2021-04-12 22:19:24.521040438 +0200
+@@ -207,6 +207,7 @@ if( "${Ruby_FIND_VERSION_SHORT_NODOT}" G
    find_path(RUBY_CONFIG_INCLUDE_DIR
      NAMES ruby/config.h  config.h
      HINTS
 +      ${RUBY_HDR_DIR}
        ${RUBY_HDR_DIR}/${RUBY_ARCH}
        ${RUBY_ARCH_DIR}
-   )
+       ${RUBY_ARCHHDR_DIR}
index 6284b808f8e81404c9d1729e95fd80eb5fdd4730..904863fd808491a03c2751339a842478a57dc2d9 100644 (file)
@@ -1,15 +1,18 @@
---- cmake-3.0.2/Auxiliary/bash-completion/CMakeLists.txt.orig  2013-10-07 17:31:00.000000000 +0200
-+++ cmake-3.0.2/Auxiliary/bash-completion/CMakeLists.txt       2013-10-20 17:12:23.756481217 +0200
+diff -urNp -x '*.orig' cmake-3.17.2.org/Auxiliary/CMakeLists.txt cmake-3.17.2/Auxiliary/CMakeLists.txt
+--- cmake-3.17.2.org/Auxiliary/CMakeLists.txt  2020-04-28 16:23:06.000000000 +0200
++++ cmake-3.17.2/Auxiliary/CMakeLists.txt      2021-04-12 22:18:36.892988114 +0200
+@@ -1,4 +1,4 @@
+ install(DIRECTORY vim/indent vim/syntax DESTINATION ${CMAKE_DATA_DIR}/editors/vim)
+-install(FILES cmake-mode.el DESTINATION ${CMAKE_DATA_DIR}/editors/emacs)
++install(FILES cmake-mode.el DESTINATION ${CMAKE_INSTALL_DATADIR}/emacs/site-lisp)
+ install(FILES cmake.m4 DESTINATION ${CMAKE_XDGDATA_DIR}/aclocal)
+ add_subdirectory (bash-completion)
+diff -urNp -x '*.orig' cmake-3.17.2.org/Auxiliary/bash-completion/CMakeLists.txt cmake-3.17.2/Auxiliary/bash-completion/CMakeLists.txt
+--- cmake-3.17.2.org/Auxiliary/bash-completion/CMakeLists.txt  2020-04-28 16:23:06.000000000 +0200
++++ cmake-3.17.2/Auxiliary/bash-completion/CMakeLists.txt      2021-04-12 22:18:36.892988114 +0200
 @@ -5,4 +5,4 @@
  # add symlinks to the files in appropriate places
  #  /etc/bash_completion.d/
  #  DATADIR/completions (may be /usr/share/<package>/completions
 -install(FILES cmake cpack ctest DESTINATION ${CMAKE_DATA_DIR}/completions)
 +install(FILES cmake cpack ctest DESTINATION ${CMAKE_INSTALL_DATADIR}/bash-completion/completions)
---- cmake-3.0.2/Auxiliary/CMakeLists.txt.orig  2013-10-20 17:07:32.733160096 +0200
-+++ cmake-3.0.2/Auxiliary/CMakeLists.txt       2013-10-20 17:13:38.969811394 +0200
-@@ -1,3 +1,3 @@
- install(FILES cmake-help.vim cmake-indent.vim cmake-syntax.vim DESTINATION ${CMAKE_DATA_DIR}/editors/vim)
--install(FILES cmake-mode.el DESTINATION ${CMAKE_DATA_DIR}/editors/emacs)
-+install(FILES cmake-mode.el DESTINATION ${CMAKE_INSTALL_DATADIR}/emacs/site-lisp)
- add_subdirectory (bash-completion)
This page took 0.214534 seconds and 4 git commands to generate.