]> git.pld-linux.org Git - packages/cmake.git/blobdiff - cmake.spec
- more x32 macro fixes
[packages/cmake.git] / cmake.spec
index 61c68d0dd513606ada00fc973e12c86a45e7556d..f37980e7b9228f498d2d06d668cc377bf5f1859d 100644 (file)
@@ -1,4 +1,5 @@
 # TODO:
+# - extend libx32 patch to work also on 64-bit arch
 # - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
 #   (and default non-verbose makefiles are hiding it!)
 # - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
@@ -7,33 +8,34 @@
 # Conditional build:
 %bcond_with    bootstrap       # use internal versions of some libraries
 %bcond_without gui             # don't build gui package
-%bcond_without tests           # do not perform "make test"
+%bcond_with    tests           # perform "make test"
 %bcond_without doc             # don't build documentation
 
 Summary:       Cross-platform, open-source make system
 Summary(pl.UTF-8):     Wieloplatformowy system make o otwartych źródłach
 Name:          cmake
-Version:       3.1.0
+Version:       3.2.2
 Release:       2
 License:       BSD
 Group:         Development/Building
-Source0:       http://www.cmake.org/files/v3.1/%{name}-%{version}.tar.gz
-# Source0-md5: 188eb7dc9b1b82b363bc51c0d3f1d461
+Source0:       http://www.cmake.org/files/v3.2/%{name}-%{version}.tar.gz
+# Source0-md5: 2da57308071ea98b10253a87d2419281
 Patch0:                %{name}-lib64.patch
 Patch1:                %{name}-helpers.patch
 Patch2:                %{name}-findruby.patch
 Patch3:                %{name}-tests.patch
-Patch4:                %{name}-bug-0015258.patch
+
 Patch5:                %{name}-findruby2.patch
 Patch6:                %{name}-findpython.patch
 Patch7:                %{name}-libx32.patch
 URL:           http://www.cmake.org/
 %{?with_gui:BuildRequires:     QtGui-devel}
+BuildRequires: jsoncpp-devel >= 1.6.2-2
 BuildRequires: libarchive-devel
 BuildRequires: libstdc++-devel
 BuildRequires: ncurses-devel > 5.9-3
-%{?with_gui:BuildRequires:     qt4-build}
-%{?with_gui:BuildRequires:     qt4-qmake}
+%{?with_gui:BuildRequires:     qt5-build}
+%{?with_gui:BuildRequires:     qt5-qmake}
 BuildRequires: rpmbuild(macros) >= 1.167
 %{?with_doc:BuildRequires:     sphinx-pdg}
 %{!?with_bootstrap:BuildRequires:      xmlrpc-c-devel >= 1.4.12-2}
@@ -117,7 +119,7 @@ Bashowe dopełnianie parametrów dla cmake'a.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
+
 %patch5 -p1
 %patch6 -p1
 %if "%{_lib}" == "libx32"
@@ -146,7 +148,7 @@ export LDFLAGS="%{rpmldflags}"
        --init=init.cmake \
        %{!?with_bootstrap:--system-libs} \
        %{?with_gui:--qt-gui} \
-       --qt-qmake=/usr/bin/qmake-qt4 \
+       --qt-qmake=%{_bindir}/qmake-qt4 \
        %{?with_doc:--sphinx-html} \
        %{?with_doc:--sphinx-man} \
        --verbose
@@ -191,6 +193,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man7/cmake-qt.7*
 %{_mandir}/man7/cmake-toolchains.7*
 %{_mandir}/man7/cmake-variables.7*
+%{_datadir}/cmake/Help
 %endif
 # top cmake/Modules dirs belong to filesystem
 %{_datadir}/cmake/Modules/.NoDartCoverage
@@ -210,10 +213,10 @@ rm -rf $RPM_BUILD_ROOT
 %files gui
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/cmake-gui
-%{_datadir}/cmake/Help
 %{_datadir}/mime/packages/cmakecache.xml
 %{_desktopdir}/CMake.desktop
-%{_pixmapsdir}/CMakeSetup32.png
+%{_iconsdir}/hicolor/128x128/apps/CMakeSetup.png
+%{_iconsdir}/hicolor/32x32/apps/CMakeSetup.png
 %{_mandir}/man1/cmake-gui.1*
 %endif
 
@@ -223,6 +226,6 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n bash-completion-%{name}
 %defattr(644,root,root,755)
-%{_datadir}/bash-completion/completions/cmake
-%{_datadir}/bash-completion/completions/cpack
-%{_datadir}/bash-completion/completions/ctest
+%{bash_compdir}/cmake
+%{bash_compdir}/cpack
+%{bash_compdir}/ctest
This page took 0.033728 seconds and 4 git commands to generate.