]> git.pld-linux.org Git - packages/cmake.git/blobdiff - cmake.spec
- I guess this patch is not really necessary (will look at it tomorrow)
[packages/cmake.git] / cmake.spec
index d5eb062dcf4da4e80e059aafdcf721cc1a2adafc..6d6761ac906c38c3c67bc652d91df50538d1d3de 100644 (file)
@@ -1,56 +1,68 @@
-%define name cmake
-%define version 1.4.7
-%define release 1
-
-Summary: Cross-platform, open-source make system
-Name: %name
-Version: %version
-Release: %release
-License: BSD
-Group: Development/Other
-Url: http://www.cmake.org/HTML/Index.html
-Source: CMake%{version}-src-unix.tar.bz2
-Patch0: cmake-ncurses.patch
-BuildRoot: %_tmppath/%name-%version
+Summary:       Cross-platform, open-source make system
+Summary(pl):   Wieloplatformowy system make o otwartych ¼ród³ach
+Name:          cmake
+Version:       1.8.3
+Release:       1
+License:       BSD
+Group:         Development/Building
+# current: http://www.cmake.org/files/v2.0/cmake-2.0.2.tar.gz
+Source0:       http://www.cmake.org/files/v1.8/%{name}-%{version}.tar.gz       
+# Source0-md5: 781afe6ed9000e303bf6ac3e4e384dce
+Patch0:                %{name}-ncurses.patch
+URL:           http://www.cmake.org/
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-CMake is used to control the software compilation process using
-simple platform and compiler independent configuration files.
-CMake generates native makefiles and workspaces that can be
-used in the compiler environment of your choice. CMake is quite
-sophisticated: it is possible to support complex environments
-requiring system configuration, pre-processor generation, code
-generation, and template instantiation.
+CMake is used to control the software compilation process using simple
+platform and compiler independent configuration files. CMake generates
+native makefiles and workspaces that can be used in the compiler
+environment of your choice. CMake is quite sophisticated: it is
+possible to support complex environments requiring system
+configuration, pre-processor generation, code generation, and template
+instantiation.
+
+%description -l pl
+CMake s³u¿y do sterowania procesem kompilacji oprogramowania przy
+u¿yciu prostych plików konfiguracyjnych niezale¿nych od platformy i
+kompilatora. CMake generuje natywne pliki makefile i workspace,
+których mo¿na u¿ywaæ w wybranym ¶rodowisku kompilatora. CMake jest
+do¶æ przemy¶lany: mo¿e obs³u¿yæ z³o¿one ¶rodowiska wymagaj±ce
+konfiguracji systemu, generowanie preprocesora, generowanie kodu i
+dziedziczenie szablonów.
 
 %prep
-%setup -q -n CMake-%version
+%setup -q
 %patch0 -p1
 
 %build
-CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
-%configure2_13
-%{__make} \
-       CXXFLAGS="%{rpmcflags} -I/usr/include/ncurses"
+./bootstrap \
+       --prefix=%{_prefix} \
+       --mandir=/share/man \
+       --datadir=/share/cmake \
+       --verbose
+
+./Bootstrap.cmk/cmake \
+       -DCURSES_INCLUDE_PATH=%{_includedir}/ncurses
+
+%{__make}
+       
 
 %install
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
-mv $RPM_BUILD_ROOT/usr/man $RPM_BUILD_ROOT/%_datadir/
-bzip2 $RPM_BUILD_ROOT/%_datadir/man/man1/*
+rm -rf $RPM_BUILD_ROOT
+
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+rm -rf $RPM_BUILD_ROOT/usr/doc
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
-%defattr(-,root,root)
-%doc ChangeLog.txt *.pdf *.rtf Copyright.txt *.gif
-%_bindir/ccmake
-%_bindir/cmake
-%_bindir/cmaketest
-%_bindir/ctest
-%_mandir/man1/*.1.*
-%_datadir/CMake/Modules
-%_datadir/CMake/Templates
-
-%changelog
-* Thu Jan 9 2003 Austin Acton <aacton@yorku.ca> 1.4.7-1mdk
-- initial package
+%defattr(644,root,root,755)
+%doc ChangeLog.txt *.pdf *.rtf Copyright.txt *.gif Docs/{cmake,ccmake,ctest}.*
+%attr(755,root,root) %{_bindir}/ccmake
+%attr(755,root,root) %{_bindir}/cmake
+%attr(755,root,root) %{_bindir}/ctest
+%{_mandir}/man1/*.1*
+%{_datadir}/cmake
This page took 0.091816 seconds and 4 git commands to generate.