]> git.pld-linux.org Git - packages/cmake.git/blobdiff - cmake.spec
- added fix for ruby 2.x b/c of moved RUBY_CONFIG_INCLUDE_DIR
[packages/cmake.git] / cmake.spec
index d4b318dad1809e47c505c41929c56a2d74457867..39401dbb72b28a303c3a4f34eb7bf79755015082 100644 (file)
@@ -7,17 +7,23 @@
 # Conditional build:
 %bcond_with    bootstrap       # use internal versions of some libraries
 %bcond_without gui             # don't build gui package
+%bcond_without tests           # do not perform "make test"
 
 Summary:       Cross-platform, open-source make system
 Summary(pl.UTF-8):     Wieloplatformowy system make o otwartych źródłach
 Name:          cmake
-Version:       2.8.6
+Version:       2.8.12.2
 Release:       1
 License:       BSD
 Group:         Development/Building
 Source0:       http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
-# Source0-md5: 2147da452fd9212bb9b4542a9eee9d5b
+# Source0-md5: 17c6513483d23590cbce6957ec6d1e66
 Patch0:                %{name}-lib64.patch
+Patch1:                %{name}-helpers.patch
+Patch2:                %{name}-findruby.patch
+Patch3:                %{name}-tests.patch
+Patch4:                %{name}-freetype2.patch
+Patch5:                %{name}-findruby2.patch
 URL:           http://www.cmake.org/
 %{?with_gui:BuildRequires:     QtGui-devel}
 BuildRequires: libarchive-devel
@@ -27,7 +33,7 @@ BuildRequires:        ncurses-devel > 5.9-3
 %{?with_gui:BuildRequires:     qt4-qmake}
 BuildRequires: rpmbuild(macros) >= 1.167
 %{!?with_bootstrap:BuildRequires:      xmlrpc-c-devel >= 1.4.12-2}
-Requires:      filesystem >= 3.0-46
+Requires:      filesystem >= 3.0-52
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -61,14 +67,48 @@ This package contains the Qt based GUI for CMake.
 Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
 CMake.
 
+%package emacs
+Summary:       Emacs mode for cmake files
+Summary(pl.UTF-8):     Tryb Emacsa dla plików cmake'a
+Group:         Development/Tools
+
+%description emacs
+Emacs mode for cmake files.
+
+%description emacs -l pl.UTF-8
+Tryb Emacsa dla plików cmake'a.
+
+%package -n bash-completion-%{name}
+Summary:       bash-completion for cmake
+Summary(pl.UTF-8):     Bashowe dopełnianie parametrów dla cmake'a
+Group:         Applications/Shells
+Requires:      %{name} = %{version}-%{release}
+Requires:      bash-completion >= 2.0
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
+
+%description -n bash-completion-%{name}
+bash-completion for cmake.
+
+%description -n bash-completion-%{name} -l pl.UTF-8
+Bashowe dopełnianie parametrów dla cmake'a.
+
 %prep
 %setup -q
 %if "%{_lib}" == "lib64"
 %patch0 -p1
 %endif
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
 
 cat > "init.cmake" <<EOF
 SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
+SET (CMAKE_INSTALL_SYSCONFDIR "%{_sysconfdir}" CACHE PATH " " FORCE)
+SET (CMAKE_INSTALL_DATADIR "%{_datadir}" CACHE PATH " " FORCE)
 EOF
 
 %build
@@ -89,13 +129,14 @@ export LDFLAGS="%{rpmldflags}"
 
 %{__make} VERBOSE=1
 
+%{?with_tests:%{__make} test}
+
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_libdir}/cmake
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-rm -r $RPM_BUILD_ROOT%{_prefix}/doc
+%{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -121,8 +162,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/cmake/Modules/.NoDartCoverage
 %{_datadir}/cmake/Modules/*
 %{_datadir}/cmake/Templates
+%{_datadir}/cmake/editors
 %{_datadir}/cmake/include
-%dir %{_libdir}/cmake
 %{_aclocaldir}/cmake.m4
 
 %if %{with gui}
@@ -134,3 +175,13 @@ rm -rf $RPM_BUILD_ROOT
 %{_pixmapsdir}/CMakeSetup32.png
 %{_mandir}/man1/cmake-gui.1*
 %endif
+
+%files emacs
+%defattr(644,root,root,755)
+%{_datadir}/emacs/site-lisp/cmake-mode.el
+
+%files -n bash-completion-%{name}
+%defattr(644,root,root,755)
+%{_datadir}/bash-completion/completions/cmake
+%{_datadir}/bash-completion/completions/cpack
+%{_datadir}/bash-completion/completions/ctest
This page took 0.02536 seconds and 4 git commands to generate.