]> git.pld-linux.org Git - packages/cmake.git/blobdiff - cmake.spec
- added fix for ruby 2.x b/c of moved RUBY_CONFIG_INCLUDE_DIR
[packages/cmake.git] / cmake.spec
index 208dacf80c72ec364d7dd2261177286182feffd9..39401dbb72b28a303c3a4f34eb7bf79755015082 100644 (file)
@@ -7,18 +7,23 @@
 # Conditional build:
 %bcond_with    bootstrap       # use internal versions of some libraries
 %bcond_without gui             # don't build gui package
+%bcond_without tests           # do not perform "make test"
 
 Summary:       Cross-platform, open-source make system
 Summary(pl.UTF-8):     Wieloplatformowy system make o otwartych źródłach
 Name:          cmake
-Version:       2.8.10.2
+Version:       2.8.12.2
 Release:       1
 License:       BSD
 Group:         Development/Building
 Source0:       http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
-# Source0-md5: 097278785da7182ec0aea8769d06860c
+# Source0-md5: 17c6513483d23590cbce6957ec6d1e66
 Patch0:                %{name}-lib64.patch
 Patch1:                %{name}-helpers.patch
+Patch2:                %{name}-findruby.patch
+Patch3:                %{name}-tests.patch
+Patch4:                %{name}-freetype2.patch
+Patch5:                %{name}-findruby2.patch
 URL:           http://www.cmake.org/
 %{?with_gui:BuildRequires:     QtGui-devel}
 BuildRequires: libarchive-devel
@@ -78,6 +83,10 @@ Summary:     bash-completion for cmake
 Summary(pl.UTF-8):     Bashowe dopełnianie parametrów dla cmake'a
 Group:         Applications/Shells
 Requires:      %{name} = %{version}-%{release}
+Requires:      bash-completion >= 2.0
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
 
 %description -n bash-completion-%{name}
 bash-completion for cmake.
@@ -91,6 +100,10 @@ Bashowe dopełnianie parametrów dla cmake'a.
 %patch0 -p1
 %endif
 %patch1 -p1
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
 
 cat > "init.cmake" <<EOF
 SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
@@ -116,9 +129,10 @@ export LDFLAGS="%{rpmldflags}"
 
 %{__make} VERBOSE=1
 
+%{?with_tests:%{__make} test}
+
 %install
 rm -rf $RPM_BUILD_ROOT
-
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
@@ -168,6 +182,6 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n bash-completion-%{name}
 %defattr(644,root,root,755)
-/etc/bash_completion.d/cmake
-/etc/bash_completion.d/cpack
-/etc/bash_completion.d/ctest
+%{_datadir}/bash-completion/completions/cmake
+%{_datadir}/bash-completion/completions/cpack
+%{_datadir}/bash-completion/completions/ctest
This page took 0.075677 seconds and 4 git commands to generate.