]> git.pld-linux.org Git - packages/cmake.git/blobdiff - cmake.spec
- updated to 3.14.1
[packages/cmake.git] / cmake.spec
index d692b1b2d9faa235c890a0412eb0a74935b74bc4..2f563fdd9b248614371c3933edb4b2859bd267f2 100644 (file)
@@ -1,6 +1,6 @@
 # TODO:
 # - system kwiml?
-# - extend libx32 patch to work also on 64-bit arch
+# - make lib64/libx32 patch changes applicable everywhere
 # - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
 #   (and default non-verbose makefiles are hiding it!)
 # - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
@@ -9,37 +9,30 @@
 # Conditional build:
 %bcond_with    bootstrap       # use internal versions of some libraries
 %bcond_without gui             # don't build gui package
-%bcond_with    xmlrpc          # XMLRPC submission method in CTest
 %bcond_with    tests           # perform "make test"
 %bcond_without doc             # don't build documentation
 
-%if %{with bootstrap}
-%undefine      with_xmlrpc
-%endif
 Summary:       Cross-platform, open-source make system
 Summary(pl.UTF-8):     Wieloplatformowy system make o otwartych źródłach
 Name:          cmake
-Version:       3.9.5
+Version:       3.14.1
 Release:       1
 License:       BSD
 Group:         Development/Building
-Source0:       https://cmake.org/files/v3.9/%{name}-%{version}.tar.gz
-# Source0-md5: 0922130d0e0c142a88e58c6e4fef4d7d
+Source0:       https://cmake.org/files/v3.14/%{name}-%{version}.tar.gz
+# Source0-md5: 7efe5394e85c3292ad020b8b70e55669
 Patch0:                %{name}-lib64.patch
 Patch1:                %{name}-libx32.patch
 Patch2:                %{name}-helpers.patch
 Patch3:                %{name}-findruby.patch
 Patch4:                %{name}-findruby2.patch
-Patch5:                man-syntax.patch
-
-Patch7:                %{name}-xmlrpc.patch
 URL:           https://cmake.org/
 %if %{with gui}
 BuildRequires: Qt5Core-devel >= 5.0
 BuildRequires: Qt5Gui-devel >= 5.0
 BuildRequires: Qt5Widgets-devel >= 5.0
 %endif
-%{!?with_xmlrpc:BuildRequires: curl-devel}
+BuildRequires: curl-devel
 BuildRequires: expat-devel
 BuildRequires: jsoncpp-devel >= 1.6.2-2
 BuildRequires: libarchive-devel
@@ -51,8 +44,7 @@ BuildRequires:        ncurses-devel > 5.9-3
 BuildRequires: rhash-devel
 BuildRequires: rpmbuild(macros) >= 1.167
 %{?with_doc:BuildRequires:     sphinx-pdg}
-%{?with_xmlrpc:BuildRequires:  xmlrpc-c-devel >= 1.4.12-2}
-%{!?with_xmlrpc:BuildRequires: zlib-devel}
+BuildRequires: zlib-devel
 Requires:      filesystem >= 3.0-52
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -136,9 +128,6 @@ Bashowe dopełnianie parametrów dla cmake'a.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-%patch5 -p1
-
-%patch7 -p1
 
 cat > "init.cmake" <<EOF
 SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
@@ -165,11 +154,10 @@ export LDFLAGS="%{rpmldflags}"
        --qt-qmake=%{_bindir}/qmake-qt5 \
        %{?with_doc:--sphinx-html} \
        %{?with_doc:--sphinx-man} \
-       --verbose \
-       -- \
-       %{?with_xmlrpc:-DCTEST_USE_XMLRPC=ON}
+       --verbose
 
-%{__make} VERBOSE=1
+%{__make} \
+       VERBOSE=1
 
 %{?with_tests:%{__make} test}
 
@@ -195,10 +183,13 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/cmake.1*
 %{_mandir}/man1/cpack.1*
 %{_mandir}/man1/ctest.1*
+%{_mandir}/man7/cpack-generators.7*
 %{_mandir}/man7/cmake-buildsystem.7*
 %{_mandir}/man7/cmake-commands.7*
 %{_mandir}/man7/cmake-compile-features.7*
 %{_mandir}/man7/cmake-developer.7*
+%{_mandir}/man7/cmake-env-variables.7*
+%{_mandir}/man7/cmake-file-api.7*
 %{_mandir}/man7/cmake-generator-expressions.7*
 %{_mandir}/man7/cmake-generators.7*
 %{_mandir}/man7/cmake-language.7*
This page took 0.032811 seconds and 4 git commands to generate.