]> git.pld-linux.org Git - packages/cmake.git/blobdiff - cmake.spec
- updated to 3.14.1
[packages/cmake.git] / cmake.spec
index c8ba83f197c13d64130274e8704aa2578abebc14..2f563fdd9b248614371c3933edb4b2859bd267f2 100644 (file)
@@ -1,5 +1,6 @@
 # TODO:
-# - extend libx32 patch to work also on 64-bit arch
+# - system kwiml?
+# - make lib64/libx32 patch changes applicable everywhere
 # - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
 #   (and default non-verbose makefiles are hiding it!)
 # - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
 Summary:       Cross-platform, open-source make system
 Summary(pl.UTF-8):     Wieloplatformowy system make o otwartych źródłach
 Name:          cmake
-Version:       3.2.2
+Version:       3.14.1
 Release:       1
 License:       BSD
 Group:         Development/Building
-Source0:       http://www.cmake.org/files/v3.2/%{name}-%{version}.tar.gz
-# Source0-md5: 2da57308071ea98b10253a87d2419281
+Source0:       https://cmake.org/files/v3.14/%{name}-%{version}.tar.gz
+# Source0-md5: 7efe5394e85c3292ad020b8b70e55669
 Patch0:                %{name}-lib64.patch
-Patch1:                %{name}-helpers.patch
-Patch2:                %{name}-findruby.patch
-Patch3:                %{name}-tests.patch
-
-Patch5:                %{name}-findruby2.patch
-Patch6:                %{name}-findpython.patch
-Patch7:                %{name}-libx32.patch
-URL:           http://www.cmake.org/
-%{?with_gui:BuildRequires:     QtGui-devel}
+Patch1:                %{name}-libx32.patch
+Patch2:                %{name}-helpers.patch
+Patch3:                %{name}-findruby.patch
+Patch4:                %{name}-findruby2.patch
+URL:           https://cmake.org/
+%if %{with gui}
+BuildRequires: Qt5Core-devel >= 5.0
+BuildRequires: Qt5Gui-devel >= 5.0
+BuildRequires: Qt5Widgets-devel >= 5.0
+%endif
+BuildRequires: curl-devel
+BuildRequires: expat-devel
 BuildRequires: jsoncpp-devel >= 1.6.2-2
 BuildRequires: libarchive-devel
 BuildRequires: libstdc++-devel
+BuildRequires: libuv-devel
 BuildRequires: ncurses-devel > 5.9-3
-%{?with_gui:BuildRequires:     qt5-build}
-%{?with_gui:BuildRequires:     qt5-qmake}
+%{?with_gui:BuildRequires:     qt5-build >= 5.0}
+%{?with_gui:BuildRequires:     qt5-qmake >= 5.0}
+BuildRequires: rhash-devel
 BuildRequires: rpmbuild(macros) >= 1.167
 %{?with_doc:BuildRequires:     sphinx-pdg}
-%{!?with_bootstrap:BuildRequires:      xmlrpc-c-devel >= 1.4.12-2}
+BuildRequires: zlib-devel
 Requires:      filesystem >= 3.0-52
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -116,15 +122,12 @@ Bashowe dopełnianie parametrów dla cmake'a.
 %if "%{_lib}" == "lib64"
 %patch0 -p1
 %endif
+%if "%{_lib}" == "libx32"
 %patch1 -p1
+%endif
 %patch2 -p1
 %patch3 -p1
-
-%patch5 -p1
-%patch6 -p1
-%if "%{_lib}" == "libx32"
-%patch7 -p1
-%endif
+%patch4 -p1
 
 cat > "init.cmake" <<EOF
 SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
@@ -148,12 +151,13 @@ export LDFLAGS="%{rpmldflags}"
        --init=init.cmake \
        %{!?with_bootstrap:--system-libs} \
        %{?with_gui:--qt-gui} \
-       --qt-qmake=%{_bindir}/qmake-qt4 \
+       --qt-qmake=%{_bindir}/qmake-qt5 \
        %{?with_doc:--sphinx-html} \
        %{?with_doc:--sphinx-man} \
        --verbose
 
-%{__make} VERBOSE=1
+%{__make} \
+       VERBOSE=1
 
 %{?with_tests:%{__make} test}
 
@@ -179,10 +183,13 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/cmake.1*
 %{_mandir}/man1/cpack.1*
 %{_mandir}/man1/ctest.1*
+%{_mandir}/man7/cpack-generators.7*
 %{_mandir}/man7/cmake-buildsystem.7*
 %{_mandir}/man7/cmake-commands.7*
 %{_mandir}/man7/cmake-compile-features.7*
 %{_mandir}/man7/cmake-developer.7*
+%{_mandir}/man7/cmake-env-variables.7*
+%{_mandir}/man7/cmake-file-api.7*
 %{_mandir}/man7/cmake-generator-expressions.7*
 %{_mandir}/man7/cmake-generators.7*
 %{_mandir}/man7/cmake-language.7*
@@ -191,6 +198,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man7/cmake-policies.7*
 %{_mandir}/man7/cmake-properties.7*
 %{_mandir}/man7/cmake-qt.7*
+%{_mandir}/man7/cmake-server.7*
 %{_mandir}/man7/cmake-toolchains.7*
 %{_mandir}/man7/cmake-variables.7*
 %{_datadir}/cmake/Help
@@ -214,7 +222,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/cmake-gui
 %{_datadir}/mime/packages/cmakecache.xml
-%{_desktopdir}/CMake.desktop
+%{_desktopdir}/cmake-gui.desktop
 %{_iconsdir}/hicolor/128x128/apps/CMakeSetup.png
 %{_iconsdir}/hicolor/32x32/apps/CMakeSetup.png
 %{_mandir}/man1/cmake-gui.1*
This page took 0.061801 seconds and 4 git commands to generate.