]> git.pld-linux.org Git - packages/cmake.git/blobdiff - cmake.spec
- up to 2.6.3
[packages/cmake.git] / cmake.spec
index c0447fa64c0721588510dfd6c5853587f66aad52..29792e2ab232b45bdb1e46e2a06c78c5fe99c83e 100644 (file)
@@ -5,27 +5,27 @@
 #   (is there any standard way???)
 #
 # Conditional build:
-%bcond_with    bootstrap # use internal versions of some libraries
-%bcond_without gui
+%bcond_with    bootstrap       # use internal versions of some libraries
+%bcond_without gui             # don't build gui package
 #
 Summary:       Cross-platform, open-source make system
 Summary(pl.UTF-8):     Wieloplatformowy system make o otwartych źródłach
 Name:          cmake
-Version:       2.6.1
+Version:       2.6.3
 Release:       1
 License:       BSD
 Group:         Development/Building
 Source0:       http://www.cmake.org/files/v2.6/%{name}-%{version}.tar.gz
-# Source0-md5: 6717f4bc3cfcced4172ad98660ce7599
-Patch1:                %{name}-lib64.patch
-URL:           http://www.cmake.org/HTML/index.html
+# Source0-md5: 5ba47a94ce276f326abca1fd72a7e7c6
+Patch0:                %{name}-lib64.patch
+URL:           http://www.cmake.org/
 %{?with_gui:BuildRequires:     QtGui-devel}
 BuildRequires: libstdc++-devel
 BuildRequires: ncurses-devel
 %{?with_gui:BuildRequires:     qt4-build}
 %{?with_gui:BuildRequires:     qt4-qmake}
 BuildRequires: rpmbuild(macros) >= 1.167
-%{!?with_bootstrap:BuildRequires:      xmlrpc-c-devel}
+%{!?with_bootstrap:BuildRequires:      xmlrpc-c-devel >= 1.4.12-2}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -47,22 +47,26 @@ konfiguracji systemu, generowanie preprocesora, generowanie kodu
 i dziedziczenie szablonów.
 
 %package gui
-Summary:       Qt GUI for %{name}
+Summary:       Qt GUI for CMake
+Summary(pl.UTF-8):     Graficzny interfejs użytkownika Qt dla CMake
 Group:         Development/Tools
 Requires:      %{name} = %{version}-%{release}
 
-%description    gui
-The %{name}-gui package contains the Qt based GUI for CMake.
+%description gui
+This package contains the Qt based GUI for CMake.
+
+%description gui -l pl.UTF-8
+Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
+CMake.
 
 %prep
 %setup -q
 %if "%{_lib}" == "lib64"
-%patch1 -p1
+%patch0 -p1
 %endif
 
 cat > "init.cmake" <<EOF
 SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
-SET (CMAKE_AR "%{__ar}" CACHE FILEPATH " " FORCE)
 EOF
 
 %build
This page took 0.025783 seconds and 4 git commands to generate.