]> git.pld-linux.org Git - packages/cmake.git/blame_incremental - cmake.spec
- 2.6.0 (functionality of ncurses.patch included)
[packages/cmake.git] / cmake.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with bootstrap # use internal versions of some libraries
4#
5Summary: Cross-platform, open-source make system
6Summary(pl.UTF-8): Wieloplatformowy system make o otwartych źródłach
7Name: cmake
8Version: 2.6.0
9Release: 0.1
10License: BSD
11Group: Development/Building
12Source0: http://www.cmake.org/files/v2.6/%{name}-%{version}.tar.gz
13# Source0-md5: e95ae003672dfc6c8151a1ee49a0d4a6
14Patch1: %{name}-lib64.patch
15URL: http://www.cmake.org/HTML/Index.html
16BuildRequires: libstdc++-devel
17BuildRequires: ncurses-devel
18BuildRequires: rpmbuild(macros) >= 1.167
19%{?!with_bootstrap:BuildRequires: xmlrpc-c-devel}
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23CMake is used to control the software compilation process using simple
24platform and compiler independent configuration files. CMake generates
25native makefiles and workspaces that can be used in the compiler
26environment of your choice. CMake is quite sophisticated: it is
27possible to support complex environments requiring system
28configuration, pre-processor generation, code generation, and template
29instantiation.
30
31%description -l pl.UTF-8
32CMake służy do sterowania procesem kompilacji oprogramowania przy
33użyciu prostych plików konfiguracyjnych niezależnych od platformy i
34kompilatora. CMake generuje natywne pliki makefile i workspace,
35których można używać w wybranym środowisku kompilatora. CMake jest
36dość przemyślany: może obsłużyć złożone środowiska wymagające
37konfiguracji systemu, generowanie preprocesora, generowanie kodu i
38dziedziczenie szablonów.
39
40%prep
41%setup -q
42%if "%{_lib}" == "lib64"
43%patch1 -p1
44%endif
45
46cat > "init.cmake" <<EOF
47SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
48SET (CMAKE_AR "%{__ar}" CACHE FILEPATH " " FORCE)
49EOF
50
51%build
52export CC="%{__cc}"
53export CXX="%{__cxx}"
54export CFLAGS="%{rpmcflags}"
55export CXXFLAGS="%{rpmcxxflags}"
56export LDFLAGS="%{rpmldflags}"
57./bootstrap \
58 --prefix=%{_prefix} \
59 --mandir=/share/man \
60 --datadir=/share/cmake \
61 --init=init.cmake \
62 %{?!with_bootstrap:--system-libs }\
63 --verbose
64
65%{__make}
66
67%install
68rm -rf $RPM_BUILD_ROOT
69
70%{__make} install \
71 DESTDIR=$RPM_BUILD_ROOT
72
73rm -rf $RPM_BUILD_ROOT%{_prefix}/doc
74
75%clean
76rm -rf $RPM_BUILD_ROOT
77
78%files
79%defattr(644,root,root,755)
80%doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
81%attr(755,root,root) %{_bindir}/ccmake
82%attr(755,root,root) %{_bindir}/cmake
83%attr(755,root,root) %{_bindir}/cpack
84%attr(755,root,root) %{_bindir}/ctest
85%{_mandir}/man1/*.1*
86%{_datadir}/cmake
This page took 0.031269 seconds and 4 git commands to generate.