]> git.pld-linux.org Git - packages/cmake.git/blame_incremental - cmake.spec
- release 2
[packages/cmake.git] / cmake.spec
... / ...
CommitLineData
1# TODO:
2# - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
3# (and default non-verbose makefiles are hiding it!)
4# - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
5# (is there any standard way???)
6#
7# Conditional build:
8%bcond_with bootstrap # use internal versions of some libraries
9%bcond_without gui # don't build gui package
10
11Summary: Cross-platform, open-source make system
12Summary(pl.UTF-8): Wieloplatformowy system make o otwartych źródłach
13Name: cmake
14Version: 2.8.7
15Release: 2
16License: BSD
17Group: Development/Building
18Source0: http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
19# Source0-md5: e1b237aeaed880f65dec9c20602452f6
20Patch0: %{name}-lib64.patch
21URL: http://www.cmake.org/
22%{?with_gui:BuildRequires: QtGui-devel}
23BuildRequires: libarchive-devel
24BuildRequires: libstdc++-devel
25BuildRequires: ncurses-devel > 5.9-3
26%{?with_gui:BuildRequires: qt4-build}
27%{?with_gui:BuildRequires: qt4-qmake}
28BuildRequires: rpmbuild(macros) >= 1.167
29%{!?with_bootstrap:BuildRequires: xmlrpc-c-devel >= 1.4.12-2}
30Requires: filesystem >= 3.0-52
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34CMake is used to control the software compilation process using simple
35platform and compiler independent configuration files. CMake generates
36native makefiles and workspaces that can be used in the compiler
37environment of your choice. CMake is quite sophisticated: it is
38possible to support complex environments requiring system
39configuration, pre-processor generation, code generation, and template
40instantiation.
41
42%description -l pl.UTF-8
43CMake służy do sterowania procesem kompilacji oprogramowania przy
44użyciu prostych plików konfiguracyjnych niezależnych od platformy i
45kompilatora. CMake generuje natywne pliki makefile i workspace,
46których można używać w wybranym środowisku kompilatora. CMake jest
47dość wyrafinowany: może obsłużyć złożone środowiska wymagające
48konfiguracji systemu, generowanie preprocesora, generowanie kodu i
49dziedziczenie szablonów.
50
51%package gui
52Summary: Qt GUI for CMake
53Summary(pl.UTF-8): Graficzny interfejs użytkownika Qt dla CMake
54Group: Development/Tools
55Requires: %{name} = %{version}-%{release}
56
57%description gui
58This package contains the Qt based GUI for CMake.
59
60%description gui -l pl.UTF-8
61Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
62CMake.
63
64%prep
65%setup -q
66%if "%{_lib}" == "lib64"
67%patch0 -p1
68%endif
69
70cat > "init.cmake" <<EOF
71SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
72EOF
73
74%build
75export CC="%{__cc}"
76export CXX="%{__cxx}"
77export CFLAGS="%{rpmcflags}"
78export CXXFLAGS="%{rpmcxxflags}"
79export LDFLAGS="%{rpmldflags}"
80./bootstrap \
81 --prefix=%{_prefix} \
82 --mandir=/share/man \
83 --datadir=/share/cmake \
84 --init=init.cmake \
85 %{!?with_bootstrap:--system-libs} \
86 %{?with_gui:--qt-gui} \
87 --qt-qmake=/usr/bin/qmake-qt4 \
88 --verbose
89
90%{__make} VERBOSE=1
91
92%install
93rm -rf $RPM_BUILD_ROOT
94
95%{__make} install \
96 DESTDIR=$RPM_BUILD_ROOT
97
98%{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc
99
100%clean
101rm -rf $RPM_BUILD_ROOT
102
103%files
104%defattr(644,root,root,755)
105%doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
106%attr(755,root,root) %{_bindir}/ccmake
107%attr(755,root,root) %{_bindir}/cmake
108%attr(755,root,root) %{_bindir}/cpack
109%attr(755,root,root) %{_bindir}/ctest
110%{_mandir}/man1/ccmake.1*
111%{_mandir}/man1/cmake.1*
112%{_mandir}/man1/cmakecommands.1*
113%{_mandir}/man1/cmakecompat.1*
114%{_mandir}/man1/cmakemodules.1*
115%{_mandir}/man1/cmakepolicies.1*
116%{_mandir}/man1/cmakeprops.1*
117%{_mandir}/man1/cmakevars.1*
118%{_mandir}/man1/cpack.1*
119%{_mandir}/man1/ctest.1*
120# top cmake/Modules dirs belong to filesystem
121%{_datadir}/cmake/Modules/.NoDartCoverage
122%{_datadir}/cmake/Modules/*
123%{_datadir}/cmake/Templates
124%{_datadir}/cmake/include
125%{_aclocaldir}/cmake.m4
126
127%if %{with gui}
128%files gui
129%defattr(644,root,root,755)
130%attr(755,root,root) %{_bindir}/cmake-gui
131%{_datadir}/mime/packages/cmakecache.xml
132%{_desktopdir}/CMake.desktop
133%{_pixmapsdir}/CMakeSetup32.png
134%{_mandir}/man1/cmake-gui.1*
135%endif
This page took 0.075687 seconds and 4 git commands to generate.