]> git.pld-linux.org Git - packages/cmake.git/blame_incremental - cmake.spec
- rebuild with expat 2.1.0
[packages/cmake.git] / cmake.spec
... / ...
CommitLineData
1# TODO:
2# - any valid CMAKE_BUILD_TYPE causes overriding of our optflags
3# (and default non-verbose makefiles are hiding it!)
4# - rpmldflags/rpmcppflags are not passed through %%cmake macro at all
5# (is there any standard way???)
6#
7# Conditional build:
8%bcond_with bootstrap # use internal versions of some libraries
9%bcond_without gui # don't build gui package
10
11Summary: Cross-platform, open-source make system
12Summary(pl.UTF-8): Wieloplatformowy system make o otwartych źródłach
13Name: cmake
14Version: 2.8.10.1
15Release: 2
16License: BSD
17Group: Development/Building
18Source0: http://www.cmake.org/files/v2.8/%{name}-%{version}.tar.gz
19# Source0-md5: aabf16d8e957f99921a0095885381373
20Patch0: %{name}-lib64.patch
21Patch1: %{name}-helpers.patch
22URL: http://www.cmake.org/
23%{?with_gui:BuildRequires: QtGui-devel}
24BuildRequires: libarchive-devel
25BuildRequires: libstdc++-devel
26BuildRequires: ncurses-devel > 5.9-3
27%{?with_gui:BuildRequires: qt4-build}
28%{?with_gui:BuildRequires: qt4-qmake}
29BuildRequires: rpmbuild(macros) >= 1.167
30%{!?with_bootstrap:BuildRequires: xmlrpc-c-devel >= 1.4.12-2}
31Requires: filesystem >= 3.0-52
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
35CMake is used to control the software compilation process using simple
36platform and compiler independent configuration files. CMake generates
37native makefiles and workspaces that can be used in the compiler
38environment of your choice. CMake is quite sophisticated: it is
39possible to support complex environments requiring system
40configuration, pre-processor generation, code generation, and template
41instantiation.
42
43%description -l pl.UTF-8
44CMake służy do sterowania procesem kompilacji oprogramowania przy
45użyciu prostych plików konfiguracyjnych niezależnych od platformy i
46kompilatora. CMake generuje natywne pliki makefile i workspace,
47których można używać w wybranym środowisku kompilatora. CMake jest
48dość wyrafinowany: może obsłużyć złożone środowiska wymagające
49konfiguracji systemu, generowanie preprocesora, generowanie kodu i
50dziedziczenie szablonów.
51
52%package gui
53Summary: Qt GUI for CMake
54Summary(pl.UTF-8): Graficzny interfejs użytkownika Qt dla CMake
55Group: Development/Tools
56Requires: %{name} = %{version}-%{release}
57
58%description gui
59This package contains the Qt based GUI for CMake.
60
61%description gui -l pl.UTF-8
62Ten pakiet zawiera oparty na Qt graficzny interfejs użytkownika dla
63CMake.
64
65%package emacs
66Summary: Emacs mode for cmake files
67Summary(pl.UTF-8): Tryb Emacsa dla plików cmake'a
68Group: Development/Tools
69
70%description emacs
71Emacs mode for cmake files.
72
73%description emacs -l pl.UTF-8
74Tryb Emacsa dla plików cmake'a.
75
76%package -n bash-completion-%{name}
77Summary: bash-completion for cmake
78Summary(pl.UTF-8): Bashowe dopełnianie parametrów dla cmake'a
79Group: Applications/Shells
80Requires: %{name} = %{version}-%{release}
81
82%description -n bash-completion-%{name}
83bash-completion for cmake.
84
85%description -n bash-completion-%{name} -l pl.UTF-8
86Bashowe dopełnianie parametrów dla cmake'a.
87
88%prep
89%setup -q
90%if "%{_lib}" == "lib64"
91%patch0 -p1
92%endif
93%patch1 -p1
94
95cat > "init.cmake" <<EOF
96SET (CURSES_INCLUDE_PATH "/usr/include/ncurses" CACHE PATH " " FORCE)
97SET (CMAKE_INSTALL_SYSCONFDIR "%{_sysconfdir}" CACHE PATH " " FORCE)
98SET (CMAKE_INSTALL_DATADIR "%{_datadir}" CACHE PATH " " FORCE)
99EOF
100
101%build
102export CC="%{__cc}"
103export CXX="%{__cxx}"
104export CFLAGS="%{rpmcflags}"
105export CXXFLAGS="%{rpmcxxflags}"
106export LDFLAGS="%{rpmldflags}"
107./bootstrap \
108 --prefix=%{_prefix} \
109 --mandir=/share/man \
110 --datadir=/share/cmake \
111 --init=init.cmake \
112 %{!?with_bootstrap:--system-libs} \
113 %{?with_gui:--qt-gui} \
114 --qt-qmake=/usr/bin/qmake-qt4 \
115 --verbose
116
117%{__make} VERBOSE=1
118
119%install
120rm -rf $RPM_BUILD_ROOT
121
122%{__make} install \
123 DESTDIR=$RPM_BUILD_ROOT
124
125%{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc
126
127%clean
128rm -rf $RPM_BUILD_ROOT
129
130%files
131%defattr(644,root,root,755)
132%doc ChangeLog.* Copyright.txt *.gif Docs/{cmake,ctest}.{txt,html}
133%attr(755,root,root) %{_bindir}/ccmake
134%attr(755,root,root) %{_bindir}/cmake
135%attr(755,root,root) %{_bindir}/cpack
136%attr(755,root,root) %{_bindir}/ctest
137%{_mandir}/man1/ccmake.1*
138%{_mandir}/man1/cmake.1*
139%{_mandir}/man1/cmakecommands.1*
140%{_mandir}/man1/cmakecompat.1*
141%{_mandir}/man1/cmakemodules.1*
142%{_mandir}/man1/cmakepolicies.1*
143%{_mandir}/man1/cmakeprops.1*
144%{_mandir}/man1/cmakevars.1*
145%{_mandir}/man1/cpack.1*
146%{_mandir}/man1/ctest.1*
147# top cmake/Modules dirs belong to filesystem
148%{_datadir}/cmake/Modules/.NoDartCoverage
149%{_datadir}/cmake/Modules/*
150%{_datadir}/cmake/Templates
151%{_datadir}/cmake/editors
152%{_datadir}/cmake/include
153%{_aclocaldir}/cmake.m4
154
155%if %{with gui}
156%files gui
157%defattr(644,root,root,755)
158%attr(755,root,root) %{_bindir}/cmake-gui
159%{_datadir}/mime/packages/cmakecache.xml
160%{_desktopdir}/CMake.desktop
161%{_pixmapsdir}/CMakeSetup32.png
162%{_mandir}/man1/cmake-gui.1*
163%endif
164
165%files emacs
166%defattr(644,root,root,755)
167%{_datadir}/emacs/site-lisp/cmake-mode.el
168
169%files -n bash-completion-%{name}
170%defattr(644,root,root,755)
171/etc/bash_completion.d/cmake
172/etc/bash_completion.d/cpack
173/etc/bash_completion.d/ctest
This page took 0.034525 seconds and 4 git commands to generate.