]> git.pld-linux.org Git - packages/clutter.git/commitdiff
Up to 1.16.0 auto/th/clutter-1.16.0-1
authorArtur Frysiak <artur@frysiak.net>
Sat, 28 Sep 2013 09:00:26 +0000 (11:00 +0200)
committerArtur Frysiak <artur@frysiak.net>
Sat, 28 Sep 2013 09:00:26 +0000 (11:00 +0200)
clutter-bug692706.patch [deleted file]
clutter.spec

diff --git a/clutter-bug692706.patch b/clutter-bug692706.patch
deleted file mode 100644 (file)
index 92be380..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-From a586c23ddcef9a11f6e343b4b6848cde2df54927 Mon Sep 17 00:00:00 2001
-From: Emmanuele Bassi <ebassi@gnome.org>
-Date: Mon, 06 May 2013 22:46:25 +0000
-Subject: cally: Use a weak pointer to hold the key focus in CallyStage
-
-We want to avoid the pointer getting stale, and causing crashes.
-
-https://bugzilla.gnome.org/show_bug.cgi?id=692706
-(cherry picked from commit 19391a9626b087bd4df452e8699d53caa54c350f)
-
-Signed-off-by: Emmanuele Bassi <ebassi@gnome.org>
----
-diff --git a/clutter/cally/cally-stage.c b/clutter/cally/cally-stage.c
-index 2b1cfd1..c95ccb0 100644
---- a/clutter/cally/cally-stage.c
-+++ b/clutter/cally/cally-stage.c
-@@ -139,7 +139,11 @@ cally_stage_notify_key_focus_cb (ClutterStage *stage,
-       AtkObject *old = NULL;
-       if (self->priv->key_focus != NULL)
--        old = clutter_actor_get_accessible (self->priv->key_focus);
-+        {
-+          g_object_remove_weak_pointer (G_OBJECT (self->priv->key_focus),
-+                                        (gpointer *) &self->priv->key_focus);
-+          old = clutter_actor_get_accessible (self->priv->key_focus);
-+        }
-       else
-         old = clutter_actor_get_accessible (CLUTTER_ACTOR (stage));
-@@ -154,7 +158,19 @@ cally_stage_notify_key_focus_cb (ClutterStage *stage,
-   self->priv->key_focus = key_focus;
-   if (key_focus != NULL)
--    new = clutter_actor_get_accessible (key_focus);
-+    {
-+      /* ensure that if the key focus goes away, the field inside
-+       * CallyStage is reset. see bug:
-+       *
-+       * https://bugzilla.gnome.org/show_bug.cgi?id=692706
-+       *
-+       * we remove the weak pointer above.
-+       */
-+      g_object_add_weak_pointer (G_OBJECT (self->priv->key_focus),
-+                                 (gpointer *) &self->priv->key_focus);
-+
-+      new = clutter_actor_get_accessible (key_focus);
-+    }
-   else
-     new = clutter_actor_get_accessible (CLUTTER_ACTOR (stage));
---
-cgit v0.9.1
index 6555d6f115618a513752e4a1aa3761d969e04785..9bf6cf68aaa04327064d8516951c0c39e1ff8c15 100644 (file)
@@ -1,15 +1,14 @@
 Summary:       Library for rich GUIs
 Summary(pl.UTF-8):     Biblioteka do bogatych graficznych interfejsów użytkownika
 Name:          clutter
-Version:       1.14.4
-Release:       2
+Version:       1.16.0
+Release:       1
 License:       LGPL v2+
 Group:         Libraries
-Source0:       http://ftp.gnome.org/pub/GNOME/sources/clutter/1.14/%{name}-%{version}.tar.xz
-# Source0-md5: c072e4c27e69368f2b877ea4f6da2cdf
+Source0:       http://ftp.gnome.org/pub/GNOME/sources/clutter/1.16/%{name}-%{version}.tar.xz
+# Source0-md5: 873c97b825c366e13e1f281e8e1f549b
 Patch0:                gtkdoc.patch
 Patch1:                missing.patch
-Patch2:                clutter-bug692706.patch
 URL:           http://www.clutter-project.org/
 BuildRequires: OpenGL-GLX-devel
 BuildRequires: atk-devel >= 1:2.5.3
@@ -17,11 +16,11 @@ BuildRequires:      autoconf >= 2.63
 BuildRequires: automake >= 1:1.11
 BuildRequires: cairo-devel >= 1.10
 BuildRequires: cairo-gobject-devel >= 1.10
-BuildRequires: cogl-devel >= 1.14.0
+BuildRequires: cogl-devel >= 1.15.9
 BuildRequires: docbook-dtd412-xml
 BuildRequires: gdk-pixbuf2-devel >= 2.0
 BuildRequires: gettext-devel >= 0.17
-BuildRequires: glib2-devel >= 1:2.32.0
+BuildRequires: glib2-devel >= 1:2.37.3
 BuildRequires: gobject-introspection-devel >= 0.10.0
 BuildRequires: gtk+3-devel >= 3.4.0
 BuildRequires: gtk-doc >= 1.15
@@ -29,7 +28,7 @@ BuildRequires:        json-glib-devel >= 0.12.0
 BuildRequires: libtool >= 2:2.2.6
 BuildRequires: libxslt-progs
 BuildRequires: pango-devel >= 1:1.30
-BuildRequires: pkgconfig
+BuildRequires: pkgconfig >= 0.16
 BuildRequires: python-modules
 BuildRequires: tar >= 1:1.22
 BuildRequires: xorg-lib-libX11-devel
@@ -39,10 +38,12 @@ BuildRequires:      xorg-lib-libXext-devel
 BuildRequires: xorg-lib-libXfixes-devel >= 4
 BuildRequires: xorg-lib-libXi-devel
 BuildRequires: xz
+BuildRequires: wayland-devel
+BuildRequires: xorg-lib-libxkbcommon-devel
 Requires:      atk >= 1:2.5.3
 Requires:      cairo-gobject >= 1.10
-Requires:      cogl >= 1.14.0
-Requires:      glib2 >= 1:2.32.0
+Requires:      cogl >= 1.15.9
+Requires:      glib2 >= 1:2.37.3
 Requires:      gtk+3 >= 3.4.0
 Requires:      json-glib >= 0.12.0
 Requires:      pango >= 1:1.30
@@ -127,7 +128,6 @@ Dokumentacja API clutter.
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
 
 %build
 %{__gtkdocize}
@@ -141,6 +141,11 @@ Dokumentacja API clutter.
        --enable-docs \
        --enable-gtk-doc \
        --enable-static \
+       --enable-wayland-backend \
+       --enable-wayland-compositor \
+       --enable-egl-backend \
+       --enable-gdk-backend \
+       --enable-xinput \
        --with-html-dir=%{_gtkdocdir}
 %{__make}
 
@@ -192,6 +197,9 @@ rm -rf $RPM_BUILD_ROOT
 %{_pkgconfigdir}/clutter-gdk-1.0.pc
 %{_pkgconfigdir}/clutter-glx-1.0.pc
 %{_pkgconfigdir}/clutter-x11-1.0.pc
+%{_pkgconfigdir}/clutter-egl-1.0.pc
+%{_pkgconfigdir}/clutter-wayland-1.0.pc
+%{_pkgconfigdir}/clutter-wayland-compositor-1.0.pc
 
 %files static
 %defattr(644,root,root,755)
This page took 0.127934 seconds and 4 git commands to generate.