]> git.pld-linux.org Git - packages/clutter.git/commitdiff
- updated to 1.22.0 auto/th/clutter-1.22.0-1
authorŁukasz Kieś <kiesiu@pld-linux.org>
Fri, 27 Mar 2015 19:30:46 +0000 (20:30 +0100)
committerŁukasz Kieś <kiesiu@pld-linux.org>
Fri, 27 Mar 2015 19:30:46 +0000 (20:30 +0100)
- libinput patch applied upstream

clutter-libinput.patch [deleted file]
clutter.spec

diff --git a/clutter-libinput.patch b/clutter-libinput.patch
deleted file mode 100644 (file)
index 5b956bf..0000000
+++ /dev/null
@@ -1,92 +0,0 @@
-From 358039182478140c8dcb7bcd077fff855d836bac Mon Sep 17 00:00:00 2001
-From: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Fri, 16 Jan 2015 01:03:52 +0100
-Subject: [PATCH] evdev: use libinput's new merged scroll events
-
-libinput's API changed from separate scroll events for vert/horiz scrolling to
-a single event that contains both axes if they changed.
-
-Updated by Armin K. to use the discrete axis value for wheel events as done
-in Weston.
----
- clutter/evdev/clutter-device-manager-evdev.c | 40 +++++++++++++++++++---------
- configure.ac                                 |  2 +-
- 2 files changed, 28 insertions(+), 14 deletions(-)
-
-diff --git a/clutter/evdev/clutter-device-manager-evdev.c b/clutter/evdev/clutter-device-manager-evdev.c
-index 7b48481..2b3828a 100644
---- a/clutter/evdev/clutter-device-manager-evdev.c
-+++ b/clutter/evdev/clutter-device-manager-evdev.c
-@@ -1191,29 +1191,43 @@ process_device_event (ClutterDeviceManagerEvdev *manager_evdev,
-     case LIBINPUT_EVENT_POINTER_AXIS:
-       {
--        gdouble value, dx = 0.0, dy = 0.0;
-+        gdouble dx = 0.0, dy = 0.0;
-         guint32 time;
-+        gboolean wheel = FALSE;
-         enum libinput_pointer_axis axis;
-+        enum libinput_pointer_axis_source source;
-         struct libinput_event_pointer *axis_event =
-           libinput_event_get_pointer_event (event);
-+
-         device = libinput_device_get_user_data (libinput_device);
-         time = libinput_event_pointer_get_time (axis_event);
--        value = libinput_event_pointer_get_axis_value (axis_event);
--        axis = libinput_event_pointer_get_axis (axis_event);
-+        source = libinput_event_pointer_get_axis_source (axis_event);
--        switch (axis)
--          {
--          case LIBINPUT_POINTER_AXIS_SCROLL_VERTICAL:
--            dx = 0;
--            dy = value;
--            break;
-+        /* libinput < 0.8 sent wheel click events with value 10. Since 0.8
-+           the value is the angle of the click in degrees. To keep
-+           backwards-compat with existing clients, we just send multiples of
-+           the click count. */
-+
-+        if (source == LIBINPUT_POINTER_AXIS_SOURCE_WHEEL)
-+            wheel = TRUE;
--          case LIBINPUT_POINTER_AXIS_SCROLL_HORIZONTAL:
--            dx = value;
--            dy = 0;
--            break;
-+        axis = LIBINPUT_POINTER_AXIS_SCROLL_VERTICAL;
-+        if (libinput_event_pointer_has_axis (axis_event, axis))
-+          {
-+            if (wheel)
-+              dy = 10 * libinput_event_pointer_get_axis_value_discrete (axis_event, axis);
-+            else
-+              dy = libinput_event_pointer_get_axis_value (axis_event, axis);
-+          }
-+        axis = LIBINPUT_POINTER_AXIS_SCROLL_HORIZONTAL;
-+        if (libinput_event_pointer_has_axis (axis_event, axis))
-+          {
-+            if (wheel)
-+              dx = 10 * libinput_event_pointer_get_axis_value_discrete (axis_event, axis);
-+            else
-+              dx = libinput_event_pointer_get_axis_value (axis_event, axis);
-           }
-         notify_scroll (device, time, dx, dy);
-diff --git a/configure.ac b/configure.ac
-index 0a9a580..2a47744 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -146,7 +146,7 @@ m4_define([uprof_req_version],          [0.3])
- m4_define([gtk_doc_req_version],        [1.20])
- m4_define([xcomposite_req_version],     [0.4])
- m4_define([gdk_req_version],            [3.3.18])
--m4_define([libinput_req_version],       [0.4.0])
-+m4_define([libinput_req_version],       [0.8.0])
- m4_define([libudev_req_version],        [136])
- AC_SUBST([GLIB_REQ_VERSION],       [glib_req_version])
--- 
-2.2.2
-
index 76d00a225ba3a7e865a8e8b6a30de9a9d085feb7..e0edd723b078bd9a697aff26e44b9e08e20722ca 100644 (file)
@@ -8,29 +8,28 @@
 Summary:       Library for rich GUIs
 Summary(pl.UTF-8):     Biblioteka do bogatych graficznych interfejsów użytkownika
 Name:          clutter
-Version:       1.20.0
-Release:       4
+Version:       1.22.0
+Release:       1
 License:       LGPL v2+
 Group:         Libraries
-Source0:       http://ftp.gnome.org/pub/GNOME/sources/clutter/1.20/%{name}-%{version}.tar.xz
-# Source0-md5: a8a33a57a944c6d7c7c013ce9aa3222b
+Source0:       http://ftp.gnome.org/pub/GNOME/sources/clutter/1.22/%{name}-%{version}.tar.xz
+# Source0-md5: 788c488d795103e4c201fae1b032cb89
 Patch0:                gtkdoc.patch
 Patch1:                missing.patch
-Patch2:                %{name}-libinput.patch
 URL:           http://www.clutter-project.org/
 BuildRequires: OpenGL-GLX-devel
 BuildRequires: atk-devel >= 1:2.5.3
 BuildRequires: autoconf >= 2.63
 BuildRequires: automake >= 1:1.11
-BuildRequires: cairo-devel >= 1.12.0
-BuildRequires: cairo-gobject-devel >= 1.12.0
-BuildRequires: cogl-devel >= 1.18.0
-%{?with_wayland:BuildRequires: cogl-devel(wayland) >= 1.18.0}
+BuildRequires: cairo-devel >= 1.14.0
+BuildRequires: cairo-gobject-devel >= 1.14.0
+BuildRequires: cogl-devel >= 1.20.0
+%{?with_wayland:BuildRequires: cogl-devel(wayland) >= 1.20.0}
 BuildRequires: docbook-dtd412-xml
 BuildRequires: gdk-pixbuf2-devel >= 2.0
 BuildRequires: gettext-tools >= 0.17
-BuildRequires: glib2-devel >= 1:2.37.3
-BuildRequires: gobject-introspection-devel >= 0.10.0
+BuildRequires: glib2-devel >= 1:2.39.0
+BuildRequires: gobject-introspection-devel >= 1.39.0
 BuildRequires: gtk+3-devel >= 3.4.0
 BuildRequires: gtk-doc >= 1.20
 BuildRequires: json-glib-devel >= 0.12.0
@@ -58,10 +57,10 @@ BuildRequires:      xorg-lib-libxkbcommon-devel
 %endif
 BuildRequires: xz
 Requires:      atk >= 1:2.5.3
-Requires:      cairo-gobject >= 1.12.0
-Requires:      cogl >= 1.18.0
-%{?with_wayland:Requires:      cogl(wayland) >= 1.18.0}
-Requires:      glib2 >= 1:2.37.3
+Requires:      cairo-gobject >= 1.14.0
+Requires:      cogl >= 1.20.0
+%{?with_wayland:Requires:      cogl(wayland) >= 1.20.0}
+Requires:      glib2 >= 1:2.39.0
 Requires:      gtk+3 >= 3.4.0
 Requires:      json-glib >= 0.12.0
 %{?with_evdev:Requires:        libinput >= 0.8.0}
@@ -100,11 +99,11 @@ Group:             Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      OpenGL-GLX-devel
 Requires:      atk-devel >= 1:2.5.3
-Requires:      cairo-gobject-devel >= 1.12.0
-Requires:      cogl-devel >= 1.18.0
-%{?with_wayland:Requires:      cogl-devel(wayland) >= 1.18.0}
+Requires:      cairo-gobject-devel >= 1.14.0
+Requires:      cogl-devel >= 1.20.0
+%{?with_wayland:Requires:      cogl-devel(wayland) >= 1.20.0}
 Requires:      gdk-pixbuf2-devel >= 2.0
-Requires:      glib2-devel >= 1:2.37.3
+Requires:      glib2-devel >= 1:2.39.0
 Requires:      gtk+3-devel >= 3.4.0
 Requires:      json-glib-devel >= 0.12.0
 %{?with_evdev:Requires:        libinput-devel >= 0.8.0}
@@ -161,7 +160,6 @@ Dokumentacja API clutter.
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
 
 %build
 %{__gtkdocize}
This page took 0.086034 seconds and 4 git commands to generate.