]> git.pld-linux.org Git - packages/clutter-gesture.git/blob - clutter-gesture.spec
x32 rebuild
[packages/clutter-gesture.git] / clutter-gesture.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4
5 %define rel             2
6 %define snap    20100106
7 Summary:        Clutter Gesture library
8 Summary(pl.UTF-8):      Biblioteka gestów Clutter
9 Name:           clutter-gesture
10 Version:        0.0.2
11 Release:        0.%{snap}.%{rel}
12 License:        LGPL v2.1
13 Group:          Libraries
14 # git clone git://git.moblin.org/clutter-gesture
15 Source0:        %{name}.tar.xz
16 # Source0-md5:  7f3b287e4213f5be4e2f0054e1112e6b
17 Patch0:         %{name}-link.patch
18 URL:            http://www.moblin.org/
19 BuildRequires:  autoconf >= 2.61
20 BuildRequires:  automake
21 BuildRequires:  clutter-devel >= 1.0.0
22 BuildRequires:  glib2-devel >= 2
23 #BuildRequires: gtk-doc >= 1.9
24 BuildRequires:  libtool
25 BuildRequires:  pkgconfig
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Clutter Gesture library allows clutter applications to be aware of
32 gestures and to easily attach some handlers to the gesture events.
33
34 %description -l pl.UTF-8
35 Biblioteka Clutter Gesture pozwala aplikacjom wykorzystujacych
36 bibliotekę clutter na obsługę gestów i łatwe podłączanie procedur
37 obsługi do zdarzeń gestów.
38
39 %package devel
40 Summary:        Header files for Clutter Gesture library
41 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Clutter Gesture
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       clutter-devel >= 1.0.0
45 Requires:       glib2-devel >= 2
46
47 %description devel
48 Header files for Clutter Gesture library.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe biblioteki Clutter Gesture.
52
53 %package static
54 Summary:        Static Clutter Gesture library
55 Summary(pl.UTF-8):      Statyczna biblioteka Clutter Gesture
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Static Clutter Gesture library.
61
62 %description static -l pl.UTF-8
63 Statyczna biblioteka Clutter Gesture.
64
65 %prep
66 %setup -q -n %{name}
67 %patch0 -p1
68
69 %build
70 %{__libtoolize}
71 %{__aclocal}
72 %{__autoconf}
73 %{__autoheader}
74 %{__automake}
75 # disable some warnings, so it builds with -Werror
76 CFLAGS="%{rpmcflags} -Wno-unused-but-set-variable -Wno-deprecated-declarations -Wno-switch -Wno-unused-result"
77 %configure \
78         %{!?with_static_libs:--disable-static} \
79         --with-html-dir=%{_gtkdocdir}
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 %{__make} install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 # obsoleted by pkg-config
89 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post   -p /sbin/ldconfig
95 %postun -p /sbin/ldconfig
96
97 %files
98 %defattr(644,root,root,755)
99 %doc README
100 %attr(755,root,root) %{_libdir}/libcluttergesture-0.0.2.so.*.*.*
101 %attr(755,root,root) %ghost %{_libdir}/libcluttergesture-0.0.2.so.0
102
103 %files devel
104 %defattr(644,root,root,755)
105 %attr(755,root,root) %{_libdir}/libcluttergesture-0.0.2.so
106 %{_includedir}/clutter-gesture
107 %{_pkgconfigdir}/clutter-gesture.pc
108
109 %if %{with static_libs}
110 %files static
111 %defattr(644,root,root,755)
112 %{_libdir}/libcluttergesture-0.0.2.a
113 %endif
This page took 0.203209 seconds and 3 git commands to generate.