]> git.pld-linux.org Git - packages/cluster.git/blob - cluster.spec
- run ldconfig on library install/uninstall
[packages/cluster.git] / cluster.spec
1 #
2 # Conditional build:
3 %bcond_without  ldap            # do not include ldap support
4
5 Summary:        Cluster infrastructure
6 Summary(pl.UTF-8):      Infrastruktura klastra
7 Name:           cluster
8 Version:        3.1.8
9 Release:        2
10 License:        GPL v2
11 Group:          Applications/System
12 Source0:        https://fedorahosted.org/releases/c/l/cluster/%{name}-%{version}.tar.bz2
13 # Source0-md5:  25699384c42c28bbec2998c25e7a8300
14 Source1:        %{name}.tmpfiles
15 Patch0:         %{name}-no_ldap.patch
16 URL:            http://sources.redhat.com/cluster/wiki
17 BuildRequires:  corosync-devel >= 1.4.1
18 BuildRequires:  libxml2-devel
19 BuildRequires:  libxslt-progs
20 BuildRequires:  ncurses-devel
21 BuildRequires:  nspr-devel
22 BuildRequires:  nss-devel
23 BuildRequires:  openais-devel >= 1.1.4
24 %{?with_ldap:BuildRequires:     openldap-devel}
25 BuildRequires:  perl-ExtUtils-MakeMaker
26 BuildRequires:  slang-devel
27 Requires:       %{name}-cman = %{version}-%{release}
28 Requires:       %{name}-rgmanager = %{version}-%{release}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _sbindir        /sbin
32
33 %description
34 %description -l pl.UTF-8
35
36 %package ccs
37 Summary:        Cluster configuration system
38 Summary(pl.UTF-8):      System konfiguracji klastra
39 Group:          Applications/System
40 Requires:       libxml2-progs
41
42 %description ccs
43 Cluster configuration system to manage the cluster config file.
44
45 %description ccs -l pl.UTF-8
46 System konfiguracji klastra do zarządzania jego plikiem
47 konfiguracyjnym.
48
49 %package ccs-devel
50 Summary:        Header filed for ccs library
51 Summary(pl.UTF-8):      Pliki nagłówkowe dla biblioteki ccs
52 Group:          Applications/System
53 Requires:       %{name}-ccs-libs = %{version}-%{release}
54
55 %description ccs-devel
56 Header filed for ccs library.
57
58 %description ccs-devel -l pl.UTF-8
59 Pliki nagłówkowe dla biblioteki ccs.
60
61 %package ccs-libs
62 Summary:        Cluster configuration system library
63 Summary(pl.UTF-8):      Biblioteka systemu konfiguracji klastra
64 Group:          Applications/System
65
66 %description ccs-libs
67 Cluster configuration system library.
68
69 %description ccs-libs -l pl.UTF-8
70 Biblioteka systemu konfiguracji klastra.
71
72 %package ccs-static
73 Summary:        Static ccs library
74 Summary(pl.UTF-8):      Statyczna biblioteka ccs
75 Group:          Applications/System
76
77 %description ccs-static
78 Static ccs library.
79
80 %description ccs-static -l pl.UTF-8
81 Statyczna biblioteka ccs.
82
83 %package cman
84 Summary:        Cluster infrastructure manager
85 Summary(pl.UTF-8):      Zarządca infrastruktury klastra
86 Group:          Applications/System
87 Requires:       %{name}-ccs = %{version}-%{release}
88 Requires:       %{name}-dlm = %{version}-%{release}
89 Requires:       %{name}-fence = %{version}-%{release}
90 Requires:       %{name}-group = %{version}-%{release}
91 Requires:       corosync
92 Requires:       openais
93 Obsoletes:      cman
94
95 %description cman
96 MAN is a symmetric, general-purpose, kernel-based cluster manager. It
97 has two parts. Connection Manager (cnxman) handles membership,
98 messaging, quorum, event notification and transitions. Service Manager
99 (sm) handles "service groups" which are a general way of representing
100 and managing instances of external systems that require cluster
101 management. The CMAN cluster manager is the foundational system upon
102 which DLM, GFS, CLVM, and Fence all depend. The CMAN API in the kernel
103 and userspace is general and available for other programs to use.
104
105 %description cman -l pl.UTF-8
106 MAN to zarządca opartych na jądrze symetrycznych klastrów ogólnego
107 przeznaczenia. Składa się z dwóch części. Zarządca połączeń
108 (Connection Manager, cnxman) obsługuje członkostwo, komunikację,
109 kworum, powiadamianie o zdarzeniach i przejścia. Zarządca usług
110 (Service Manager, sm) obsługuje "grupy usług", które są ogólnym
111 sposobem reprezentacji i zarządzania instancjami zewnętrznych systemów
112 wymagających zarządzania klastrem. Zarządca klastrów CMAN to
113 podstawowy system, na którym polegają DLM, GFS, CLVM i Fence. API
114 CMAN-a w jądrze i przestrzeni użytkownika jest ogólne i w całości
115 dostępne do wykorzystania w innych programach.
116
117 %package cman-devel
118 Summary:        Header filed for cman library
119 Summary(pl.UTF-8):      Pliki nagłówkowe dla biblioteki cman
120 Group:          Applications/System
121 Requires:       %{name}-cman-libs = %{version}-%{release}
122 Obsoletes:      cman-devel
123
124 %description cman-devel
125 Header filed for cman library.
126
127 %description cman-devel -l pl.UTF-8
128 Pliki nagłówkowe dla biblioteki cman.
129
130 %package cman-libs
131 Summary:        Cluster infrastructure manager library
132 Summary(pl.UTF-8):      Biblioteka zarządcy infrastruktury klastra
133 Group:          Applications/System
134
135 %description cman-libs
136 Cluster infrastructure manager library.
137
138 %description cman-libs -l pl.UTF-8
139 Biblioteka zarządcy infrastruktury klastra.
140
141 %package cman-static
142 Summary:        Static cman library
143 Summary(pl.UTF-8):      Statyczna biblioteka cman
144 Group:          Applications/System
145 Obsoletes:      cman-static
146
147 %description cman-static
148 Static cman library.
149
150 %description cman-static -l pl.UTF-8
151 Statyczna biblioteka cman.
152
153 %package dlm
154 Summary:        Distributed lock manager
155 Summary(pl.UTF-8):      Zarządca rozporoszonych blokad
156 Group:          Applications/System
157 Obsoletes:      dlm
158
159 %description dlm
160 The DLM lock manager is a kernel-based VMS-like distributed lock
161 manager. It is general purpose and not specific to only GFS or CLVM.
162 Kernel and userspace locking API's are available.
163
164 %description dlm -l pl.UTF-8
165 Zarządca blokad DLM to oparty na jądrze zarządca rozproszonych blokad
166 w stylu VMS. Jest ogólnego przeznaczenia, przeznaczonym nie tylko dla
167 GFS-a czy CLVM-a. Dostępne są API blokowania w jądrze i przestrzeni
168 użytkownika.
169
170 %package dlm-devel
171 Summary:        Header filed for dlm library
172 Summary(pl.UTF-8):      Pliki nagłówkowe dla biblioteki dlm
173 Group:          Applications/System
174 Requires:       %{name}-dlm-libs = %{version}-%{release}
175 Obsoletes:      dlm-devel
176
177 %description dlm-devel
178 Header filed for dlm library.
179
180 %description dlm-devel -l pl.UTF-8
181 Pliki nagłówkowe dla biblioteki dlm.
182
183 %package dlm-libs
184 Summary:        Distributed lock manager library
185 Summary(pl.UTF-8):      Biblioteka zarządca rozporoszonych blokad
186 Group:          Applications/System
187
188 %description dlm-libs
189 Distributed lock manager library.
190
191 %description dlm-libs -l pl.UTF-8
192 Biblioteka zarządca rozporoszonych blokad.
193
194 %package dlm-static
195 Summary:        Static dlm library
196 Summary(pl.UTF-8):      Statyczna biblioteka dlm
197 Group:          Applications/System
198 Obsoletes:      dlm-static
199
200 %description dlm-static
201 Static dlm library.
202
203 %description dlm-static -l pl.UTF-8
204 Statyczna biblioteka dlm.
205
206 %package fence
207 Summary:        Cluster infrastructure I/O fencing system
208 Summary(pl.UTF-8):      System barier I/O infrastruktury klastra
209 Group:          Applications/System
210 Suggests:       fence-agents
211
212 %description fence
213 The Fence system does I/O fencing of cluster members. Any member may
214 join the default fence domain after which it will be fenced if it
215 fails without leaving the fence domain cleanly. The lock_dlm GFS lock
216 module will not permit GFS to be mounted until the node has joined a
217 fence domain.
218
219 The fence daemon, fenced, is usually started by running "fence_tool
220 join". Once started, fenced joins the default fence domain and the
221 node is subject to being fenced if it fails. A collection of fence
222 agents are used by fenced to interface with hardware devices (usually
223 to shut off its path to shared storage or cycle its power source.)
224
225 %description fence -l pl.UTF-8
226 System Fence odpowiada za bariery I/O dla członków klastra. Każdy z
227 członków może dołączyć do domyślnej domeny barier, po czym będzie
228 odgrodzony jeśli zawiedzie nie opuszczając czysto domeny barier. Moduł
229 blokujący GFS-a lock_dlm nie pozwoli na podmontowanie GFS-a dopóki
230 węzeł nie dołączy do domeny barier.
231
232 Demon fence, fenced, jest zwykle uruchamiany przez fence_tool join. Po
233 uruchomieniu fenced dołącza do domyślnej domeny barier, a węzeł jest
234 przedmiotem odgrodzenia jeśli zawiedzie. fenced wykorzystuje zbiór
235 agentów fence do komunikacji z urządzeniami sprzętowymi (zwykle do
236 odcinania drogi do dzielonej pamięci lub wyłączania i włączania
237 zasilania).
238
239 %package fence-devel
240 Summary:        Header filed for fence library
241 Summary(pl.UTF-8):      Pliki nagłówkowe dla biblioteki fence
242 Group:          Applications/System
243 Requires:       %{name}-fence-libs = %{version}-%{release}
244
245 %description fence-devel
246 Header filed for fence library.
247
248 %description fence-devel -l pl.UTF-8
249 Pliki nagłówkowe dla biblioteki fence.
250
251 %package fence-libs
252 Summary:        Cluster infrastructure I/O fencing system library
253 Summary(pl.UTF-8):      Biblioteka systemu barier I/O infrastruktury klastra
254 Group:          Applications/System
255
256 %description fence-libs
257 Cluster infrastructure I/O fencing system library.
258
259 %description fence-libs -l pl.UTF-8
260 Biblioteka systemu barier I/O infrastruktury klastra.
261
262 %package fence-static
263 Summary:        Static fence library
264 Summary(pl.UTF-8):      Statyczna biblioteka fence
265 Group:          Applications/System
266
267 %description fence-static
268 Static fence library.
269
270 %description fence-static -l pl.UTF-8
271 Statyczna biblioteka fence.
272
273 %package group
274 Summary:        Cluster infrastructure
275 Summary(pl.UTF-8):      Infrastruktura klastra
276 Group:          Applications/System
277
278 %description group
279 Cluster infrastructure.
280
281 %description group -l pl.UTF-8
282 Infrastruktura klastra.
283
284 %package rgmanager
285 Summary:        HA resource group failover
286 Summary(pl.UTF-8):      Failover dla grupy zasobów wysokiej dostępności
287 Group:          Applications/System
288 Suggests:       resource-agents
289
290 %description rgmanager
291 Resource Group Manager provides high availability of critical server
292 applications in the event of planned or unplanned system downtime.
293
294 %description rgmanager -l pl.UTF-8
295 Resource Group Manager daje wysoką dostępność krytycznych aplikacji
296 serwerowych w przypadku planowanych lub nieplanowanych wyłączeń
297 serwera.
298
299 %prep
300 %setup -q
301 %{!?with_ldap:%patch0 -p1}
302
303 sed -i -e 's,-Wall,%{rpmcflags} -I/usr/include/ncurses -Wall,' make/defines.mk.input
304
305 %build
306 ./configure \
307         --libdir=%{_libdir} \
308         --libexecdir=%{_libdir} \
309         --mandir=%{_mandir} \
310         --prefix=%{_prefix} \
311         --sbindir=%{_sbindir} \
312         --ncursesincdir=/usr/include/ncurses \
313         --disable_kernel_check
314
315 %{__make}
316
317 %install
318 rm -rf $RPM_BUILD_ROOT
319 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/cluster,/etc/rc.d/init.d} \
320                 $RPM_BUILD_ROOT{/var/log/cluster,%{systemdtmpfilesdir}}
321
322 %{__make} install \
323         DESTDIR=$RPM_BUILD_ROOT
324
325 mv $RPM_BUILD_ROOT/''etc/init.d/* $RPM_BUILD_ROOT/etc/rc.d/init.d
326
327 install %{SOURCE1} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
328
329 %clean
330 rm -rf $RPM_BUILD_ROOT
331
332 %post   ccs-libs   -p /sbin/ldconfig
333 %postun ccs-libs   -p /sbin/ldconfig
334 %post   cman-libs  -p /sbin/ldconfig
335 %postun cman-libs  -p /sbin/ldconfig
336 %post   dlm-libs   -p /sbin/ldconfig
337 %postun dlm-libs   -p /sbin/ldconfig
338 %post   fence-libs -p /sbin/ldconfig
339 %postun fence-libs -p /sbin/ldconfig
340
341 %files
342 %defattr(644,root,root,755)
343
344 %files ccs
345 %defattr(644,root,root,755)
346 %if %{with ldap}
347 %attr(755,root,root) %{_sbindir}/confdb2ldif
348 %endif
349 %attr(755,root,root) %{_sbindir}/ccs_config_dump
350 %attr(755,root,root) %{_sbindir}/ccs_config_validate
351 %attr(755,root,root) %{_sbindir}/ccs_test
352 %attr(755,root,root) %{_sbindir}/ccs_tool
353 %attr(755,root,root) %{_sbindir}/ccs_update_schema
354 %attr(755,root,root) %{_libdir}/lcrso/*.lcrso
355 %{_mandir}/man8/ccs_config_dump.*
356 %{_mandir}/man8/ccs_config_validate.*
357 %{_mandir}/man8/ccs_tool.*
358 %{_mandir}/man8/ccs_update_schema.*
359 %if %{with ldap}
360 %{_mandir}/man8/confdb2ldif.*
361 %endif
362 %attr(700,root,root) /var/run/cluster
363 %{systemdtmpfilesdir}/%{name}.conf
364
365 %files ccs-libs
366 %defattr(644,root,root,755)
367 %attr(755,root,root) %{_libdir}/libccs.so.3.0
368 %attr(755,root,root) %ghost %{_libdir}/libccs.so.3
369
370 %files ccs-devel
371 %defattr(644,root,root,755)
372 %attr(755,root,root) %{_libdir}/libccs.so
373 %{_includedir}/ccs.h
374 %{_pkgconfigdir}/libccs.pc
375
376 %files ccs-static
377 %defattr(644,root,root,755)
378 %{_libdir}/libccs.a
379
380 %files cman
381 %defattr(644,root,root,755)
382 %{_sysconfdir}/cluster
383 /etc/logrotate.d/cluster
384 %attr(754,root,root) /etc/rc.d/init.d/cman
385 %attr(755,root,root) %{_sbindir}/cman_notify
386 %attr(755,root,root) %{_sbindir}/cman_tool
387 %attr(755,root,root) %{_sbindir}/cmannotifyd
388 %attr(755,root,root) %{_sbindir}/mkqdisk
389 %attr(755,root,root) %{_sbindir}/qdiskd
390 %{_datadir}/cluster
391 %{_docdir}/cluster
392 %{_mandir}/man5/cluster.conf.*
393 %{_mandir}/man5/cman.*
394 %{_mandir}/man5/qdisk.*
395 %{_mandir}/man8/checkquorum.*
396 %{_mandir}/man8/cman_notify.*
397 %{_mandir}/man8/cman_tool.*
398 %{_mandir}/man8/cmannotifyd.*
399 %{_mandir}/man8/mkqdisk.*
400 %{_mandir}/man8/qdiskd.*
401 /var/log/cluster
402
403 %files cman-devel
404 %defattr(644,root,root,755)
405 %attr(755,root,root) %{_libdir}/libcman.so
406 %attr(755,root,root) %{_libdir}/liblogthread.so
407 %{_includedir}/libcman.h
408 %{_includedir}/liblogthread.h
409 %{_pkgconfigdir}/libcman.pc
410 %{_pkgconfigdir}/liblogthread.pc
411
412 %files cman-libs
413 %defattr(644,root,root,755)
414 %attr(755,root,root) %{_libdir}/libcman.so.3.0
415 %attr(755,root,root) %ghost %{_libdir}/libcman.so.3
416 %attr(755,root,root) %{_libdir}/liblogthread.so.3.0
417 %attr(755,root,root) %ghost %{_libdir}/liblogthread.so.3
418
419 %files cman-static
420 %defattr(644,root,root,755)
421 %{_libdir}/libcman.a
422 %{_libdir}/liblogthread.a
423
424 %files dlm
425 %defattr(644,root,root,755)
426 /lib/udev/rules.d/51-dlm.rules
427 %attr(755,root,root) %{_sbindir}/dlm_tool
428 %{_mandir}/man8/dlm_tool.*
429
430 %files dlm-devel
431 %defattr(644,root,root,755)
432 %{_includedir}/libdlm.h
433 %{_includedir}/libdlmcontrol.h
434 %{_pkgconfigdir}/libdlm.pc
435 %{_pkgconfigdir}/libdlm_lt.pc
436 %{_pkgconfigdir}/libdlmcontrol.pc
437 %attr(755,root,root) %{_libdir}/libdlm.so
438 %attr(755,root,root) %{_libdir}/libdlm_lt.so
439 %attr(755,root,root) %{_libdir}/libdlmcontrol.so
440 %{_mandir}/man3/dlm_*.*
441 %{_mandir}/man3/libdlm.*
442
443 %files dlm-libs
444 %defattr(644,root,root,755)
445 %attr(755,root,root) %{_libdir}/libdlm.so.3.0
446 %attr(755,root,root) %ghost %{_libdir}/libdlm.so.3
447 %attr(755,root,root) %{_libdir}/libdlm_lt.so.3.0
448 %attr(755,root,root) %ghost %{_libdir}/libdlm_lt.so.3
449 %attr(755,root,root) %{_libdir}/libdlmcontrol.so.3.1
450 %attr(755,root,root) %ghost %{_libdir}/libdlmcontrol.so.3
451
452 %files dlm-static
453 %defattr(644,root,root,755)
454 %{_libdir}/libdlm.a
455 %{_libdir}/libdlm_lt.a
456 %{_libdir}/libdlmcontrol.a
457
458 %files fence
459 %defattr(644,root,root,755)
460 %attr(755,root,root) %{_sbindir}/fence_*
461 %attr(755,root,root) %{_sbindir}/fenced
462 %{perl_vendorarch}/Cluster
463 %{perl_vendorarch}/auto/Cluster
464 %{_mandir}/man8/fence_*.*
465 %{_mandir}/man8/fenced.*
466
467 %files fence-devel
468 %defattr(644,root,root,755)
469 %{_includedir}/libfence.h
470 %{_includedir}/libfenced.h
471 %{_pkgconfigdir}/libfence.pc
472 %{_pkgconfigdir}/libfenced.pc
473 %attr(755,root,root) %{_libdir}/libfence.so
474 %attr(755,root,root) %{_libdir}/libfenced.so
475 %{_mandir}/man3/Cluster::CCS.3pm.*
476
477 %files fence-libs
478 %defattr(644,root,root,755)
479 %attr(755,root,root) %{_libdir}/libfence.so.4.0
480 %attr(755,root,root) %ghost %{_libdir}/libfence.so.4
481 %attr(755,root,root) %{_libdir}/libfenced.so.3.0
482 %attr(755,root,root) %ghost %{_libdir}/libfenced.so.3
483
484 %files fence-static
485 %defattr(644,root,root,755)
486 %{_libdir}/libfence.a
487 %{_libdir}/libfenced.a
488
489 %files group
490 %defattr(644,root,root,755)
491 %attr(755,root,root) %{_sbindir}/dlm_controld
492 %attr(755,root,root) %{_sbindir}/group_tool
493 %attr(755,root,root) %{_sbindir}/groupd
494 %{_mandir}/man8/dlm_controld.*
495 %{_mandir}/man8/group_tool.*
496 %{_mandir}/man8/groupd.*
497
498 %files rgmanager
499 %defattr(644,root,root,755)
500 %attr(754,root,root) /etc/rc.d/init.d/rgmanager
501 %attr(755,root,root) %{_sbindir}/clubufflush
502 %attr(755,root,root) %{_sbindir}/clufindhostname
503 %attr(755,root,root) %{_sbindir}/clulog
504 %attr(755,root,root) %{_sbindir}/clunfslock
505 %attr(755,root,root) %{_sbindir}/clurgmgrd
506 %attr(755,root,root) %{_sbindir}/clustat
507 %attr(755,root,root) %{_sbindir}/clusvcadm
508 %attr(755,root,root) %{_sbindir}/rg_test
509 %attr(755,root,root) %{_sbindir}/rgmanager
510 %{_mandir}/man8/clubufflush.*
511 %{_mandir}/man8/clufindhostname.*
512 %{_mandir}/man8/clulog.*
513 %{_mandir}/man8/clurgmgrd.*
514 %{_mandir}/man8/clustat.*
515 %{_mandir}/man8/clusvcadm.*
516 %{_mandir}/man8/rgmanager.*
This page took 0.09969 seconds and 3 git commands to generate.