]> git.pld-linux.org Git - packages/cloc.git/blob - cloc.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/cloc.git] / cloc.spec
1 Summary:        CLOC - Count Lines of Code
2 Name:           cloc
3 Version:        1.84
4 Release:        1
5 License:        GPL v2
6 Group:          Applications
7 Source0:        https://github.com/AlDanial/cloc/releases/download/%{version}/%{name}-%{version}.tar.gz
8 # Source0-md5:  a52f3843825377cfa4e4b3b30a567ab4
9 URL:            https://github.com/AlDanial/cloc
10 BuildRequires:  perl-Regexp-Common
11 BuildRequires:  rpm-perlprov >= 4.1-13
12 BuildArch:      noarch
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 cloc counts blank lines, comment lines, and physical lines of source
17 code in many programming languages. Given two versions of a code base,
18 cloc can also compute differences in blank, comment, and source lines.
19
20 %prep
21 %setup -q
22
23 # fix #!env perl -w -> #!%{__perl}:
24 %{__sed} -e '1s,^#!.*perl,#!%{__perl},' Unix/cloc
25
26 %build
27 %{__make} -C Unix
28
29 %install
30 rm -rf $RPM_BUILD_ROOT
31 %{__make} -C Unix install \
32         DESTDIR=$RPM_BUILD_ROOT
33
34 %clean
35 rm -rf $RPM_BUILD_ROOT
36
37 %files
38 %defattr(644,root,root,755)
39 %doc LICENSE README.md sqlite_formatter
40 %doc Unix/{AUTHORS,COPYING,INSTALL,NEWS,README}
41 %attr(755,root,root) %{_bindir}/cloc
42 %{_mandir}/man1/cloc.1*
This page took 0.059108 seconds and 3 git commands to generate.