]> git.pld-linux.org Git - packages/cln.git/blob - cln.spec
- updated to 1.2.2
[packages/cln.git] / cln.spec
1 Summary:        C++ Class Library for Numbers
2 Summary(pl.UTF-8):      Biblioteka klas C++ dla liczb
3 Name:           cln
4 Version:        1.2.2
5 Release:        1
6 License:        GPL
7 Group:          Libraries
8 Source0:        ftp://ftpthep.physik.uni-mainz.de/pub/gnu/%{name}-%{version}.tar.bz2
9 # Source0-md5:  6b479281fec86314b4c7a9357bd83ef8
10 Patch0:         %{name}-info.patch
11 URL:            http://www.ginac.de/CLN/
12 BuildRequires:  autoconf >= 2.50
13 BuildRequires:  automake
14 BuildRequires:  gmp-devel >= 3.0
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  libtool >= 2:1.5
17 BuildRequires:  tetex-dvips
18 BuildRequires:  tetex-fonts-latex
19 BuildRequires:  tetex-format-plain
20 BuildRequires:  tetex-metafont
21 BuildRequires:  texinfo
22 BuildRequires:  texinfo-texi2dvi
23 Requires:       gmp >= 3.0
24 Obsoletes:      libcln2
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 # won't work with -O0 because of static const initialization loops
28 %define         debugcflags     -O1 -g
29
30 %description
31 A GPLed collection of C++ math classes and functions, that will bring
32 efficiency, type safety, algebraic syntax to everyone in a memory and
33 speed efficient library.
34
35 %description -l pl.UTF-8
36 Objęty licencją GPL zbiór klas i funkcji matematycznych C++ dający
37 wydajność, bezpieczne typy i składnię algebraiczną.
38
39 %package devel
40 Summary:        Development files for programs using the CLN library
41 Summary(pl.UTF-8):      Pliki do programowania z użyciem biblioteki CLN
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       gmp-devel >= 3.0
45 Requires:       libstdc++-devel
46 Obsoletes:      libcln2-devel
47
48 %description devel
49 This package is necessary if you wish to develop software based on the
50 CLN library.
51
52 %description devel -l pl.UTF-8
53 Ten pakiet jest niezbędny do tworzenia oprogramowania opartego na
54 bibliotece CLN.
55
56 %package static
57 Summary:        Static CLN library
58 Summary(pl.UTF-8):      Statyczna biblioteka CLN
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static CLN library.
64
65 %description static -l pl.UTF-8
66 Statyczna biblioteka CLN.
67
68 %prep
69 %setup -q
70 %patch0 -p1
71
72 rm -f m4/libtool.m4
73
74 %build
75 %{__libtoolize}
76 %{__aclocal} -I m4
77 %{__autoconf}
78 %configure
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
84
85 %{__make} install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 install examples/{Makefile,*.cc} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post   -p /sbin/ldconfig
94 %postun -p /sbin/ldconfig
95
96 %post   devel -p /sbin/postshell
97 -/usr/sbin/fix-info-dir -c %{_infodir}
98
99 %postun devel -p /sbin/postshell
100 -/usr/sbin/fix-info-dir -c %{_infodir}
101
102 %files
103 %defattr(644,root,root,755)
104 %doc ChangeLog NEWS README TODO*
105 %attr(755,root,root) %{_libdir}/libcln.so.*.*.*
106 %attr(755,root,root) %ghost %{_libdir}/libcln.so.5
107
108 %files devel
109 %defattr(644,root,root,755)
110 %attr(755,root,root) %{_libdir}/libcln.so
111 %{_libdir}/libcln.la
112 %{_includedir}/cln
113 %{_infodir}/cln.info*
114 %{_pkgconfigdir}/cln.pc
115 %{_examplesdir}/%{name}-%{version}
116
117 %files static
118 %defattr(644,root,root,755)
119 %{_libdir}/libcln.a
This page took 0.300255 seconds and 3 git commands to generate.