]> git.pld-linux.org Git - packages/clisp.git/commitdiff
- Initial version.
authorqrczak <qrczak@pld-linux.org>
Sat, 1 Dec 2001 12:54:15 +0000 (12:54 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    clisp-shell.patch -> 1.1
    clisp.spec -> 1.1

clisp-shell.patch [new file with mode: 0644]
clisp.spec [new file with mode: 0644]

diff --git a/clisp-shell.patch b/clisp-shell.patch
new file mode 100644 (file)
index 0000000..3612d4d
--- /dev/null
@@ -0,0 +1,13 @@
+--- clisp-2.27/src/makemake.in~        Mon Jun 25 16:54:46 2001
++++ clisp-2.27/src/makemake.in Sat Dec  1 11:22:09 2001
+@@ -282,8 +282,8 @@
+      # Assume we are on Unix, and target=host (not cross-compiling).
+      CROSS=false
+      # Some shells (A/UX and OSF/1) need the parentheses around "arch" below.
+-     HSYS=`((arch) 2>/dev/null || uname -m 2>/dev/null) | $tolower` # system name in lowercase
+-     HSYSOS=`((uname) 2>/dev/null || arch 2>/dev/null) | $tolower` # OS name in lowercase
++     HSYS=`( (arch) 2>/dev/null || uname -m 2>/dev/null) | $tolower` # system name in lowercase
++     HSYSOS=`( (uname) 2>/dev/null || arch 2>/dev/null) | $tolower` # OS name in lowercase
+      if [ "$HSYS" = 386bsd -o "$HSYS" = sun386 -o "$HSYS" = "386/at" -o "$HSYS" = i86pc ] ; then
+        HSYS='i386'
+      fi
diff --git a/clisp.spec b/clisp.spec
new file mode 100644 (file)
index 0000000..0b74c16
--- /dev/null
@@ -0,0 +1,94 @@
+Summary:       Common Lisp (ANSI CL) implementation
+Name:          clisp
+Version:       2.27
+Release:       1
+Icon:          clisp.gif
+License:       GPL
+Group:         Development/Languages
+Group(de):     Entwicklung/Sprachen
+Group(pl):     Programowanie/Jêzyki
+Source0:       ftp://cvs2.cons.org/pub/lisp/clisp/source/latest/%{name}-%{version}.tar.bz2
+#Alternatively http://prdownloads.sourceforge.net/clisp/clisp-2.27.tar.bz2
+Patch0:                %{name}-shell.patch
+URL:           http://clisp.cons.org/
+BuildRequires: readline-devel
+BuildRequires: gettext-devel
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Common Lisp is a high-level, all-purpose programming language. CLISP
+is a Common Lisp implementation by Bruno Haible of Karlsruhe
+University and Michael Stoll of Munich University, both in Germany. It
+mostly supports Common Lisp as described in the ANSI CL standard. It
+runs on microcomputers (DOS, OS/2, Windows NT, Windows 95, Amiga
+500-4000, Acorn RISC PC) as well as on Unix workstations (Linux, SVR4,
+Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI, AIX, Sun3 and others) and
+needs only 2 MB of RAM.
+
+It is free software and may be distributed under the terms of GNU GPL,
+while it is possible to distribute commercial applications compiled
+with CLISP.
+
+The user interface comes in German, English, French and Spanish. CLISP
+includes an interpreter, a compiler, a large subset of CLOS, a foreign
+language interface and a socket interface. An X11 interface is
+available through CLX and Garnet.
+
+%prep
+%setup -q
+%patch0 -p1
+
+%build
+./configure --prefix=%{_prefix}
+cd src
+./makemake \
+       --prefix=%{_prefix} \
+       --with-readline \
+       --with-gettext \
+       --with-dynamic-ffi \
+       --with-module=wildcard \
+       --with-module=regexp \
+       --with-module=bindings/linuxlibc6 \
+       >Makefile
+%{__make} config.lisp
+%{__make}
+#make check
+
+%install
+rm -rf $RPM_BUILD_ROOT
+cd src
+install -d $RPM_BUILD_ROOT{%{_bindir},%{_docdir},%{_libdir},%{_mandir}}
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT \
+       lispdocdir=%{_docdir}/%{name}-%{version} \
+       mandir=%{_mandir}
+cd ..
+mkdir $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
+cp modules/*/*.dvi $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/clisp
+%doc %{_docdir}/%{name}-%{version}
+%dir %{_libdir}/clisp
+%dir %{_libdir}/clisp/base
+%{_libdir}/clisp/base/*.[aho]
+%{_libdir}/clisp/base/lispinit.mem
+%attr(755,root,root) %{_libdir}/clisp/base/lisp.run
+%{_libdir}/clisp/base/makevars
+%{_libdir}/clisp/clisp-link
+%{_libdir}/clisp/data
+%{_libdir}/clisp/full/*.[aho]
+%{_libdir}/clisp/full/lispinit.mem
+%attr(755,root,root) %{_libdir}/clisp/full/lisp.run
+%{_libdir}/clisp/full/makevars
+%{_libdir}/clisp/linkkit
+%lang(de) %{_datadir}/locale/de/LC_MESSAGES/*
+%lang(en) %{_datadir}/locale/en/LC_MESSAGES/*
+%lang(es) %{_datadir}/locale/es/LC_MESSAGES/*
+%lang(fr) %{_datadir}/locale/fr/LC_MESSAGES/*
+%lang(nl) %{_datadir}/locale/nl/LC_MESSAGES/*
+%{_mandir}/man[13]/*
This page took 0.065557 seconds and 4 git commands to generate.