]> git.pld-linux.org Git - packages/clisp.git/blob - clisp.spec
- updated to version 2.30, STBR
[packages/clisp.git] / clisp.spec
1 Summary:        Common Lisp (ANSI CL) implementation
2 Summary(pl):    Implementacja Common Lisp (ANSI CL)
3 Summary(pt_BR): Implementação do Common Lisp (ANSI CL)
4 Name:           clisp
5 Version:        2.30
6 Release:        1
7 License:        GPL
8 Group:          Development/Languages
9 Source0:        ftp://cvs2.cons.org/pub/lisp/clisp/source/latest/%{name}-%{version}.tar.bz2
10 Patch0:         %{name}-shell.patch
11 Icon:           clisp.gif
12 URL:            http://clisp.cons.org/
13 BuildRequires:  readline-devel
14 BuildRequires:  gettext-devel
15 BuildRequires:  ncurses-devel
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Common Lisp is a high-level, all-purpose programming language. CLISP
20 is a Common Lisp implementation by Bruno Haible of Karlsruhe
21 University and Michael Stoll of Munich University, both in Germany. It
22 mostly supports Common Lisp as described in the ANSI CL standard. It
23 runs on microcomputers (DOS, OS/2, Windows NT, Windows 95, Amiga
24 500-4000, Acorn RISC PC) as well as on Unix workstations (Linux, SVR4,
25 Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI, AIX, Sun3 and others) and
26 needs only 2 MB of RAM.
27
28 It is free software and may be distributed under the terms of GNU GPL,
29 while it is possible to distribute commercial applications compiled
30 with CLISP.
31
32 The user interface comes in German, English, French and Spanish. CLISP
33 includes an interpreter, a compiler, a large subset of CLOS, a foreign
34 language interface and a socket interface. An X11 interface is
35 available through CLX and Garnet.
36
37 %description -l pl
38 Common Lisp to wysokopoziomowy jêzyk programowania ogólnego
39 przeznaczenia. CLISP to implementacja Common Lisp, której autorami s±
40 Bruno Haible z Karlsruhe University oraz Michael Stoll z Munich
41 University (oba w Niemczech). W wiêkszo¶ci wspiera Common Lisp opisany
42 w standardzie ANSI CL. Dzia³a na mikrokomputerach (DOS, OS/2, Windows
43 NT, Windows 95, Amiga 500-4000, Acorn RICS PC), a tak¿e stacjach
44 uniksowych (Linux, SVR4, Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI,
45 AIX, Sun3 i inne) i wymaga tylko 2 MB RAM.
46
47 To jest oprogramowanie wolnodostêpne, na licencji GNU GPL, mo¿liwe
48 jest dystrybuowanie komercyjnych aplikacji skompilowanych CLISP-em.
49
50 Interfejs u¿ytkownika dostêpny jest po niemiecku, angielsku, francusku
51 i hiszpañsku. CLISP zawiera interpreter, kompilator, znaczny podzbiór
52 CLOS, interfejs do innych jêzyków oraz interfejs do gniazdek.
53 Interfejs X11 jest dostêpny poprzez CLX i Garnet.
54
55 %description -l pt_BR
56 Common Lisp é uma linguagem de programação de propósito geral de alto
57 nível. CLISP é uma implementação do Common Lisp feita por Bruno
58 Haible, da Universidade Karlsruhe, e Michael Stoll, da Universidade de
59 Munique, ambas na Alemanha. O CLISP é quase totalmente compatível com
60 o Common Lisp descrito pelo padrão ANSI CL. Além disso, CLISP é
61 software livre, distribuído sob os termos da GNU GPL.
62
63 %prep
64 %setup -q
65 %patch0 -p1
66
67 %build
68 ./configure --prefix=%{_prefix}
69 cd src
70 ./makemake \
71         --prefix=%{_prefix} \
72         --with-readline \
73         --with-gettext \
74         --with-dynamic-ffi \
75         --with-module=wildcard \
76         --with-module=regexp \
77         --with-module=bindings/linuxlibc6 \
78         >Makefile
79 %{__make} config.lisp
80 %{__make}
81 #make check
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 cd src
86 install -d $RPM_BUILD_ROOT{%{_bindir},%{_docdir},%{_libdir},%{_mandir}}
87 %{__make} install \
88         DESTDIR=$RPM_BUILD_ROOT \
89         lispdocdir=%{_docdir}/%{name}-%{version} \
90         mandir=%{_mandir}
91 cd ..
92 mkdir $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
93 install modules/*/*.dvi $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
94
95 %find_lang %{name} --all-name
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %files -f %{name}.lang
101 %defattr(644,root,root,755)
102 %attr(755,root,root) %{_bindir}/clisp
103 %doc %{_docdir}/%{name}-%{version}
104 %dir %{_libdir}/clisp
105 %dir %{_libdir}/clisp/base
106 %{_libdir}/clisp/base/*.[aho]
107 %{_libdir}/clisp/base/lispinit.mem
108 %attr(755,root,root) %{_libdir}/clisp/base/lisp.run
109 %attr(755,root,root) %{_libdir}/clisp/full/lisp.run
110 %{_libdir}/clisp/base/makevars
111 %{_libdir}/clisp/clisp-link
112 %{_libdir}/clisp/data
113 %{_libdir}/clisp/full/*.[aho]
114 %{_libdir}/clisp/full/lispinit.mem
115 %{_libdir}/clisp/full/makevars
116 %{_libdir}/clisp/linkkit
117 %{_mandir}/man[13]/*
This page took 0.396177 seconds and 4 git commands to generate.