]> git.pld-linux.org Git - packages/clisp.git/blob - clisp.spec
- pl translations, cosmetics
[packages/clisp.git] / clisp.spec
1 Summary:        Common Lisp (ANSI CL) implementation
2 Summary(pl):    Implementacja Common Lisp (ANSI CL)
3 Name:           clisp
4 Version:        2.27
5 Release:        1
6 Icon:           clisp.gif
7 License:        GPL
8 Group:          Development/Languages
9 Group(de):      Entwicklung/Sprachen
10 Group(pl):      Programowanie/Jêzyki
11 Source0:        ftp://cvs2.cons.org/pub/lisp/clisp/source/latest/%{name}-%{version}.tar.bz2
12 #Alternatively http://prdownloads.sourceforge.net/clisp/clisp-2.27.tar.bz2
13 Patch0:         %{name}-shell.patch
14 URL:            http://clisp.cons.org/
15 BuildRequires:  readline-devel
16 BuildRequires:  gettext-devel
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Common Lisp is a high-level, all-purpose programming language. CLISP
21 is a Common Lisp implementation by Bruno Haible of Karlsruhe
22 University and Michael Stoll of Munich University, both in Germany. It
23 mostly supports Common Lisp as described in the ANSI CL standard. It
24 runs on microcomputers (DOS, OS/2, Windows NT, Windows 95, Amiga
25 500-4000, Acorn RISC PC) as well as on Unix workstations (Linux, SVR4,
26 Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI, AIX, Sun3 and others) and
27 needs only 2 MB of RAM.
28
29 It is free software and may be distributed under the terms of GNU GPL,
30 while it is possible to distribute commercial applications compiled
31 with CLISP.
32
33 The user interface comes in German, English, French and Spanish. CLISP
34 includes an interpreter, a compiler, a large subset of CLOS, a foreign
35 language interface and a socket interface. An X11 interface is
36 available through CLX and Garnet.
37
38 %description -l pl
39 Common Lisp to wysokopoziomowy jêzyk programowania ogólnego
40 przeznaczenia. CLISP to implementacja Common Lisp, której autorami s±
41 Bruno Haible z Karlsruhe University oraz Michael Stoll z Munich
42 University (oba w Niemczech). W wiêkszo¶ci wspiera Common Lisp opisany
43 w standardzie ANSI CL. Dzia³a na mikrokomputerach (DOS, OS/2, Windows
44 NT, Windows 95, Amiga 500-4000, Acorn RICS PC), a tak¿e stacjach
45 uniksowych (Linux, SVR4, Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI,
46 AIX, Sun3 i inne) i wymaga tylko 2 MB RAM.
47
48 To jest oprogramowanie wolnodostêpne, na licencji GNU GPL, mo¿liwe
49 jest dystrybuowanie komercyjnych aplikacji skompilowanych CLISP-em.
50
51 Interfejs u¿ytkownika dostêpny jest po niemiecku, angielsku, francusku
52 i hiszpañsku. CLISP zawiera interpreter, kompilator, znaczny podzbiór
53 CLOS, interfejs do innych jêzyków oraz interfejs do gniazdek.
54 Interfejs X11 jest dostêpny poprzez CLX i Garnet.
55
56 %prep
57 %setup -q
58 %patch0 -p1
59
60 %build
61 ./configure --prefix=%{_prefix}
62 cd src
63 ./makemake \
64         --prefix=%{_prefix} \
65         --with-readline \
66         --with-gettext \
67         --with-dynamic-ffi \
68         --with-module=wildcard \
69         --with-module=regexp \
70         --with-module=bindings/linuxlibc6 \
71         >Makefile
72 %{__make} config.lisp
73 %{__make}
74 #make check
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 cd src
79 install -d $RPM_BUILD_ROOT{%{_bindir},%{_docdir},%{_libdir},%{_mandir}}
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT \
82         lispdocdir=%{_docdir}/%{name}-%{version} \
83         mandir=%{_mandir}
84 cd ..
85 mkdir $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
86 install modules/*/*.dvi $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(644,root,root,755)
93 %attr(755,root,root) %{_bindir}/clisp
94 %doc %{_docdir}/%{name}-%{version}
95 %dir %{_libdir}/clisp
96 %dir %{_libdir}/clisp/base
97 %{_libdir}/clisp/base/*.[aho]
98 %{_libdir}/clisp/base/lispinit.mem
99 %attr(755,root,root) %{_libdir}/clisp/base/lisp.run
100 %{_libdir}/clisp/base/makevars
101 %{_libdir}/clisp/clisp-link
102 %{_libdir}/clisp/data
103 %{_libdir}/clisp/full/*.[aho]
104 %{_libdir}/clisp/full/lispinit.mem
105 %attr(755,root,root) %{_libdir}/clisp/full/lisp.run
106 %{_libdir}/clisp/full/makevars
107 %{_libdir}/clisp/linkkit
108 %lang(de) %{_datadir}/locale/de/LC_MESSAGES/*
109 %lang(en) %{_datadir}/locale/en/LC_MESSAGES/*
110 %lang(es) %{_datadir}/locale/es/LC_MESSAGES/*
111 %lang(fr) %{_datadir}/locale/fr/LC_MESSAGES/*
112 %lang(nl) %{_datadir}/locale/nl/LC_MESSAGES/*
113 %{_mandir}/man[13]/*
This page took 0.163214 seconds and 3 git commands to generate.