]> git.pld-linux.org Git - packages/clisp.git/blob - clisp.spec
- merge translations from Conectiva.
[packages/clisp.git] / clisp.spec
1 Summary:        Common Lisp (ANSI CL) implementation
2 Summary(pl):    Implementacja Common Lisp (ANSI CL)
3 Summary(pt_BR): Implementação do Common Lisp (ANSI CL)
4 Name:           clisp
5 Version:        2.28
6 Release:        3
7 License:        GPL
8 Group:          Development/Languages
9 Source0:        ftp://cvs2.cons.org/pub/lisp/clisp/source/latest/%{name}-%{version}.tar.bz2
10 #Alternatively http://prdownloads.sourceforge.net/clisp/clisp-2.27.tar.bz2
11 Patch0:         %{name}-shell.patch
12 Icon:           clisp.gif
13 URL:            http://clisp.cons.org/
14 BuildRequires:  readline-devel
15 BuildRequires:  gettext-devel
16 BuildRequires:  ncurses-devel
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Common Lisp is a high-level, all-purpose programming language. CLISP
21 is a Common Lisp implementation by Bruno Haible of Karlsruhe
22 University and Michael Stoll of Munich University, both in Germany. It
23 mostly supports Common Lisp as described in the ANSI CL standard. It
24 runs on microcomputers (DOS, OS/2, Windows NT, Windows 95, Amiga
25 500-4000, Acorn RISC PC) as well as on Unix workstations (Linux, SVR4,
26 Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI, AIX, Sun3 and others) and
27 needs only 2 MB of RAM.
28
29 It is free software and may be distributed under the terms of GNU GPL,
30 while it is possible to distribute commercial applications compiled
31 with CLISP.
32
33 The user interface comes in German, English, French and Spanish. CLISP
34 includes an interpreter, a compiler, a large subset of CLOS, a foreign
35 language interface and a socket interface. An X11 interface is
36 available through CLX and Garnet.
37
38 %description -l pl
39 Common Lisp to wysokopoziomowy jêzyk programowania ogólnego
40 przeznaczenia. CLISP to implementacja Common Lisp, której autorami s±
41 Bruno Haible z Karlsruhe University oraz Michael Stoll z Munich
42 University (oba w Niemczech). W wiêkszo¶ci wspiera Common Lisp opisany
43 w standardzie ANSI CL. Dzia³a na mikrokomputerach (DOS, OS/2, Windows
44 NT, Windows 95, Amiga 500-4000, Acorn RICS PC), a tak¿e stacjach
45 uniksowych (Linux, SVR4, Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI,
46 AIX, Sun3 i inne) i wymaga tylko 2 MB RAM.
47
48 To jest oprogramowanie wolnodostêpne, na licencji GNU GPL, mo¿liwe
49 jest dystrybuowanie komercyjnych aplikacji skompilowanych CLISP-em.
50
51 Interfejs u¿ytkownika dostêpny jest po niemiecku, angielsku, francusku
52 i hiszpañsku. CLISP zawiera interpreter, kompilator, znaczny podzbiór
53 CLOS, interfejs do innych jêzyków oraz interfejs do gniazdek.
54 Interfejs X11 jest dostêpny poprzez CLX i Garnet.
55
56 %description -l pt_BR
57 Common Lisp é uma linguagem de programação de propósito geral de alto
58 nível. CLISP é uma implementação do Common Lisp feita por Bruno
59 Haible, da Universidade Karlsruhe, e Michael Stoll, da Universidade de
60 Munique, ambas na Alemanha. O CLISP é quase totalmente compatível com
61 o Common Lisp descrito pelo padrão ANSI CL. Além disso, CLISP é
62 software livre, distribuído sob os termos da GNU GPL.
63
64 %prep
65 %setup -q
66 %patch0 -p1
67
68 %build
69 ./configure --prefix=%{_prefix}
70 cd src
71 ./makemake \
72         --prefix=%{_prefix} \
73         --with-readline \
74         --with-gettext \
75         --with-dynamic-ffi \
76         --with-module=wildcard \
77         --with-module=regexp \
78         --with-module=bindings/linuxlibc6 \
79         >Makefile
80 %{__make} config.lisp
81 %{__make}
82 #make check
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 cd src
87 install -d $RPM_BUILD_ROOT{%{_bindir},%{_docdir},%{_libdir},%{_mandir}}
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT \
90         lispdocdir=%{_docdir}/%{name}-%{version} \
91         mandir=%{_mandir}
92 cd ..
93 mkdir $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
94 install modules/*/*.dvi $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
95
96 %find_lang %{name} --all-name
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %files -f %{name}.lang
102 %defattr(644,root,root,755)
103 %attr(755,root,root) %{_bindir}/clisp
104 %doc %{_docdir}/%{name}-%{version}
105 %dir %{_libdir}/clisp
106 %dir %{_libdir}/clisp/base
107 %{_libdir}/clisp/base/*.[aho]
108 %{_libdir}/clisp/base/lispinit.mem
109 %attr(755,root,root) %{_libdir}/clisp/base/lisp.run
110 %attr(755,root,root) %{_libdir}/clisp/full/lisp.run
111 %{_libdir}/clisp/base/makevars
112 %{_libdir}/clisp/clisp-link
113 %{_libdir}/clisp/data
114 %{_libdir}/clisp/full/*.[aho]
115 %{_libdir}/clisp/full/lispinit.mem
116 %{_libdir}/clisp/full/makevars
117 %{_libdir}/clisp/linkkit
118 %{_mandir}/man[13]/*
This page took 0.083709 seconds and 3 git commands to generate.