]> git.pld-linux.org Git - packages/clisp.git/blob - clisp.spec
- readline 5.0
[packages/clisp.git] / clisp.spec
1 Summary:        Common Lisp (ANSI CL) implementation
2 Summary(pl):    Implementacja Common Lisp (ANSI CL)
3 Summary(pt_BR): Implementação do Common Lisp (ANSI CL)
4 Name:           clisp
5 Version:        2.34
6 Release:        2
7 License:        GPL
8 Group:          Development/Languages
9 Source0:        http://dl.sourceforge.net/clisp/%{name}-%{version}.tar.bz2
10 # Source0-md5:  68b20ad2d13bdc544e57000e38c856de
11 Patch0:         %{name}-shell.patch
12 Icon:           clisp.gif
13 URL:            http://clisp.cons.org/
14 BuildRequires:  gettext-devel
15 BuildRequires:  ncurses-devel
16 BuildRequires:  readline-devel
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Common Lisp is a high-level, all-purpose programming language. CLISP
21 is a Common Lisp implementation by Bruno Haible of Karlsruhe
22 University and Michael Stoll of Munich University, both in Germany. It
23 mostly supports Common Lisp as described in the ANSI CL standard. It
24 runs on microcomputers (DOS, OS/2, Windows NT, Windows 95, Amiga
25 500-4000, Acorn RISC PC) as well as on Unix workstations (Linux, SVR4,
26 Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI, AIX, Sun3 and others) and
27 needs only 2 MB of RAM.
28
29 It is free software and may be distributed under the terms of GNU GPL,
30 while it is possible to distribute commercial applications compiled
31 with CLISP.
32
33 The user interface comes in German, English, French and Spanish. CLISP
34 includes an interpreter, a compiler, a large subset of CLOS, a foreign
35 language interface and a socket interface. An X11 interface is
36 available through CLX and Garnet.
37
38 %description -l pl
39 Common Lisp to wysokopoziomowy jêzyk programowania ogólnego
40 przeznaczenia. CLISP to implementacja Common Lisp, której autorami s±
41 Bruno Haible z Karlsruhe University oraz Michael Stoll z Munich
42 University (oba w Niemczech). W wiêkszo¶ci wspiera Common Lisp opisany
43 w standardzie ANSI CL. Dzia³a na mikrokomputerach (DOS, OS/2, Windows
44 NT, Windows 95, Amiga 500-4000, Acorn RICS PC), a tak¿e stacjach
45 uniksowych (Linux, SVR4, Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI,
46 AIX, Sun3 i inne) i wymaga tylko 2 MB RAM.
47
48 To jest oprogramowanie wolnodostêpne, na licencji GNU GPL, mo¿liwe
49 jest dystrybuowanie komercyjnych aplikacji skompilowanych CLISP-em.
50
51 Interfejs u¿ytkownika dostêpny jest po niemiecku, angielsku, francusku
52 i hiszpañsku. CLISP zawiera interpreter, kompilator, znaczny podzbiór
53 CLOS, interfejs do innych jêzyków oraz interfejs do gniazdek.
54 Interfejs X11 jest dostêpny poprzez CLX i Garnet.
55
56 %description -l pt_BR
57 Common Lisp é uma linguagem de programação de propósito geral de alto
58 nível. CLISP é uma implementação do Common Lisp feita por Bruno
59 Haible, da Universidade Karlsruhe, e Michael Stoll, da Universidade de
60 Munique, ambas na Alemanha. O CLISP é quase totalmente compatível com
61 o Common Lisp descrito pelo padrão ANSI CL. Além disso, CLISP é
62 software livre, distribuído sob os termos da GNU GPL.
63
64 %prep
65 %setup -q
66 %patch0 -p1
67
68 # changing default -O to optflags causes memory fault on amd64
69 # - so something is broken... code or compiler
70 # -fno-strict-aliasing seems to fix crashes on amd64 but doesn't fix
71 # random crashes on sparc (which occur with default CFLAGS)
72 #%{__perl} -pi -e "s@' -O2?([^0])@' %{rpmcflags} -fno-strict-aliasing\$1@" src/makemake.in
73
74 %build
75 ./configure \
76         --prefix=%{_prefix}
77 cd src
78 ./makemake \
79         --prefix=%{_prefix} \
80         --with-readline \
81         --with-gettext \
82         --with-dynamic-ffi \
83         --fsstnd=redhat \
84         --with-module=wildcard \
85         --with-module=regexp \
86         --with-module=bindings/glibc \
87         --with-module=clx/new-clx \
88         --with-module=syscalls \
89         >Makefile
90 %{__make} config.lisp
91 %{__make} \
92         libdir=%{_libdir}
93 #make check
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 %{__make} -C src install \
99         DESTDIR=$RPM_BUILD_ROOT \
100         libdir=%{_libdir} \
101         lispdocdir=%{_docdir}/%{name}-%{version} \
102         mandir=%{_mandir}
103
104 install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
105 install modules/*/*.dvi $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
106
107 %find_lang %{name} --all-name
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %files -f %{name}.lang
113 %defattr(644,root,root,755)
114 %attr(755,root,root) %{_bindir}/clisp
115 %doc %{_docdir}/%{name}-%{version}
116 %dir %{_libdir}/clisp
117 %dir %{_libdir}/clisp/base
118 %{_libdir}/clisp/base/*.[aho]
119 %{_libdir}/clisp/base/lispinit.mem
120 %attr(755,root,root) %{_libdir}/clisp/base/lisp.run
121 %{_libdir}/clisp/base/makevars
122 %{_libdir}/clisp/clisp-link
123 %{_libdir}/clisp/data
124 %dir %{_libdir}/clisp/full
125 %attr(755,root,root) %{_libdir}/clisp/full/lisp.run
126 %{_libdir}/clisp/full/*.[aho]
127 %{_libdir}/clisp/full/lispinit.mem
128 %{_libdir}/clisp/full/makevars
129 %{_libdir}/clisp/linkkit
130 %{_mandir}/man[13]/*
This page took 0.056366 seconds and 3 git commands to generate.