]> git.pld-linux.org Git - packages/clisp.git/blob - clisp.spec
*** empty log message ***
[packages/clisp.git] / clisp.spec
1 Summary:        Common Lisp (ANSI CL) implementation
2 Summary(pl):    Implementacja Common Lisp (ANSI CL)
3 Summary(pt_BR): Implementação do Common Lisp (ANSI CL)
4 Name:           clisp
5 Version:        2.32
6 Release:        1
7 License:        GPL
8 Group:          Development/Languages
9 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
10 # Source0-md5:  20a036128ec04e7a48d44c1a1c6f8afe
11 Patch0:         %{name}-shell.patch
12 Icon:           clisp.gif
13 URL:            http://clisp.cons.org/
14 BuildRequires:  readline-devel
15 BuildRequires:  gettext-devel
16 BuildRequires:  ncurses-devel
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Common Lisp is a high-level, all-purpose programming language. CLISP
21 is a Common Lisp implementation by Bruno Haible of Karlsruhe
22 University and Michael Stoll of Munich University, both in Germany. It
23 mostly supports Common Lisp as described in the ANSI CL standard. It
24 runs on microcomputers (DOS, OS/2, Windows NT, Windows 95, Amiga
25 500-4000, Acorn RISC PC) as well as on Unix workstations (Linux, SVR4,
26 Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI, AIX, Sun3 and others) and
27 needs only 2 MB of RAM.
28
29 It is free software and may be distributed under the terms of GNU GPL,
30 while it is possible to distribute commercial applications compiled
31 with CLISP.
32
33 The user interface comes in German, English, French and Spanish. CLISP
34 includes an interpreter, a compiler, a large subset of CLOS, a foreign
35 language interface and a socket interface. An X11 interface is
36 available through CLX and Garnet.
37
38 %description -l pl
39 Common Lisp to wysokopoziomowy jêzyk programowania ogólnego
40 przeznaczenia. CLISP to implementacja Common Lisp, której autorami s±
41 Bruno Haible z Karlsruhe University oraz Michael Stoll z Munich
42 University (oba w Niemczech). W wiêkszo¶ci wspiera Common Lisp opisany
43 w standardzie ANSI CL. Dzia³a na mikrokomputerach (DOS, OS/2, Windows
44 NT, Windows 95, Amiga 500-4000, Acorn RICS PC), a tak¿e stacjach
45 uniksowych (Linux, SVR4, Sun4, DEC Alpha OSF, HP-UX, NeXTstep, SGI,
46 AIX, Sun3 i inne) i wymaga tylko 2 MB RAM.
47
48 To jest oprogramowanie wolnodostêpne, na licencji GNU GPL, mo¿liwe
49 jest dystrybuowanie komercyjnych aplikacji skompilowanych CLISP-em.
50
51 Interfejs u¿ytkownika dostêpny jest po niemiecku, angielsku, francusku
52 i hiszpañsku. CLISP zawiera interpreter, kompilator, znaczny podzbiór
53 CLOS, interfejs do innych jêzyków oraz interfejs do gniazdek.
54 Interfejs X11 jest dostêpny poprzez CLX i Garnet.
55
56 %description -l pt_BR
57 Common Lisp é uma linguagem de programação de propósito geral de alto
58 nível. CLISP é uma implementação do Common Lisp feita por Bruno
59 Haible, da Universidade Karlsruhe, e Michael Stoll, da Universidade de
60 Munique, ambas na Alemanha. O CLISP é quase totalmente compatível com
61 o Common Lisp descrito pelo padrão ANSI CL. Além disso, CLISP é
62 software livre, distribuído sob os termos da GNU GPL.
63
64 %prep
65 %setup -q
66 %patch0 -p1
67
68 %build
69 ./configure --prefix=%{_prefix}
70 cd src
71 ./makemake \
72         --prefix=%{_prefix} \
73         --with-readline \
74         --with-gettext \
75         --with-dynamic-ffi \
76         --fsstnd=redhat \
77         --with-module=wildcard \
78         --with-module=regexp \
79         --with-module=bindings/glibc \
80         --with-module=clx/new-clx \
81         --with-module=syscalls \
82         >Makefile
83 %{__make} config.lisp
84 %{__make}
85 #make check
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 cd src
90 install -d $RPM_BUILD_ROOT{%{_bindir},%{_docdir},%{_libdir},%{_mandir}}
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT \
93         lispdocdir=%{_docdir}/%{name}-%{version} \
94         mandir=%{_mandir}
95 cd ..
96 mkdir $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
97 install modules/*/*.dvi $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/modules
98
99 %find_lang %{name} --all-name
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %files -f %{name}.lang
105 %defattr(644,root,root,755)
106 %attr(755,root,root) %{_bindir}/clisp
107 %doc %{_docdir}/%{name}-%{version}
108 %dir %{_libdir}/clisp
109 %dir %{_libdir}/clisp/base
110 %{_libdir}/clisp/base/*.[aho]
111 %{_libdir}/clisp/base/lispinit.mem
112 %attr(755,root,root) %{_libdir}/clisp/base/lisp.run
113 %attr(755,root,root) %{_libdir}/clisp/full/lisp.run
114 %{_libdir}/clisp/base/makevars
115 %{_libdir}/clisp/clisp-link
116 %{_libdir}/clisp/data
117 %{_libdir}/clisp/full/*.[aho]
118 %{_libdir}/clisp/full/lispinit.mem
119 %{_libdir}/clisp/full/makevars
120 %{_libdir}/clisp/linkkit
121 %{_mandir}/man[13]/*
This page took 0.071128 seconds and 3 git commands to generate.