]> git.pld-linux.org Git - packages/clementine.git/commitdiff
- up to 0.6rc1 tarball
authorElan Ruusamäe <glen@pld-linux.org>
Wed, 8 Dec 2010 22:24:06 +0000 (22:24 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    build-languages-dynamic.patch -> 1.2
    clementine.spec -> 1.27
    desktop-install.patch -> 1.3
    qt-ver.patch -> 1.2

build-languages-dynamic.patch [deleted file]
clementine.spec
desktop-install.patch
qt-ver.patch [deleted file]

diff --git a/build-languages-dynamic.patch b/build-languages-dynamic.patch
deleted file mode 100644 (file)
index 2a6841e..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-Set LANGUAGES dynamically at build time, this allows easily add new languages
-just by placing .po into src/translations dir
-
-Author: Elan Ruusamäe <glen@delfi.ee>
---- clementine-0.5.3/src/CMakeLists.txt~       2010-10-20 13:10:28.276756134 +0300
-+++ clementine-0.5.3/src/CMakeLists.txt        2010-10-20 13:10:33.456551043 +0300
-@@ -327,41 +327,12 @@
- set(LINGUAS "All" CACHE STRING "A space-seperated list of translations to compile in to Clementine, or \"None\".")
- if (LINGUAS STREQUAL "All")
--  set (LANGUAGES
--    ar
--    bg
--    ca
--    cs
--    da
--    de
--    el
--    en_CA
--    en_GB
--    es
--    fi
--    fr
--    gl
--    hu
--    it
--    kk
--    lt
--    nb
--    nl
--    oc
--    pl
--    pt
--    pt_BR
--    ro
--    ru
--    sk
--    sl
--    sr
--    sv
--    tr
--    uk
--    zh_CN
--    zh_TW
--  )
-+  # build LANGUAGES from all existing .po files
-+  file(GLOB pofiles translations/*.po)
-+  foreach(pofile ${pofiles})
-+    get_filename_component(lang ${pofile} NAME_WE)
-+    list(APPEND LANGUAGES ${lang})
-+  endforeach(pofile)
- else (LINGUAS STREQUAL "All")
-   if (NOT LINGUAS OR LINGUAS STREQUAL "None")
-     set (LANGUAGES "")
index dac7b4e42b3c995884e320ae76578db2d02a2cb1..643bb961e6fb35e9d4f196af292f55777eb6e85b 100644 (file)
 Summary:       A music player and library organiser
 Summary(hu.UTF-8):     Egy zenelejátszó és gyűjtemény-kezelő
 Name:          clementine
-Version:       0.5.3
-Release:       3
+Version:       0.6
+Release:       0.1
 License:       GPL v3 and GPL v2+
 Group:         Applications/Multimedia
 URL:           http://www.clementine-player.org/
-Source0:       http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
-# Source0-md5: 3411a0e31bdab7a6693048e934996f40
+Source0:       http://clementine-player.googlecode.com/files/%{name}-%{version}rc1.tar.gz
+# Source0-md5: cbe2b70a8df53b19e5d881a674708c5d
 Patch0:                desktop-install.patch
 Patch1:                unbundle-po.patch
-Patch2:                build-languages-dynamic.patch
-Patch3:                qt-ver.patch
 BuildRequires: QtCore-devel >= %{qtver}
 BuildRequires: QtDBus-devel >= %{qtver}
 BuildRequires: QtGui-devel >= %{qtver}
@@ -96,11 +94,9 @@ az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
 a Qt4 előnyeit.
 
 %prep
-%setup -q
+%setup -q -n clementine-0.5.90
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
-%patch3 -p1
 
 # We already don't use these but just to make sure
 rm -rf 3rdparty/gmock
index 7b06b1cdd5fc47d604dcd133ac38f6daaeace642..1452675ad5fed5774c2e48b71ec2101cd746615e 100644 (file)
@@ -9,16 +9,16 @@
  Terminal=false
  Categories=AudioVideo;Player;Qt;
  StartupNotify=false
---- clementine-0.4/src/CMakeLists.txt  2010-06-28 19:47:58.000000000 +0000
-+++ clementine-0.4/src/CMakeLists.txt  2010-06-29 20:49:41.000000000 +0000
-@@ -546,8 +546,8 @@
-   )
+--- clementine-0.5.90/dist/CMakeLists.txt~     2010-10-24 16:16:44.000000000 +0300
++++ clementine-0.5.90/dist/CMakeLists.txt      2010-12-09 00:20:22.298618631 +0200
+@@ -14,8 +14,8 @@
  
-   install(FILES ../dist/clementine_64.png
+ if (NOT APPLE)
+   install(FILES clementine_64.png
 -    DESTINATION share/icons/hicolor/64x64/apps/
 -    RENAME application-x-clementine.png
 +    DESTINATION share/pixmaps
 +    RENAME clementine.png
    )
  
-   install(FILES ../dist/clementine.desktop
+   install(FILES ../data/icon.svg
diff --git a/qt-ver.patch b/qt-ver.patch
deleted file mode 100644 (file)
index d506fc7..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- clementine-0.5.3/CMakeLists.txt~   2010-10-19 14:26:26.098273180 +0300
-+++ clementine-0.5.3/CMakeLists.txt    2010-10-21 15:46:12.957182252 +0300
-@@ -7,7 +7,8 @@
- include(cmake/Deb.cmake)
- include(cmake/Rpm.cmake)
--find_package(Qt4 REQUIRED QtCore QtGui QtOpenGL QtSql QtNetwork QtXml)
-+find_package(Qt4 4.5.0 REQUIRED QtCore QtGui QtOpenGL QtSql QtNetwork QtXml)
-+
- if(UNIX AND NOT APPLE)
-   find_package(Qt4 REQUIRED QtDbus)
- endif(UNIX AND NOT APPLE)
This page took 0.086346 seconds and 4 git commands to generate.