]> git.pld-linux.org Git - packages/clementine.git/commitdiff
- added gcc11 patch, release 23 auto/th/clementine-1.3.1-23
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 10 Jul 2022 08:29:34 +0000 (10:29 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 10 Jul 2022 08:29:34 +0000 (10:29 +0200)
clementine-gcc11.patch [new file with mode: 0644]
clementine.spec

diff --git a/clementine-gcc11.patch b/clementine-gcc11.patch
new file mode 100644 (file)
index 0000000..83eea00
--- /dev/null
@@ -0,0 +1,72 @@
+Based on the following (but downgrade to gnu++11 as C++17 forbids throw specifications)
+
+From 5472f628c803f3d4c5f62f11fe1d2f9f92237bc7 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Robert-Andr=C3=A9=20Mauchin?= <zebob.m@gmail.com>
+Date: Wed, 16 Dec 2020 20:03:26 +0100
+Subject: [PATCH] Drop -std=c++0x and -U__STRICT_ANSI__
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+This was causing compilation failures, static assertion failed, with GCC 11.
+
+Fix #6865
+
+Signed-off-by: Robert-André Mauchin <zebob.m@gmail.com>
+---
+ ext/clementine-spotifyblob/CMakeLists.txt | 2 +-
+ ext/clementine-tagreader/CMakeLists.txt   | 2 +-
+ src/CMakeLists.txt                        | 2 +-
+ tests/CMakeLists.txt                      | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/ext/clementine-spotifyblob/CMakeLists.txt b/ext/clementine-spotifyblob/CMakeLists.txt
+index e5342ee5b3..6fd551d572 100644
+--- a/ext/clementine-spotifyblob/CMakeLists.txt
++++ b/ext/clementine-spotifyblob/CMakeLists.txt
+@@ -7,7 +7,7 @@ include_directories(${CMAKE_SOURCE_DIR}/ext/libclementine-spotifyblob)
+ include_directories(${CMAKE_SOURCE_DIR}/ext/libclementine-common)
+ include_directories(${CMAKE_SOURCE_DIR}/src)
+-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Woverloaded-virtual -Wall -Wno-sign-compare -Wno-deprecated-declarations -Wno-unused-local-typedefs -Wno-unused-private-field -Wno-unknown-warning-option --std=c++0x -U__STRICT_ANSI__")
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Woverloaded-virtual -Wall -Wno-sign-compare -Wno-deprecated-declarations -Wno-unused-local-typedefs -Wno-unused-private-field -Wno-unknown-warning-option -std=gnu++11")
+ link_directories(${SPOTIFY_LIBRARY_DIRS})
+diff --git a/ext/clementine-tagreader/CMakeLists.txt b/ext/clementine-tagreader/CMakeLists.txt
+index 855e390cfe..a48b014504 100644
+--- a/ext/clementine-tagreader/CMakeLists.txt
++++ b/ext/clementine-tagreader/CMakeLists.txt
+@@ -7,7 +7,7 @@ include_directories(${CMAKE_BINARY_DIR}/ext/libclementine-tagreader)
+ include_directories(${CMAKE_SOURCE_DIR}/src)
+ include_directories(${CMAKE_BINARY_DIR}/src)
+-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} --std=c++0x -U__STRICT_ANSI__")
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=gnu++11")
+ set(EXECUTABLE_OUTPUT_PATH ${CMAKE_BINARY_DIR})
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 627b2e7cb9..0bbc775ba8 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -1,6 +1,6 @@
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall")
+-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Woverloaded-virtual -Wall -Wno-sign-compare -Wno-deprecated-declarations -Wno-unused-local-typedefs -Wno-unused-private-field -Wno-unknown-warning-option --std=c++0x -U__STRICT_ANSI__")
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Woverloaded-virtual -Wall -Wno-sign-compare -Wno-deprecated-declarations -Wno-unused-local-typedefs -Wno-unused-private-field -Wno-unknown-warning-option -std=gnu++11")
+ option(BUILD_WERROR "Build with -Werror" ON)
+diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
+index 4474e7be51..ff571fc199 100644
+--- a/tests/CMakeLists.txt
++++ b/tests/CMakeLists.txt
+@@ -1,6 +1,6 @@
+ cmake_minimum_required(VERSION 2.6)
+-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x -fpermissive -Wno-c++11-narrowing -U__STRICT_ANSI__")
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fpermissive -Wno-c++11-narrowing -std=gnu++11")
+ if(USE_SYSTEM_GMOCK)
+   include_directories(${GMOCK_INCLUDE_DIRS} ${GTEST_INCLUDE_DIRS})
index 01856fd2505ed6b715057ca2fbc1eea14d064e7e..39a0e33f9dbdc03f265a63d479514a3b6ed9ead3 100644 (file)
@@ -20,7 +20,7 @@ Summary(hu.UTF-8):    Egy zenelejátszó és gyűjtemény-kezelő
 Summary(pl.UTF-8):     Odtwarzacz muzyki i organizator biblioteczki
 Name:          clementine
 Version:       1.3.1
-Release:       22
+Release:       23
 License:       GPL v3 and GPL v2+
 Group:         X11/Applications/Multimedia
 Source0:       https://github.com/clementine-player/Clementine/releases/download/%{version}/%{name}-%{version}.tar.xz
@@ -32,6 +32,7 @@ Patch3:               %{name}-mygpo.patch
 Patch4:                moc.patch
 Patch5:                %{name}-protobuf.patch
 Patch6:                %{name}-cryptopp.patch
+Patch7:                %{name}-gcc11.patch
 URL:           https://www.clementine-player.org/
 BuildRequires: OpenGL-devel
 BuildRequires: QtCore-devel >= %{qt_ver}
@@ -125,6 +126,7 @@ przepisanymi tak, aby wykorzystać Qt4.
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
+%patch7 -p1
 
 # cleanup vendor. keep only needed libraries.
 %{__mv} 3rdparty 3rdparty.dist
This page took 1.304288 seconds and 4 git commands to generate.