]> git.pld-linux.org Git - packages/clementine.git/blob - clementine.spec
libimobiledevice patch is not backward compatible
[packages/clementine.git] / clementine.spec
1 # TODO:
2 # - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
3 # - apply patches to libprojectM.spec and use
4 # - Google Drive support (missing Google sparsehash)
5 # - package for kde4 stuff (or nuke them):
6 #        /usr/share/kde4/services/clementine-feed.protocol
7 #        /usr/share/kde4/services/clementine-itms.protocol
8 #        /usr/share/kde4/services/clementine-itpc.protocol
9 #        /usr/share/kde4/services/clementine-zune.protocol
10 #
11 # Conditional build:
12 %bcond_without  static_sqlite   # with static sqlite3
13 %bcond_with     static_projectm # with static projectM
14 %bcond_with     libspotify      # build with system libspotify instead of downloading blob
15
16 %define         qtver   %(pkg-config --silence-errors --modversion QtCore 2>/dev/null || echo ERROR)
17 Summary:        A music player and library organiser
18 Summary(hu.UTF-8):      Egy zenelejátszó és gyűjtemény-kezelő
19 Name:           clementine
20 Version:        1.1.1
21 Release:        6
22 License:        GPL v3 and GPL v2+
23 Group:          Applications/Multimedia
24 URL:            http://www.clementine-player.org/
25 Source0:        http://clementine-player.googlecode.com/files/%{name}-%{version}.tar.gz
26 # Source0-md5:  28e4afb822388bd337a761db8f86febf
27 Patch0:         desktop-install.patch
28 Patch1:         unbundle-po.patch
29 Patch2:         %{name}-1.1.1-libimobiledevice-fix.patch
30 Patch3:         %{name}-dt_categories.patch
31 BuildRequires:  QtCore-devel >= %{qtver}
32 BuildRequires:  QtDBus-devel >= %{qtver}
33 BuildRequires:  QtGui-devel >= %{qtver}
34 BuildRequires:  QtIOCompressor-devel
35 BuildRequires:  QtNetwork-devel >= %{qtver}
36 BuildRequires:  QtOpenGL-devel >= %{qtver}
37 BuildRequires:  QtSingleApplication-devel >= 2.6-4
38 BuildRequires:  QtSql-devel >= %{qtver}
39 %{?with_tests:BuildRequires:    QtTest-devel >= %{qtver}}
40 BuildRequires:  QtXml-devel >= %{qtver}
41 BuildRequires:  QtXmlPatterns-devel >= %{qtver}
42 BuildRequires:  boost-devel
43 BuildRequires:  cmake >= 2.6
44 #%{?with_static_projectm:BuildRequires: ftgl-devel >= 2.1.3}
45 BuildRequires:  gettext-devel
46 %{?with_static_projectm:BuildRequires:  glew-devel}
47 BuildRequires:  glib2-devel
48 BuildRequires:  gstreamer0.10-devel
49 BuildRequires:  gstreamer0.10-plugins-base-devel
50 BuildRequires:  gtest-devel
51 BuildRequires:  libcdio-devel
52 BuildRequires:  libchromaprint-devel
53 BuildRequires:  libgpod-devel >= 0.7.92
54 BuildRequires:  libimobiledevice-devel >= 1.1.5
55 BuildRequires:  libindicate-qt-devel
56 BuildRequires:  liblastfm-devel >= 0.3.3
57 BuildRequires:  libmtp-devel
58 BuildRequires:  libplist-devel
59 %{!?with_static_projectm:BuildRequires: libprojectM-devel >= 1:2.0.1-4}
60 BuildRequires:  libqxt-devel
61 %{?with_libspotify:BuildRequires:       libspotify-devel >= 12.1.45}
62 BuildRequires:  libxml2-devel
63 BuildRequires:  pkgconfig
64 BuildRequires:  pkgconfig
65 BuildRequires:  protobuf-devel
66 BuildRequires:  qca-devel
67 BuildRequires:  qjson-devel
68 BuildRequires:  qt4-build >= %{qtver}
69 BuildRequires:  qt4-linguist
70 BuildRequires:  qt4-qmake
71 BuildRequires:  rpmbuild(find_lang) >= 1.33
72 BuildRequires:  rpmbuild(macros) >= 1.596
73 BuildRequires:  sed >= 4.0
74 %{!?with_static_sqlite:BuildRequires:   sqlite3-devel}
75 BuildRequires:  taglib-devel >= 1.6
76 BuildRequires:  usbmuxd-devel
77 Requires(post,postun):  desktop-file-utils
78 Requires(post,postun):  gtk-update-icon-cache
79 Requires(post,postun):  hicolor-icon-theme
80 Requires:       QtSingleApplication >= 2.6-4
81 %{!?with_static_sqlite:Requires:        QtSql-sqlite3 >= %{qtver}}
82 Requires:       gstreamer0.10-audio-effects-base
83 Requires:       gstreamer0.10-mad
84 # while we do not link (yet), we use datafiles
85 Requires:       libprojectM
86 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
87
88 # see libprojectM.spec for explanation
89 %define         filterout_ld    -Wl,--as-needed -Wl,--no-copy-dt-needed-entries
90
91 %description
92 Clementine is a modern music player and library organiser. It is
93 largely a port of Amarok 1.4, with some features rewritten to take
94 advantage of Qt4.
95
96 %description -l hu.UTF-8
97 Clementine egy modern zenelejátszó és gyűjtemény kezelő. Túlnyomórészt
98 az Amarok 1.4 port-ja, néhány funkciója újraírva, hogy kihasználhassa
99 a Qt4 előnyeit.
100
101 %prep
102 %setup -q
103 %patch0 -p1
104 %patch1 -p1
105 %patch2 -p1
106 %patch3 -p1
107
108 # We already don't use these but just to make sure
109 rm -rf 3rdparty/gmock
110 %{!?with_static_sqlite:rm -rf 3rdparty/qsqlite}
111 rm -rf 3rdparty/qtsingleapplication
112 rm -rf 3rdparty/qxt
113 rm -rf 3rdparty/qtiocompressor
114 %{!?with_static_projectm:rm -rf 3rdparty/libprojectM}
115
116 # Don't build tests. They require gmock
117 sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
118 # remove -Wall
119 sed -i -e 's/-Wall//' src/CMakeLists.txt
120 # ...and -Werror
121 sed -i -e 's/-Werror//' src/CMakeLists.txt
122
123 %build
124 install -d build
125 install -d build/src/translations
126 cd build
127 # as our buildtype is not Release, need to pass these manually. see CMakeLists.txt ~125
128 CXXFLAGS="%{rpmcxxflags} -DNDEBUG -DQT_NO_DEBUG_OUTPUT"
129 %cmake \
130         -DBUNDLE_PROJECTM_PRESETS=OFF \
131         -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
132         -DQTSINGLEAPPLICATION_INCLUDE_DIRS=%{_includedir}/qt4/QtSolutions/ \
133         -DUSE_SYSTEM_QXT=ON \
134         -DUSE_SYSTEM_PROJECTM=ON \
135         -DSTATIC_SQLITE=%{?with_static_sqlite:ON}%{!?with_static_sqlite:OFF} \
136         ..
137 %{__make}
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 %{__make} -C build install \
142         DESTDIR=$RPM_BUILD_ROOT
143
144 rm $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/application-x-clementine.svg
145
146 # not in our glibc?
147 rm -r $RPM_BUILD_ROOT%{_localedir}/tr_TR
148
149 %find_lang %{name} --with-qm
150
151 install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps
152 cp -a dist/icons/ubuntu-mono-light/clementine-panel-grey.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel-grey.png
153 cp -a dist/icons/ubuntu-mono-light/clementine-panel.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/clementine-panel.png
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %post
159 %update_desktop_database_post
160 %update_icon_cache hicolor
161
162 %postun
163 %update_desktop_database_postun
164 %update_icon_cache hicolor
165
166 %files -f %{name}.lang
167 %defattr(644,root,root,755)
168 %doc Changelog
169 %attr(755,root,root) %{_bindir}/clementine
170 %attr(755,root,root) %{_bindir}/clementine-tagreader
171 %{_desktopdir}/clementine.desktop
172 %{_pixmapsdir}/clementine.png
173 %{_iconsdir}/hicolor/*/apps/clementine-panel-grey.png
174 %{_iconsdir}/hicolor/*/apps/clementine-panel.png
This page took 0.053262 seconds and 4 git commands to generate.